Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox cannot open profile

  • 2 svar
  • 0 har dette problem
  • 157 visninger
  • Seneste svar af Wayne Knight

more options

After upgrading Ubuntu from 18.04 to 22.04, I attempted to import my old profile data into the new version of Firefox (118.0.2). All attempts following the instructions at [https://support.mozilla.org/en-US/kb/recover-user-data-missing-after-fire...] failed.

Following the instructions at [https://support.mozilla.org/en-US/kb/how-run-firefox-when-profile-missing...], I deleted the profile.ini file.

Since then, Firefox does not open. I still get the message "Your Firefox profile cannot be loaded. It may be missing or inaccessible." The only option is to press the OK button at which point, FIrefox closes.

There is no current information in the crash logs and I can't find any error logs.

After upgrading Ubuntu from 18.04 to 22.04, I attempted to import my old profile data into the new version of Firefox (118.0.2). All attempts following the instructions at [[https://support.mozilla.org/en-US/kb/recover-user-data-missing-after-firefox-update]] failed. Following the instructions at [[https://support.mozilla.org/en-US/kb/how-run-firefox-when-profile-missing-inaccessible#w_profile-was-deleted]], I deleted the profile.ini file. Since then, Firefox does not open. I still get the message "Your Firefox profile cannot be loaded. It may be missing or inaccessible." The only option is to press the OK button at which point, FIrefox closes. There is no current information in the crash logs and I can't find any error logs.

Valgt løsning

This approach worked for me in Ubuntu 22.04:

  • First, before upgrading, make sure that Firefox has been updated to the latest version.
  • Copy profile folder (.../firefox/xxxx.default) to an external drive
  • Upgrade system - Do not launch Firefox, it must be closed.
  • Copy the old profile folder from the external drive to the desktop
  • Go to /myfiles/snap/firefox/common/.mozilla/firefox
  • Rename profiles.ini to profiles.oldini and copy to profiles.ini

WARNING: profile folders will have filenames like 031u5p1l.default. Do not mess with the first part.

  • Rename xxxx.default to xxxx.olddefault (this is the new profiles folder created by the Ubuntu upgrade)
  • Copy the old profile folder from desktop to this folder
  • If the profile foldername is xxxx.defaultsomethingelse, change it to xxxx.default. Otherwise leave it alone
  • Edit the profiles.ini file and change the path=xxxx.default
  • Save the profile.ini file
  • Launch Firefox and hopefully it will work for you too.
Læs dette svar i sammenhæng 👍 0

Alle svar (2)

more options

Amendment: I renamed the file profile.ini in the home/snap/firefox/common/.mozilla/firefox folder and now Firefox opens, but I still haven't figured out how to import my old profile data which I copied over to my desktop.

PS I have no idea why there is a similar file in the folder /home/.mozilla./firefox.

Ændret af Wayne Knight den

more options

Valgt løsning

This approach worked for me in Ubuntu 22.04:

  • First, before upgrading, make sure that Firefox has been updated to the latest version.
  • Copy profile folder (.../firefox/xxxx.default) to an external drive
  • Upgrade system - Do not launch Firefox, it must be closed.
  • Copy the old profile folder from the external drive to the desktop
  • Go to /myfiles/snap/firefox/common/.mozilla/firefox
  • Rename profiles.ini to profiles.oldini and copy to profiles.ini

WARNING: profile folders will have filenames like 031u5p1l.default. Do not mess with the first part.

  • Rename xxxx.default to xxxx.olddefault (this is the new profiles folder created by the Ubuntu upgrade)
  • Copy the old profile folder from desktop to this folder
  • If the profile foldername is xxxx.defaultsomethingelse, change it to xxxx.default. Otherwise leave it alone
  • Edit the profiles.ini file and change the path=xxxx.default
  • Save the profile.ini file
  • Launch Firefox and hopefully it will work for you too.