Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Place / configure TB 115's main window's menu bar ABOVE the button toolbar

  • 39 svar
  • 62 har dette problem
  • 3002 visninger
  • Seneste svar af Rohan Sharma

more options

Hi, In TB 102 the menu toolbar was still above the button toolbar, if I am not mistaken. In TB 115 this seems to have changed... I could not find a way to customize it back as it was. Pointers anyone ? Thank you.

Hi, In TB 102 the menu toolbar was still above the button toolbar, if I am not mistaken. In TB 115 this seems to have changed... I could not find a way to customize it back as it was. Pointers anyone ? Thank you.

Valgt løsning

click help>troubleshootinginformation and scroll down to 'profile folder' and click 'open folder' and you'll be there. create a folder named 'chrome' and inside that folder create a simple txt file called userChrome.css and place the above CSS there. Be sure the file isn't accidentally called userChrome.css.txt

Læs dette svar i sammenhæng 👍 19

Alle svar (20)

more options

- click settings>general and scrollodown to config editor - search for toolkit.legacyUserProfileCustomizations.stylesheets and change to true - then you need the chrome folder in profile, and a userChrome.css file in the folder (with content shown below). - exit and restart TB and it should work, although I've sometimes found I have to restart TB twice to see changes in userChrome.css - Below is content for userChrome.css

/*  #######    */
@namespace html url("http://www.w3.org/1999/xhtml");

#toolbar-menubar {
  order: 1;             
}

unified-toolbar {
  order: 2;             
}

#tabs-toolbar {
  order: 3;              
}

more options

@david Great answer, thank you. I expedited the toolkit.legacyUserProfileCustomizations.stylesheets change from False to True. However as I have no "Chrome directory in my profile, could you walk me through its creation, by providing just a FQN for that directory ? Thank you again.

more options

Valgt løsning

click help>troubleshootinginformation and scroll down to 'profile folder' and click 'open folder' and you'll be there. create a folder named 'chrome' and inside that folder create a simple txt file called userChrome.css and place the above CSS there. Be sure the file isn't accidentally called userChrome.css.txt

more options

Thanks @david: it worked on the first restart of TB. Perfect.

more options

You're welcome. :)

more options

It’s a pity this wasn’t made easy.

A user from the beginning, I feel like Thunderbird is losing its way with a messy, cluttered and incoherent interface. Sidebar, toolbar, tab-bar, buttons to open tabs, buttons on toolbar for a new message as well as a big button for a new message in the folder list.

more options

Hi, This seems not to work for Thunderbird under Linux. I still seem to be unable to have any change in the order the menus are displayed.

Located the profile via the 'help>troubleshootinginformation' way. That folder appeared to be just ~/.thunderbird. I created the chrome folder and used vim to create userChrome.css. I am puzzled however about the '#' in the syntax below. Tried several ways to add an '#' just removed them all. But no change. Is it correct that 'unified-toolbar' has no starting '#' as the other items do have an '#'?

  1. toolbar-menubar {
 order: 1;             

} unified-toolbar {

 order: 2;             

}

  1. tabs-toolbar {
 order: 3;              

}

Regards, Bert.

more options

Fixed it! Do not use 'profile directory' but move down to 'about profiles'. Choose the root directory of the profile in use and create the chrome directory in there. Leave all '#' out.

toolbar-menubar {

  order: 1; 

} unified-toolbar {

  order: 2; 

} tabs-toolbar {

  order: 3; 

}

Thanks! Bert.

more options

It does work for me in Linux using the profile directory. Probably you can use both — I’d guess the root applies to all profiles.

Re commenting (#), if the unified toolbar is visible it shows tabs so you don’t really need the tabs-toobar option.

more options

Hi Moilleadóir, Thank you, I will change that although it sometimes looks like the ordering of the menus is just random. But you might know how to alter the way the unread messages are displayed too. In the previous version this was just a number between (). It is way too present now. It gets all your attention while it is basically just information of low importance. I would like to just remove it altogether or have it displayed as before. It might be good enough if the black background disappears and the number would be in grey. Regards, Bert.

more options

david said

- click settings>general and scrollodown to config editor - search for toolkit.legacyUserProfileCustomizations.stylesheets and change to true - then you need the chrome folder in profile, and a userChrome.css file in the folder (with content shown below). - exit and restart TB and it should work, although I've sometimes found I have to restart TB twice to see changes in userChrome.css - Below is content for userChrome.css
/*  #######    */
@namespace html url("http://www.w3.org/1999/xhtml");

#toolbar-menubar {
  order: 1;             
}

unified-toolbar {
  order: 2;             
}

#tabs-toolbar {
  order: 3;              
}

Good evening, Thanks for the tip, I had the same problem and was able to get my toolbars back in order. I didn't know about this easy trick. Thanks again

more options

This took me a couple tries because the first time I forgot to enable toolkit.legacyUserProfileCustomizations.stylesheets and fell into the trap of accidentally naming my file userChrome.css.txt but re-reading your directions helped me find both mistakes. Thanks for the help.

more options

You're welcome. I'm glad it works.

more options

It worked, but this is totally unacceptable. I am somewhat computer literate and it was a challenge trying to figure out what to do. I'll bet 90% of the users have no clue what to do even with your help.

more options

rlee91 a écrit

It worked, but this is totally unacceptable. I am somewhat computer literate and it was a challenge trying to figure out what to do. I'll bet 90% of the users have no clue what to do even with your help.

You are exaggerating there, the longest part of the manipulation is to find the folder and create the file. Even without mastering the language used, I immediately understood that we could place the three paragraphs of the text in the order we wanted. And as for the extension and since the goal is to create a css file, removing the '.txt' is obvious. So this manipulation is quite useful and easy to implement.

more options

I added an entry for the single message window (which also used to display the menu underneath the toolbar), and also made sure my Add-on QuickFolders is at the bottom, so here is my version:


| #toolbar-menubar { order: 1; } | #tabs-toolbar { order: 2; } | unified-toolbar, #mail-bar3 { order: 3; } | #QuickFolders-Toolbar { order: 4; }


(sorry for the extra | somehow the markdown here doesn't allow me using ``` for code) I have added a screenshot of the css

more options

I have tried this numerous times. Changed settings to True, in profile created a folder chrome (all lower case) and copied the code into a file called userChrome.css. Restarted numerous times with no change.

Update- figured it out. I didn't realized I had file extensions hidden. Once I showed file extensions, I saw it was userChrome.css.txt. Removed the txt and all works now.

Ændret af Steve M den

more options

Steve M said

I have tried this numerous times. Changed settings to True, in profile created a folder chrome (all lower case) and copied the code into a file called userChrome.css. Restarted numerous times with no change.

Also you need to go to General Settings, scroll down, click [Config Editor...]

then find the entry

toolkit.legacyUserProfileCustomizations.stylesheets

and set it to true.

more options

Thanks for the reply, but as I stated I did have it set to true. I edited my post with the update. I didn't realize I had extensions hidden, so once I changed it from a txt to css, all works.

more options

Steve M said

Thanks for the reply, but as I stated I did have it set to true. I edited my post with the update. I didn't realize I had extensions hidden, so once I changed it from a txt to css, all works.

alright - always the first thing I change after installing windows. No point in being kept in the dark about what a file / application / virus might be, even if Microsoft wants to keep us dumb about this.

  1. 1
  2. 2