Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to remove the new toolbar in version 115?

  • 16 svar
  • 49 har dette problem
  • 890 visninger
  • Seneste svar af y70fomn3ie9

more options

Hello,

The new UI has this massive customizable toolbar at the top of the screen, it wastes a lot of space and doesn't look good compared to the old UI, you can fully customize it even leaving it blank but that does not remove it entirely and it looks off with just a blank nothing up there, where is the option to completely remove this new toolbar?

Regards,

Hello, The new UI has this massive customizable toolbar at the top of the screen, it wastes a lot of space and doesn't look good compared to the old UI, you can fully customize it even leaving it blank but that does not remove it entirely and it looks off with just a blank nothing up there, where is the option to completely remove this new toolbar? Regards,
Vedhæftede skærmbilleder

Ændret af Wayne Mery den

Valgt løsning

Currently there is not.

Did you not use the old toolbar in version 102?

Læs dette svar i sammenhæng 👍 0

Alle svar (16)

more options

Valgt løsning

Currently there is not.

Did you not use the old toolbar in version 102?

more options

I used it more because everything was on one line, now it's split in 3 lines, and making the top part of the client a lot more confusing and messy. And now I realize this looks a lot more like the way outlook does it, so maybe that was the inspiration. Hope we get the option to remove it one day.

more options

I can assure you outlook is not the inspiration.

My toolbar is roughly one character in height, so I don't understand what you mean "split in 3 lines".

Can you post a screen shot, or explain in more detail so we understand what you mean?

more options

Everything used to be on one clean line like you can see in my first screenshot, Writing a message, search bar, quick filters, all one clean line. Now New Message and Get messages is on their own part (the folder pane), quick filter is on its own bar as well, and the search bar is up there. And with the new toolbar taking the space up now tabs don't go all the way up, like seen in this screen shot I'm sending. (you can check the first screenshot for comparison)

more options

After fiddling a bit I think the easiest way to "fix" this would be to have an option to have tabs above the toolbar, right now I'm seeing the toolbar as an obstacle but being able to put it below everything, maybe making it a bit thinner, would make it blend nicely.

more options

I think you can do everything you want:

  • View > Folder > uncheck folder pane header
  • Customaize to add the buttons you want to the toolbar
  • View > toolbars > uncheck menu bar
more options

Right clicking on toolbars usually has an option to disable the toolbar. However, the Unified Toolbar has the option to disable the Menu Bar instead of itself.

The issue of the Unified Toolbar taking up ~3 lines could be caused by the fix https://phabricator.services.mozilla..../D180418 for the bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1837594. The fix sets the minimum height of the Unified Toolbar when empty.

Maybe in a future Thunderbird release we could have an option to hide and unhide the Unified Toolbar. The feature could be similar to the Spaces Toolbar and perhaps pressing Ctrl + K (to bring up the search) could toggle it too.


Hiding the Unified Toolbar: You can hide the Unified Toolbar using 'userChrome.css' and setting unifiedToolbar visibilty to collapse. Note that the older way of using "display: none" does not work.

Enable Legacy User Profile Customizations

  • Open the Config Editor: E.g. Tools -> Settings ->Search "config" -> Select "Config Editor..."
  • In "Search preference name", enter "toolkit.legacyUserProfileCustomizations.stylesheets"
  • Set the value to true (default false)

Setup userChrome.css

  • Go to your Thunderbird profile directory, e.g. ~/.thunderbird/xxxxxxxx.default
  • Create the chrome directory (if it doesn't exist), e.g. mkdir chrome
  • Go into the chrome directory, e.g. cd chrome
  • Create the userChrome.css file (if it doesn't exist), e.g. touch userChrome.css
  • Edit the file, e.g. nano userChrome.css
  • Paste the following into the userChrome.css file:
    #unifiedToolbar {
      visibility: collapse;
    }
    

You will need to restart Thunderbird after updating userChrome.css. Once restarted, Thunderbird 115 should no longer show the Unified Toolbar.

more options
more options

I just updated to 115, and the devs have to be kidding me. After removing all the clutter from the universal toolbar, as @chugg7 wrote, there now is a useless space that I do not want, taking up 5 % of my window height for ... nothing? See screenshot.

I am used to TB taking controversial decisions, but this is a real bummer.

I am going to try @ jschroed57's CSS solution now.

Ændret af flberger den

more options

jschroed57 said

... Hiding the Unified Toolbar: You can hide the Unified Toolbar using 'userChrome.css' and setting unifiedToolbar visibilty to collapse. Note that the older way of using "display: none" does not work. Enable Legacy User Profile Customizations
  • Open the Config Editor: E.g. Tools -> Settings ->Search "config" -> Select "Config Editor..."
  • In "Search preference name", enter "toolkit.legacyUserProfileCustomizations.stylesheets"
  • Set the value to true (default false)
Setup userChrome.css
  • Go to your Thunderbird profile directory, e.g. ~/.thunderbird/xxxxxxxx.default
  • Create the chrome directory (if it doesn't exist), e.g. mkdir chrome
  • Go into the chrome directory, e.g. cd chrome
  • Create the userChrome.css file (if it doesn't exist), e.g. touch userChrome.css
  • Edit the file, e.g. nano userChrome.css
  • Paste the following into the userChrome.css file:
    #unifiedToolbar {
      visibility: collapse;
    }
    
You will need to restart Thunderbird after updating userChrome.css. Once restarted, Thunderbird 115 should no longer show the Unified Toolbar.

I can confirm that this solves it for me, I have added a before and after images. In the same way as other reporters I initially could not understand the new bar at the top so I thought about reporting it but found this thread already.

more options

jschroed57 said

Note that the older way of using "display: none" does not work.

FYI, it's working for me in 115.3.0 - you accidentally left a # in your css, so it's trying to hide the wrong thing.  :)

more options

This new UI is so bad that I am even spending time writing a response here. No, not to add to the complaints, but to give back to the people who posted here since the workaround above got me started finding an even better workaround.

The problem with simply hiding the unified toolbar via CSS is that it also hides the popup windows that Thunderbird would display when installing a new extension. So effectively that workaround makes it impossible to install new extensions.

A better way is to move the toolbar out of sight by giving it a negative margin... at least almost, a 1 pixel high toolbar remains. Worse though, as soon as tabs are opened the original-size toolbar content is rendered underneath the tabs. Luckily, the content has its own ID and we can hide it without impacting popup windows.

So this solution worked well for me:

#unifiedToolbar {
  margin: -32px;
}
#unifiedToolbarContent {
  display: none !important;
}

Ændret af Michael Mamer den

more options

Wayne Mery said

I think you can do everything you want:
  • View > Folder > uncheck folder pane header
  • Customaize to add the buttons you want to the toolbar
  • View > toolbars > uncheck menu bar

That does not work, because the “View” menu has no option to hide the new toolbar. The solution by lapeqmack works perfectly though.

more options

This gave me the look I wanted:

   #unifiedToolbar {
     margin: -32px;
   }
   #unifiedToolbarContent {
     display: none !important;
   }
   .titlebar-buttonbox-container {
     display: none;
   }

Ændret af Roberto von Schoettler den

more options

Thanks for these suggestions- if I use the text below:

#unifiedToolbar {
    margin: -32px;
  }
  #unifiedToolbarContent {
    display: none !important;
  }

I lose the toolbar but still get a blank bar with the standard minimise/ restore/ close buttons in the top right.

If I add in the extra line as suggested by Roberto von Schoettler I lose the top bar but all the buttons as well.

  #unifiedToolbar {
    margin: -32px;
  }
  #unifiedToolbarContent {
    display: none !important;
  }
  .titlebar-buttonbox-container {
    display: none;
  }

Is there any way to bring the buttons onto the tab bar below? Thanks!

more options

Figured it out- the code below works. However with all of these options there is a 'gap' at the top of the screen of a few pixels so the open tabs can't be reached by moving the mouse to the top of the screen. The buttons work fine though

  1. unifiedToolbar {

margin: -32px; }

  1. unifiedToolbarContent {

display: none !important; } .titlebar-buttonbox-container { position: fixed; top: 0px; right: 0px; z-index: 99999; }

Ændret af y70fomn3ie9 den