Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Videos won't play

  • 1 svar
  • 1 har dette problem
  • 20 visninger
  • Seneste svar af FredMcD

more options

I can watch videos on news9.com using Microsoft Edge with no problem. When I use Firefox the videos will load but will never play. This seems to be the only site I am having trouble with. I just purchased this new Windows 11 computer so I haven't checked everything yet. I ran the Video Playback Troubleshooter and it says to install the HEVC Codec for 4K playback which I have to pay for but why would that be the problem if the videos play in Microsoft Edge?

I can watch videos on news9.com using Microsoft Edge with no problem. When I use Firefox the videos will load but will never play. This seems to be the only site I am having trouble with. I just purchased this new Windows 11 computer so I haven't checked everything yet. I ran the Video Playback Troubleshooter and it says to install the HEVC Codec for 4K playback which I have to pay for but why would that be the problem if the videos play in Microsoft Edge?

Alle svar (1)

more options

I have several versions of Firefox and had no problem.


https://support.mozilla.org/en-US/kb/update-firefox-latest-version?cache=no Did you update Firefox to the latest version?

Version 96.0, first offered to Release channel users on January 11, 2022 Version 96.0.1, first offered to Release channel users on January 14, 2022 Version 96.0.3, first offered to Release channel users on January 27, 2022


https://support.mozilla.org/en-US/questions/1359657#answer-1463359 and updated to 95.0. . . . I finally found where the plugin "Widevine Content Decryption Module provided by Google Inc." was not updating to the newest version of December 1, 2021. Ver #4.10.2391.0

cor-el; Make sure you have the latest Widevine version. You can toggle DRM off/on to see if that makes Firefox (re)load DRM components.

You can possibly check the XHR requests in the Browser Console if this doesn't work.