X
Pritisnite ovdje da biste otišli na mobilnu verziju stranice.

Forum podrške

Manually updating add-ons

Objavljeno

Firefox says at https://support.mozilla.org/en-US/kb/how-update-add-ons, "Check for Updates: Allows you to check for any updates to your add-ons manually. If there is an update available, you have the option to choose to update it now or later." I don't see that option. I can install all updates now or not. How can I install selectively? And (since Firefox does not seem to reveal the versions of the add-ons I'm using), how can I be sure whether a particular add-on I'm using is already up-to-date?

Firefox says at https://support.mozilla.org/en-US/kb/how-update-add-ons, "Check for Updates: Allows you to check for any updates to your add-ons manually. If there is an update available, you have the option to choose to update it now or later." I don't see that option. I can install all updates now or not. How can I install selectively? And (since Firefox does not seem to reveal the versions of the add-ons I'm using), how can I be sure whether a particular add-on I'm using is already up-to-date?
Citiraj

Dodatni detalji o sistemu

Instalirani priključci

  • Shockwave Flash 32.0 r0

Aplikacija

  • Korisnički agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:69.0) Gecko/20100101 Firefox/69.0

Više informacija

WMagicModel
  • Top 25 Contributor
  • Administrator
6 rješenja 120 odgovora
Objavljeno

Hi Odin3,

There is an option to check for updates if you configured Firefox to never check for updates for extensions automatically.

  • in about:addons under each extension, if you click on the "More Options" you will get a detailed list of the extension followed by an option to turn off "Allow automatic updates" for that individual extension as well as the Version and Last Updated.

You can also browse extension manually to see the version history as well the ability to revert to later versions.

  1. Search your extension on the top-right of your browser Firefox Add-ons {link}
  2. Scroll down to the "More Information"
  3. Select the "see all versions"
Hi Odin3, There is an option to check for updates if you configured Firefox to never check for updates for extensions automatically. * in '''about:addons''' under each extension, if you click on the "'''More Options'''" you will get a detailed list of the extension followed by an option to turn off "Allow automatic updates" for that individual extension as well as the '''Version '''and Last '''Updated'''. You can also browse extension manually to see the version history as well the ability to revert to later versions. # Search your extension on the top-right of your browser [https://addons.mozilla.org/en-US/firefox/search/?platform=WINNT Firefox Add-ons] {link} # Scroll down to the "'''More Information'''" # Select the "'''see all versions'''"

Izmjenjeno od strane WMagicModel

Je li vam ovo pomoglo?
Citiraj
cor-el
  • Top 10 Contributor
  • Moderator
17424 rješenja 157452 odgovora
Objavljeno

You can click an extension on the about:addons page to check how it is updated.

  • Allow automatic updates : [x] Default; [] On; [] Off;
You can click an extension on the about:addons page to check how it is updated. *Allow automatic updates : [x] Default; [] On; [] Off;
Je li vam ovo pomoglo?
Citiraj

Vlasnik pitanja

Thanks, both. WMagicModel, you seem to be saying that If I want to update a particular add-on (only), I must enable automatic updating and take pains to exclude all those except the one I want to update. Is that correct? If so, it's a terrible system.

Thanks, both. WMagicModel, you seem to be saying that If I want to update a particular add-on (only), I must enable automatic updating and take pains to exclude all those except the one I want to update. Is that correct? If so, it's a terrible system.
Je li vam ovo pomoglo?
Citiraj
jscher2000
  • Top 10 Contributor
8643 rješenja 70721 odgovora
Objavljeno

Korisan odgovor

Hi Odin3, for many years I have used the same setting and unless something changed in Firefox 69, it might be what you are looking for.

(1) Set the default for extension auto-updates to false

(A) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(B) In the search box above the list, type or paste autoup and pause while the list is filtered

(C) Double-click the extensions.update.autoUpdateDefault preference to switch the value from true to false

(2) From time to time, check the left column of the Add-ons page for a new "Available Updates" category

That is where you can find a list of extensions that have an update, check the release notes for each one, and choose to update them individually, or not.

Hi Odin3, for many years I have used the same setting and unless something changed in Firefox 69, it might be what you are looking for. '''(1) Set the default for extension auto-updates to false''' (A) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button accepting the risk. (B) In the search box above the list, type or paste '''autoup''' and pause while the list is filtered (C) Double-click the '''extensions.update.autoUpdateDefault''' preference to switch the value from true to false '''(2) From time to time, check the left column of the Add-ons page for a new "Available Updates" category''' That is where you can find a list of extensions that have an update, check the release notes for each one, and choose to update them individually, or not.
Je li vam ovo pomoglo? 2
Citiraj
cor-el
  • Top 10 Contributor
  • Moderator
17424 rješenja 157452 odgovora
Objavljeno

Note that you can toggle extensions.update.autoUpdateDefault more easily via the cogwheel menu on the about:addons page: Update Add-Ons Automatically

Note that you can toggle extensions.update.autoUpdateDefault more easily via the cogwheel menu on the about:addons page: Update Add-Ons Automatically
Je li vam ovo pomoglo?
Citiraj

Vlasnik pitanja

Jscher, I must have overlooked the option to update an add-on individually (which I see now). Thanks for the tip.

Jscher, I must have overlooked the option to update an add-on individually (which I see now). Thanks for the tip.

Izmjenjeno od strane Odin3

Je li vam ovo pomoglo?
Citiraj
AZBruno 1 rješenja 15 odgovora
Objavljeno

I am having the same problem.

I am running FF 69.0 and automatic updating of add-ons is set to False.

I have a list of Available Updates, but I cannot find any UI element to allow me to update add-ons, either individually or all together.

@Odin3, where did you find it that you overlooked before?

EDIT: OK, I found it. I thought I'd clicked on the 3 dots, but apparently I missed. Oddly, when I selected to update, it seemed like nothing happened. The little update dot disappeared but the number of available updates did not decrease. I did this for 3 of the 13 available updates. Since nothing happened, I thought maybe I need to restart FF. On restart it still told me there were 13 updates, but when I went to the page to view the updates it was blank. I restarted FF again and this time it worked almost as expected... as soon as I selected Update it did so and the number of available updates decreased. I had to refresh the page to get the add-on to not be shown any more. Apparently there is no longer an Update All option.

I am having the same problem. I am running FF 69.0 and automatic updating of add-ons is set to False. I have a list of Available Updates, but I cannot find any UI element to allow me to update add-ons, either individually or all together. @Odin3, where did you find it that you overlooked before? EDIT: OK, I found it. I thought I'd clicked on the 3 dots, but apparently I missed. Oddly, when I selected to update, it seemed like nothing happened. The little update dot disappeared but the number of available updates did not decrease. I did this for 3 of the 13 available updates. Since nothing happened, I thought maybe I need to restart FF. On restart it still told me there were 13 updates, but when I went to the page to view the updates it was blank. I restarted FF again and this time it worked almost as expected... as soon as I selected Update it did so and the number of available updates decreased. I had to refresh the page to get the add-on to not be shown any more. Apparently there is no longer an Update All option.

Izmjenjeno od strane AZBruno

Je li vam ovo pomoglo?
Citiraj
jscher2000
  • Top 10 Contributor
8643 rješenja 70721 odgovora
Objavljeno

Hi AZBruno, could you look at the attached screenshot composite.

Hi AZBruno, could you look at the attached screenshot composite.
Je li vam ovo pomoglo?
Citiraj
Postavite pitanje

Morate se prijaviti na račun da biste odgovarali na poruke. Molimo postavite novo pitanje, ako još uvijek nemate račun.