Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why won't my credit card statement PFDs open on the chase.com website? They used to open, but now they neither open nor download.

  • 11 odgovori
  • 2 ima ovaj problem
  • 2 views
  • Posljednji odgovor poslao BeeFree46

more options

I have downloaded my Chase credit card statement PDF for many years, using Firefox. Suddenly, when I click on the document icon next to the statement date, nothing happens. I called Chase, and they were really rude! They said it can't possibly be their fault and would not help me, other than to tell me to get a different browser! I downloaded Opera, and sure enough, Opera downloads my statement (to the Downloads folder) when I click the document icon. Even Opera won't OPEN the PDF, which makes me suspect Chase has changed its website. But knowing that doesn't help with the Firefox problem--it just makes me use Opera to get the darn statement. Any idea what is going on?

I have downloaded my Chase credit card statement PDF for many years, using Firefox. Suddenly, when I click on the document icon next to the statement date, nothing happens. I called Chase, and they were really rude! They said it can't possibly be their fault and would not help me, other than to tell me to get a different browser! I downloaded Opera, and sure enough, Opera downloads my statement (to the Downloads folder) when I click the document icon. Even Opera won't OPEN the PDF, which makes me suspect Chase has changed its website. But knowing that doesn't help with the Firefox problem--it just makes me use Opera to get the darn statement. Any idea what is going on?

All Replies (11)

more options

Hi, try deleting ALL references to the Chase website. To do that, open the 3-bar menu, choose History (looks like a clock), then click the Show All History link at the bottom of the list to open the Library window. Search for the website you want to clear by typing its name in the Search History field in the top-right corner, then press Enter. Now in the search results, right-click on the site you want to remove, and select Forget About This Site. (Browsing and download history, cookies, cache, active logins, passwords, saved form data, exceptions for cookies, images and pop-ups for that site will be removed). Give it a minute to complete the deletion then try the site (not from an old bookmark) again. More - Delete browsing, search and download history on Firefox.


If that doesn't help, check your default PDF settings -


You could also try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu, click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem. Thank you!

more options

Wow! Thanks for this wonderful tutorial! Unfortunately, my problem didn't go away. (1) Delete History: There were no references to the Chase website in my History. Perhaps this is due to my having recently cleared All History at the direction of Verizon Fios Tech Support to cure a problem using their site. But the Chase problem came AFTER the Verizon issue anyway. (2) Default PDF setting: It was set to Always Ask (but for the Chase site, it was no longer asking). I changed it to Use Adobe Acrobat 9.5, which I have on my computer and which was happily opening Chase statements before the problem (I don't even have the Reader since I have full Acrobat). But that didn't help with the Chase site. (3) Safe Mode: tried this, but it did not help at the Chase site, so I'm back in regular mode. (4) Plugins, etc: The only Plugin it looked at was Flash, and that one is up to date. It ignored Open H264 Codec and Wildvine Content Decryption Module. Those are my only plug-ins. (5) Stop using hardware acceleration: I UnChecked the option to use hardware acceleration if available, but that did not help.

The only thing I didn't look at was Extensions (I am using the Default Theme). I don't want to mess with extensions in case I break something else that I rely upon using.

So I still think Chase did something to its website. They've been "upgrading" it for months. None of the upgrades is very useful IMHO; all of them make the screens more confusing than ever to find stuff I want to use. FYI, if I right click on the useless Document Icon next to Statements, I DON'T get "Open" as a choice. All I get are: Bookmark This Link, Copy Link Location, Search Google for 'save statement', and Inspect Element.

I am not willing to put Firefox back into its "original" state, undoing the various choices I have made over the years about Options, especially the Saved Logins feature. The only add-on I have Enabled is Password Exporter. So I guess I am resigned to using Opera to get my Chase statement. Every few months I'll check to see if Chase fixed the problem on their end.

Thank you again for your detailed tutorial on troubleshooting my issue!

more options

What do you get instead of the expected PDF? Nothing happens? Blank page?

Some users have reported blank pages and other problems navigating on banking sites if the optional redirect block is enabled. You can check for and unblock here:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences

In the left column, click Advanced. Then on the right side, with the "General" mini-tab active, make sure the following is not selected (box is not checked): "Warn me when websites try to redirect or reload the page"

more options

I looked at this immediately. But this option is already unchecked. None the less, thank you for this suggestion.

more options

You mentioned a very short right-click menu when you right-click the document icon. Is "Save Link As" available to download the link target?

Have you had any issues with secure connections?

Of course major sites use multiple servers and these issues may be hidden when a URL is not loaded directly into the address bar. You could try the right-click > Copy Link Location and then paste it into the address bar and press Enter to load it -- assuming the address starts with HTTPS. if it doesn't start with HTTPS, don't submit it.

Do PDFs on other sites follow your preference when you open them?

If the problem has become global:

One possible reason for settings confusion is that the file which stores these application handling preferences can become corrupted. Since it has a somewhat inscrutable XML-based format, we generally recommend letting Firefox rebuild it from scratch. And this is how...

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter/Return

In the first table on the page, click the "Open Folder" / "Show in Finder" / "Open Directory" button. This should launch a new window listing various files and folders.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > "power" button
  • (menu bar) File > Exit / Quit

Pause while Firefox finishes its cleanup, then rename mimeTypes.rdf to mimeTypes.old.

Start Firefox back up again. PDFs should be assigned to "Preview in Firefox" by default on the Options page.

more options

Let me answer your questions quickly:

1. No, there is no "Save Link As" option when I right-click. That was exactly what I had hoped to find by right-clicking! No luck.

2. What I get from pasting after Click in Copy Link Location is not a URL. I get: javascript:void(0);

3. Is the problem global? No. I still open PDFs for every other site I visit regularly--my bank's monthly statements, other credit cards, my utility bills, etc. No problems anywhere else either when clicking on PDF links.

Thanks for your suggestions.

more options

BeeFree46 said

2. What I get from pasting after Click in Copy Link Location is not a URL. I get: javascript:void(0);

That usually indicates there's a script command attached to the link instead of a normal address. Most likely it works through window.open(), better known as a pop-up. Could you make sure popup windows are allowed for that page with the button? You can use the Permissions panel of the Page Info dialog.

While on the page, either:

  • right-click a blank area of the page and choose View Page Info > Permissions
  • (menu bar) Tools menu > Page Info > Permissions
  • click the padlock or "i" icon to the left of the site address, then the ">" icon, then More Information > Permissions

Scroll down to "Open Pop-up Windows" and uncheck the "Use default" box, and click Allow.

There's no Save button for this dialog, the change should be saved immediately. Any difference?

Otherwise, if you are on a mission to make this work in Firefox, you could start investigating errors in either the Web Console or Browser Console, and Firefox's Network Monitor. But I don't know how often you need to do this, so...

more options

AT LAST!!!

I did have an exception for the Chase website in the dialog are for Block Pop-ups. Maybe the big re-do of the site by Chase invalidated it.

WHAT WORKED was the last of your suggestions regarding opening View Page Info>Permissions. I unchecked Use Default and clicked on Allow as you directed and boom! I can open my PDFs on Chase again.

THANK YOU! THANK YOU! THANK YOU!!!!

more options

OH NO!!!!!!

I just signed out and signed in again at Chase to repeat my success, and it won't work!!!!! It's broken again. HOW?

more options

I can't explain it. It seems that there's something inconsistent in how Firefox applying the pop-up blocker or how the site is generating the download.

If you turn off the pop-up blocker completely does that help? That's on the Options page: Pop-up blocker settings, exceptions and troubleshooting.

more options

Nope, turning off the Firefox Pop-Up Blocker does not restore my ability to open the PDF statements. And your solution that worked for me the first time, then didn't work the second time, is still set up "properly" to Allow Pop-ups. Just that one time, the pop-up opened in a new window as I used to see.

The only other thing I might mention is that the PDFs don't open in the Opera browser either when I click on the statement icon--they just automatically download to my Downloads folder when I click on the statement icon. I'm not sure what made me go look there when I was trying Opera as a solution; by that time I had four copies of the one statement! I've looked there now, and no statement PDFs have surreptitiously gone to Downloads in all my testing of proposed solutions in Firefox.