Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cannot install 52.9.0esr on XP SP3

  • 7 replies
  • 0 have this problem
  • 227 views
  • Last reply by andrzejm007

more options

52.9.0esr is claimed to be the last version for XP. Unfortunately it is not quite true. It is for XP SP2 ONLY. Trying to install on SP3 ends with the message that SP2 is required. IMO the installer is simply too strict on demanding exact version of SP ! https://www.mozilla.org/en-US/firefox/52.9.0/system-requirements/

I went through the list of versions (thanks Mozilla that they all are still available!) and found that the last version I can install is... version... 12.0b6. https://www.mozilla.org/en-US/firefox/12.0/system-requirements/

And indeed I installed 12.0b6 successfully but I would like to install 52.9.

52.9.0esr is claimed to be the last version for XP. Unfortunately it is not quite true. It is for XP SP2 '''ONLY'''. Trying to install on SP3 ends with the message that SP2 is required. IMO the installer is simply too strict on demanding exact version of SP ! https://www.mozilla.org/en-US/firefox/52.9.0/system-requirements/ I went through the list of versions (thanks Mozilla that they all are still available!) and found that the last version I can install is... version... 12.0b6. https://www.mozilla.org/en-US/firefox/12.0/system-requirements/ And indeed I installed 12.0b6 successfully but I would like to install 52.9.

Chosen solution

@jscher200, My version is: Version 5.1 (Build 2600.xpsp.080413-2111 : Service Pack 3)

@James, I downloaded FF 32 bit from the exact location you pointed (or a subfolder to be precise). It’s either my XP installation is broken somehow or a developer of Firefox installation used „version == SP2” instead of „version >= SP2” ;) If the latter is true it’s not a feature it’s a bug! However, you are right, it’s far too late to request any changes in the existing codebase!


Currently I have working 12.0b6 and that’s fine. In case I need a more modern browser I will search for alternatives.

Thanks a lot!

Read this answer in context 👍 0

All Replies (7)

more options

Hi

That is probably not a good link to follow.

Please appreciate that Microsoft no longer supports Windows XP and that Mozilla has not supported Firefox 52 for quite a few years.

Aside from the challenge that you are having getting Firefox to work, your computer is very likely to not be very safe from viruses and malware. I strongly recommend that you consider updating your device, possibly moving to Linux (which may support older hardware) or, if possible, getting a new device.

more options

Thanks a lot for both answers. IMO definitely this is a bug in Firefox installer but because 52 is no longer supported I see that I will have to do some tricks... (like reinstall XP, possibly install SP2, install FF 52 and only then install SP3, hopefully FF will still work...).

I agree that using XP online may be dangerous today but in my case it must be XP for some reasons. I will connect only to grab some drivers and later on it will be an offline computer forever.

Modified by andrzejm007

more options

BTW I tried to mark both answers as useful but I think this web page (support.mozilla.org) has bug that does not allow to do it... or it's a very strange design that limits possibility to give feedback ;)

Modified by andrzejm007

more options

I don't recall ever hearing of this problem before. Nor should it be a problem, since SP3 was released nearly a decade before Firefox 52.

If you run winver (from Run or maybe it was from cmd.exe, I can't remember), how does your version identify itself? For example:

Version 5.1 (Build 2600.xpsp_sp3[other stuff] : Service Pack 3)

more options

Dropa said

If that's the case then you need to follow this link. https://support.mozilla.org/en-US/kb/file-bug-report-or-feature-request-mozilla

Really??? you want the OP to do a feature request for Firefox 52 ESR when the last one 52.9.0esr was Released way back on June 26, 2018.

more options

WinXP SP2 was the Minimum requirement for Windows so having WinXP SP3 should be fine.

Where did you download Firefox 52.9.0 esr from as was it from some random third-party download site?

https://archive.mozilla.org/pub/firefox/releases/52.9.0esr/win32/

Also note for WinXP/Vista you need 32-bit version as 64-bit (Win64) was for 64-bit Windows 7 or later.

Modified by James

more options

Chosen Solution

@jscher200, My version is: Version 5.1 (Build 2600.xpsp.080413-2111 : Service Pack 3)

@James, I downloaded FF 32 bit from the exact location you pointed (or a subfolder to be precise). It’s either my XP installation is broken somehow or a developer of Firefox installation used „version == SP2” instead of „version >= SP2” ;) If the latter is true it’s not a feature it’s a bug! However, you are right, it’s far too late to request any changes in the existing codebase!


Currently I have working 12.0b6 and that’s fine. In case I need a more modern browser I will search for alternatives.

Thanks a lot!