Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Customisation of colors does not work in 68.4.2

  • 17 replies
  • 3 have this problem
  • 22 views
  • Last reply by myken

more options

I have customization of colors by settings in userchrome.css. They worked fine until I updated to 68.4.2. How can I get them back?

I have customization of colors by settings in userchrome.css. They worked fine until I updated to 68.4.2. How can I get them back?

Chosen solution

Thank you, it now works.

So, it seems that the location of the chrome folder changed from earlier versions. How does one find out these things?

Read this answer in context 👍 0

All Replies (17)

more options

Please post an image of your 'userChrome.css' file showing all the contents.

Please state exactly what is and is not working. Please state what OS you use.

Confirm: Thunderbird is not operating in Safe Mode; 'userChrome.css' will not work in Safe Mode.

more options

Until the latest update to 68.4.2 (32 bit) unread messages were colored red. Now they are just bold black.

OS is Windows 10 Home Version 1909 Thunderbird is not in Safe mode.

UserChrome.css file in C:\Users\Ken\AppData\Roaming\Thunderbird\Profiles\chrome

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* set default namespace to XUL */

/* Change background color of unread messages to slightly red */ treechildren::-moz-tree-cell(unread) {

   background-color: #8afff3 !important;

} treechildren::-moz-tree-cell(unread,selected) {

   background-color: #66fff0 !important;

}

treechildren::-moz-tree-cell-text(unread) {

   color: #0000 !important;

}

more options
treechildren::-moz-tree-cell-text(unread) {
 color: #0000 !important;

}

Note: color: #0000 technically this should be #000000, but it is likely to be unreadible and the default for Thunderbird is being used. This means the text colour of the cell would be black

If you want the text to be red then you need to use a red hex colour like #FF0000 It would seem the file has been edited and the FF has been removed from the #FF0000 hence #0000

Suggest you Exit Thunderbird, edit that hex code so it says #FF0000, save the file and restart Thunderbird.

Modified by Toad-Hall

more options

Note: When you post a comment, an email is sent to recipient. It has been noticed that part of the code (!important) is missing in the sent emails, but shows correctly in the forum question. So, always check code via the forum question.

more options

I changed the code to #FF0000 and it made no difference. None of the other color settings in the UserChrome.css file work. It seems that the css file is being ignored.

more options

This script makes unread messages in the Threads Pane have yellow text on a salmon background:

#threadTree treechildren::-moz-tree-cell(unread) {
  -moz-appearance: none !important;
  background-image: none !important;
  background-color: #F08080 !important;
}

#threadTree treechildren::-moz-tree-cell-text(unread) {
  -moz-appearance: none !important;
  font-weight: bold !important;
  color: yellow !important;
}
more options

sfhowes

Your coding does not work.

I am wondering if the namespace statement is the problem. Does the one that I have apply to version 68.4.2?

more options

The code works (see picture), with or without the namespace statement, in 68.4.2 32b/W10. Check that you have the userChrome.css in a chrome subfolder of the profile folder.

more options

Still doesn't work.

more options

What add-ons do you have? Some of them conflict with colored cells in the Threads Pane.

more options

I have no add-ons.

more options

Please check that the 'userChrome.css' file is spelt exactly as I've written. As that file got edited at some point, perhaps it has become saved with a .txt extension eg: userChrome.css.txt You may not see the .txt if the computer is set up to not display common extensions.

Exit Thunderbird. Open the 'chrome' folder to see the 'userChrome.css' file. Make sure you can see the 'Type' column header. The file should be described as a 'Cascading Style Sheet Document' (CSS).

Or right clickon the 'userChrome.css' file and select 'Properties'. This will tell you the info you need.

If it is not Type CSS then edit the filename to remove the .txt and save as css.

more options

The file has the correct name and content. Just in case there were some hidden characters, I re-created it. The type is 'CSS file' not 'Cascading Style Sheet Document (CSS)'

Still doesn't work.

more options

You mentioned in earlier comment: UserChrome.css file in C:\Users\Ken\AppData\Roaming\Thunderbird\Profiles\chrome

The 'chrome' folder is not in the correct location. It is currently in the 'Profiles' folder. It should be in the 'profile name' folder: C:\Users\Ken\AppData\Roaming\Thunderbird\Profiles\<profile name>\chrome

The 'profile name' folder is by default called 'xxxxxxxx.default' where the x's are letters and numbers.

  • Exit Thunderbird.
  • Move the 'chrome' folder from the 'Profiles' folder and put it in your 'profile name' folder. So it appears in the same location as the 'Mail' folder. see image below as guide.
more options

Chosen Solution

Thank you, it now works.

So, it seems that the location of the chrome folder changed from earlier versions. How does one find out these things?

more options

The chrome folder was in wrong location, but the userChrome.css file was also edited incorrectly, so the red font would not have worked even if the chrome folder was in the correct location.

Meddling pixies at work :) or just an accident where something was moved without realising it. Probably at the same as the editing issue.

more options

I probably lost the color hex value when I was trying to solve the problem. With the correct hex value It certainly worked in earlier versions of Thunderbird.

It highlights the issue that when one flounders around trying to solve a problem it often compounds the problem.