Join the AMA (Ask Me Anything) with Firefox leadership team to talk about Firefox priorities in 2024. Mark your calendar! Thursday, June 13, 17:00 - 19:00 UTC.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

My firefox updated to the latest version and now the game that I play which is a flash based game lags all the time in firefox, but does not lag in IE

  • 7 replies
  • 1 has this problem
  • 1 view
  • Last reply by FredMcD

more options

ok so I play a game called Emporea on my PC and it uses flash, I have never had a problem then I refreshed firefox like it suggested and it updated to the latest version, I have never had any problems with it before on previous versions and now with this one the lag is so bad that it makes the game almost unplayable. I have tried to open it in other browsers such as IE and it works fine in those. so the issue is somewhere with firefox, I have updated my flash player and still no change in firefox

ok so I play a game called Emporea on my PC and it uses flash, I have never had a problem then I refreshed firefox like it suggested and it updated to the latest version, I have never had any problems with it before on previous versions and now with this one the lag is so bad that it makes the game almost unplayable. I have tried to open it in other browsers such as IE and it works fine in those. so the issue is somewhere with firefox, I have updated my flash player and still no change in firefox

Chosen solution

One of the headline changes in Firefox 48-49 is e10s, which separates the browser interface process from the page content process. The performance impact of this can vary a lot between systems, so it would be helpful to know whether you have this feature turned on. To check that, either:

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, check the row for Multiprocess Windows and see whether the number on the left side of the fraction is greater than zero. If so, you are using e10s.

If you are using e10s:

To help evaluate whether that feature is causing this problem, you could turn it off as follows:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste autos and pause while the list is filtered

(3) Double-click the browser.tabs.remote.autostart.2 preference to switch the value from true to false

Note: the exact name of the preference may vary, but it will start with browser.tabs.remote.autostart

At your next Firefox startup, it should run in the traditional way. Any difference?

Read this answer in context 👍 0

All Replies (7)

more options
more options

No my graphics card is up to date for updates

more options

There's a new acceleration-like feature for the Flash plugin that isn't working well for everyone. You could try turning it off:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste async and pause while the list is filtered

(3) Double-click the dom.ipc.plugins.asyncdrawing.enabled preference to switch the value from true to false

That might take effect the next time you load a Flash game, or you might need to exit out of Firefox and start it up again, I'm not sure.

Any difference?

more options

It is already set to false

more options

Chosen Solution

One of the headline changes in Firefox 48-49 is e10s, which separates the browser interface process from the page content process. The performance impact of this can vary a lot between systems, so it would be helpful to know whether you have this feature turned on. To check that, either:

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, check the row for Multiprocess Windows and see whether the number on the left side of the fraction is greater than zero. If so, you are using e10s.

If you are using e10s:

To help evaluate whether that feature is causing this problem, you could turn it off as follows:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste autos and pause while the list is filtered

(3) Double-click the browser.tabs.remote.autostart.2 preference to switch the value from true to false

Note: the exact name of the preference may vary, but it will start with browser.tabs.remote.autostart

At your next Firefox startup, it should run in the traditional way. Any difference?

more options

that seems to have restored the speed to my flash for now

Thank you all for the help

Modified by schondo7

more options

Glad to help. Safe Surfing.