ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I have tried to remove sweetpacks per your intructions but there is no "remove" button on the extensions page for sweetpacks.

  • 2 (ردّان اثنان)
  • 6 have this problem
  • 1774 views
  • آخر ردّ كتبه cor-el

more options

I tried the suggestions posted and nothing works. I have tried going to the mozilla extensions page but there is no "remove" button for sweetpacks.

I have also tried "about:config" but when I make the change to have a different homepage (google), the change is not saved, it goes back to sweetpacks.

Again, nothing seems to work even though i removed all the sweetpacks stuff via control panel/remove programs - sweetpacks keeps coming up as my homepage.

الحل المُختار

You can use the SearchReset extension to reset some preferences to the default values.

Note that the SearchReset extension only runs once and then uninstalls automatically, so it won't show on the "Firefox > Add-ons" page (about:addons).

If you do not keep changes after a restart or otherwise have problems with preferences, see:


Read this answer in context 👍 0

All Replies (2)

more options

Hi FrankWonka,

Thanks for contacting Mozilla Support. I'm sorry to see that Sweetpacks has overriden Firefox. Let's see how I can help.

First, from what I am aware of, Sweetpacks is a hijacker so it won't be in your Add-ons or about:config. You need to go to your Control Panel (Start>Control Panel>Programs and Features>Uninstall a program). There you should find these programs to uninstall: 'SweetIM for Messenger, SweetPacks Toolbar for Firefox, Update Manager for SweetPacks. NOTE: these instructions are based of IE


If this doesn't work, then you should reset Firefox to factory settings. (NOTE: your bookmarks, browsing history, passwords, cookies and web form auto-fill information will be saved) To do this, Click the orange Firefox button at the top left corner of the window, hover over Help and click Troubleshooting Information. Click the Reset Firefox button in the upper right corner of the Troubleshooting Information page.

If none of this works, please do not hesitate to respond.


P.S. I see you are running Fx24. I recommend upgrading to Fx25 to get the latest bug fixes and security updates. You can upgrade by clicking here.

Regards, Moses


edit: added new info

Modified by Moses

more options

الحل المُختار

You can use the SearchReset extension to reset some preferences to the default values.

Note that the SearchReset extension only runs once and then uninstalls automatically, so it won't show on the "Firefox > Add-ons" page (about:addons).

If you do not keep changes after a restart or otherwise have problems with preferences, see: