ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox window animations in MacOS

  • 1 (رد واحد)
  • 1 has this problem
  • 6 views
  • آخر ردّ كتبه cor-el

more options

Hello!

I use Mosaic, a window manager utility, for macOS. With a hotkey, I can move or resize a window according to a preconfigured grid.

This always has worked great with all different applications, and only in the past couple of months it stopped working with Firefox.

It appears to be related to the way Firefox is does animation of resizing or window movement. My hotkeys no longer have the effect on the Firefox window moving.

This is disruptive enough to my workflow that I have switched to Chrome, which doesn't have the same issue. I really am not okay with this solution, as Chrome is the worst for a software developer. Tab and session management in Firefox is the absolute best and I want to come back to FF.

Is there any way to completely disable whatever window animation features have recently been added to Firefox?

Hello! I use Mosaic, a window manager utility, for macOS. With a hotkey, I can move or resize a window according to a preconfigured grid. This always has worked great with all different applications, and only in the past couple of months it stopped working with Firefox. It appears to be related to the way Firefox is does animation of resizing or window movement. My hotkeys no longer have the effect on the Firefox window moving. This is disruptive enough to my workflow that I have switched to Chrome, which doesn't have the same issue. I really am not okay with this solution, as Chrome is the worst for a software developer. Tab and session management in Firefox is the absolute best and I want to come back to FF. Is there any way to completely disable whatever window animation features have recently been added to Firefox?

All Replies (1)

more options

You can create a new Number pref named ui.prefersReducedMotion on the about:config page.

  • set its value to 0 if you want to see animations
  • set its value to 1 if you want to block animations.

Also see the Mac OS System Preferences.

Helpful?

اطرح سؤالا

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.