ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Version 116

  • 6 ردود
  • 1 has this problem
  • 70 views
  • آخر ردّ كتبه tom3trip

more options

I have windows 7. On August 1 Firefox automatically uploaded version 116. Now my computer is running very slowly, and is taking a long time to load pages on the internet when I browse the web. I just learned searching the web (I never go any notification from Firefox) that version 115 was going to be the last version for windows 7, so how did I get version 116 automatically loaded onto my computer? How do I go back to version 115 which was working great? I right clicked on the Firefox icon on my desktop and clicked restore previous version and it states there is no previous version there. How do I go back to version 115.

I have windows 7. On August 1 Firefox automatically uploaded version 116. Now my computer is running very slowly, and is taking a long time to load pages on the internet when I browse the web. I just learned searching the web (I never go any notification from Firefox) that version 115 was going to be the last version for windows 7, so how did I get version 116 automatically loaded onto my computer? How do I go back to version 115 which was working great? I right clicked on the Firefox icon on my desktop and clicked restore previous version and it states there is no previous version there. How do I go back to version 115.

الحل المُختار

By changing the connection settings to "No Proxy" fixed the problem of my internet speed. It's back to normal. Changing from "Default Protection" to "Off" had no effect, so I left it on "Default Protection". One last question, is it harmful or risky for my computer to leave the connection setting at "No Proxy"? Thanks.

Read this answer in context 👍 0

All Replies (6)

more options

Update. It won't let me edit my original question. My computer is a windows 10 not 7. I got it mixed up with another computer I have. But the problem is still the same. Since version 116.0 automatically uploaded on 8/1/23 my computer is running slow while browsing the web. Speed test shows downloads around 110mbps and uploads only around 3mbps. I have 300mbps internet service. I get higher speeds with Microsoft Edge around 190mbps downloads and 12mbps uploads. I don't like Edge. I still want to how to go back to the previous Firefox version which was 115.0.3. Thanks.

more options

Note that users on Windows 7/8/8.1 will be moved to the 115.1.0 ESR version, as those platforms are no longer supported (minimum is Windows 10).


It is possible that your firewall or other security software blocks or restricts Firefox without informing you, possibly after detecting changes (update) to the Firefox application. Remove all rules for Firefox from the permissions list in the firewall and let your firewall ask again for permission to get full, unrestricted, access for Firefox and the plugin-container process and the updater process.

See:

more options

Thanks for the reply. How will this help? I have windows 10. My problem is not that I can't open websites after the update. I can view all websites. It's just that now after this version 116.0 updated my internet browsing is very slow. Particularly the upload button. It's now at around 2mbps and takes forever for the site to connect and then not everything loads on the page. It's like I'm on a dial up connection. I'm not having any problems with Microsoft Egde. Do you still think doing this with the firewall will work? Also can you send me a link on how to get my previous 115.0.3 version back. Thanks.

more options
more options

Try changing DNS over HTTPS from "Default Protection" to "Off" (or vice versa) and in Connection Settings change "Use system proxy settings" to "No proxy".

more options

الحل المُختار

By changing the connection settings to "No Proxy" fixed the problem of my internet speed. It's back to normal. Changing from "Default Protection" to "Off" had no effect, so I left it on "Default Protection". One last question, is it harmful or risky for my computer to leave the connection setting at "No Proxy"? Thanks.