Relay Phone Masking users currently cannot register for a new phone number, this will primarily impact new phone masking users. Please check https://status.relay.firefox.com/ for updates.

ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Stop auto-download for Version 98.0.1 (64-bit)

  • 17 ردًا
  • 9 have this problem
  • 4233 views
  • آخر ردّ كتبه T.P.

more options

Hi, new updates on Version 98.0.1 quite a hassle for me. It auto-download all my files even when I just want to view. Is there any other way to disable this feature? I opened Setting>Download but there is no disable button or checkbox for that. Please help me. Thank you in advance.

Hi, new updates on Version 98.0.1 quite a hassle for me. It auto-download all my files even when I just want to view. Is there any other way to disable this feature? I opened Setting>Download but there is no disable button or checkbox for that. Please help me. Thank you in advance.

الحل المُختار

One thing they did was change "Always ask" to 'Save' for each file type where that choice was made. Go to Applications on the General page of Settings to change them back to what you want. You can still choose which folder to use for downloads under Downloads on the same page.

Read this answer in context 👍 0

All Replies (17)

more options

Your only other choice is a "RegEdit" that disable FireFox updates. But they will not allow discussion on that so you will have to search the internet for this option and how to use it.

more options

الحل المُختار

One thing they did was change "Always ask" to 'Save' for each file type where that choice was made. Go to Applications on the General page of Settings to change them back to what you want. You can still choose which folder to use for downloads under Downloads on the same page.

more options

terry21 said

One thing they did was change "Always ask" to 'Save' for each file type where that choice was made. Go to Applications on the General page of Settings to change them back to what you want. You can still choose which folder to use for downloads under Downloads on the same page.


Thanks for this. I’ve tried this and they’re back like before. I almost change my browser because of this.

more options

Terry- said

One thing they did was change "Always ask" to 'Save' for each file type where that choice was made. Go to Applications on the General page of Settings to change them back to what you want. You can still choose which folder to use for downloads under Downloads on the same page.

I have done this but when I want to only open a document (for example in Word or something) it automatically also downloads it to my pc. Previously it would only be a temp file and not stored locally on my computer. I do not like this since I often have to only look if a document has a specific info and I don't want it permanently saved... is there any way I can have the previous settings without having to downgrade ff?

more options

inmauser said

Terry- said

One thing they did was change "Always ask" to 'Save' for each file type where that choice was made. Go to Applications on the General page of Settings to change them back to what you want. You can still choose which folder to use for downloads under Downloads on the same page.

I have done this but when I want to only open a document (for example in Word or something) it automatically also downloads it to my pc. Previously it would only be a temp file and not stored locally on my computer. I do not like this since I often have to only look if a document has a specific info and I don't want it permanently saved... is there any way I can have the previous settings without having to downgrade ff?

Exactly! I have the same issue! I absolutely want to go back to files saved in temporary folder rather than in Download folder when I open with Firefox.

more options

Very, very simple. Using the GUI DOES NOT WORK. I use Crap Cleaner and configured it to clean two hidden files out at computer start up. Fitst you have to show hidden files, configure CC cleaner in the 'Options' tab to delete 'Update folder and 'Update lock'

These two items are located ina hidden files on the C drive in the Mozilla 'program data' folder.

Even with internet is disconnected you open Mozilla browser.... they appear! The registry hack and using the GUI does not work for me, because it gets up Mozilla noses.

Dave

more options

Not working. These are my settings for downloading documents. There is a "Save Files To" field, but I can't just make it an empty field. Can someone explain how to set up the Download settings so .pdf files just open in a new tab, and are not automatically downloaded to my Downloads folder? What is going on with FF? This never used to happen.

more options

With 102 there is a preference in about:config. browser.download.start_downloads_in_tmp_dir

https://support.mozilla.org/en-US/kb/about-config-editor-firefox

If that doesn't deal with your issue, I suggest filing a new question.

more options
more options

Have followed the instructions provided in both above links, see my screen snip in my original post. I am still having FF download a .pdf file when I click on a .pdf link, and now, also launching the .pdf in a new tab. I don't want FF to auto-download to my Downloads folder, but I can't figure out how to stop that action, and JUST have the .pdf launch in a new browser tab.

more options

Terry said

With 102 there is a preference in about:config. browser.download.start_downloads_in_tmp_dir https://support.mozilla.org/en-US/kb/about-config-editor-firefox If that doesn't deal with your issue, I suggest filing a new question.

So, am I supposed to find that Preference and delete it??

more options

No, the intention is to change this pref to true on the about:config page.

  • browser.download.start_downloads_in_tmp_dir = true

You can open the about:config page via the location/address bar. If you get the warning page, you can click the "Accept the Risk and Continue" button.

Modified by cor-el

more options

Okay, if I make this "true" will this turn OFF the auto download? Seems like telling this command string "true" tells FF to auto download something. I want that feature to be turned off. Not sure why I cannot just do this in the FF Settings, without having to change coding string?? I just want a .pdf to launch into a separate tab (which it is doing), without also auto downloading the .pdf to my Downloads folder. FF never used to do this, I am perplexed.

more options

cor-el said

No, the intention is to change this pref to true on the about:config page.
  • browser.download.start_downloads_in_tmp_dir = true
You can open the about:config page via the location/address bar. If you get the warning page, you can click the "Accept the Risk and Continue" button.

That did the trick. Auto Download to my Downloads folder has stopped. Not super happy I had to manually go into the FF Config folder to override Settings, but sure glad this additional annoying auto download behavior has been halted. Much appreciated!

Modified by cor-el

more options

cor-el said

No, the intention is to change this pref to true on the about:config page.
  • browser.download.start_downloads_in_tmp_dir = true
You can open the about:config page via the location/address bar. If you get the warning page, you can click the "Accept the Risk and Continue" button.

Why is this still not working for me?

Also, I'm running the same FF at my office and at home. At home, this whole fiasco is not an issue at all because nothing changed. I verified I'm running the same version. At the office, where I'm most affected, I cannot find a solution to change my life. Do I need to delete FF and start all over? This is bugging the absolute S out of me!

Modified by cor-el

more options

@darthno2, is your office software affected by a policies.json? Check about:policies.

more options

cor-el said

No, the intention is to change this pref to true on the about:config page.
  • browser.download.start_downloads_in_tmp_dir = true

That is not really a solution because file is still in Temp and it stays there, meaning every time you open *ANYTHING* it slightly fills up your hard drive. I don't know how it behaved before this change, but I don't see any files I opened before in temp or anywhere else for that matter.