On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Set the old Print Dialog Window as the default

more options

How can I restore my old system print dialog window as my default, instead of getting the horrible new print window that now appears? I have already set both the print.tab_modal.enabled preference and the app.normandy.startupRolloutPrefs.print.tab_modal.enabled preference to FALSE. This did NOT solve the problem! I knew updating Firefox to version 97 would be a huge mistake, and of course it was. I'm so irritated...

I'm using Windows 10 Professional. Any help greatly appreciated.

How can I restore my old system print dialog window as my default, instead of getting the horrible new print window that now appears? I have already set both the '''print.tab_modal.enabled''' preference and the '''app.normandy.startupRolloutPrefs.print.tab_modal.enabled''' preference to FALSE. This did NOT solve the problem! I knew updating Firefox to version 97 would be a huge mistake, and of course it was. I'm so irritated... I'm using Windows 10 Professional. Any help greatly appreciated.

All Replies (16)

more options

I think you need to click the "Print using the system dialog..." link now.

more options

Thank you. I'm well aware of that option. However, that's an aggravating Extra Step that I did not have to be subjected to before the update to 97.0. What I'm looking for is a way for the System Print dialog window to open instantly upon clicking the Print button, just as it always did, instead of first opening the new window above. I could not find a preference setting to make that happen, nor did setting the two config preferences I cited earlier to False solve the problem either, as they should have. Is there any other way to get the system dialog by default?

Modified by SadFirefoxUser

more options

I don't think there is any built-in way to avoid clicking that link.

I also don't think an add-on can bypass the preview/setup/print overlay.

Why do you prefer using the system dialog?

more options

I prefer it because I'm used to it and 'have always done it that way' (a bad reason, I know), but, and much more importantly, because the new print utility does not give me access to the all-important printer preference settings, which is crucial when printing to Adobe PDF because I need to uncheck the 'Use system fonts' setting and increase print quality. These settings are only available through the system dialog and were forgotten in the new print window. Also, the new print window opens a print preview of the job which isn't aways necessary or convenient. Thirdly, the change was foisted upon me without any say in the matter and I don;t like major changes rammed down my throat.

I attach two screenshots to illustrate why the system dialog is so important.


Well, seems the 'Add Images' utility below is malfunctioning. It refuses to load the png screenshots and doesn't allow a PDF. Screwed.

more options

Seems it allows just one image at a time?

more options

And the second. Maybe my pop-up blocker was crashing the image upload utility.

more options

I have exactly the same issue. The new print dialog box in Firefox doesn't give me any print preview...and the system print dialog box in Mac OS worked great. There was absolutely no reason for Firefox to implement this new design. It doesn't solve any problems!!

And to add insult to injury, The new dialog box says I have B&W output but it prints in color so it doesn't even work right on an ordinary HP Laserjet M475 printer.

Sure, I can just clock on the "Use System Dialog" box but this is totally unnecessary.

more options

SadFirefoxUser said

I prefer it because I'm used to it and 'have always done it that way' (a bad reason, I know), but, and much more importantly, because the new print utility does not give me access to the all-important printer preference settings, which is crucial when printing to Adobe PDF because I need to uncheck the 'Use system fonts' setting and increase print quality.

I'm not sure why you need to change those settings every time you print; that would make me crazy. Can you get new default settings to stick if you change them through the system-level Printer settings? Screenshot collage attached for reference.

(The image uploader on this forum is flaky.)

more options

jschneid002 said

I have exactly the same issue.

And you have your own thread here: https://support.mozilla.org/questions/1367394

more options

Is there any progress on this issue? We're now up to 98.0.2 and still the new terrible print dialog window comes up which forces me to manually select the system print dialog... thank you.

more options

SadFirefoxUser said

Is there any progress on this issue?

I don't think so. Code still needs to be written for the two bugs on file:

  • preference to skip preview and go directly to the system print dialog
  • new keyboard shortcut to skip preview and go directly to the system print dialog
more options

Having to click "use system dialog" every time is a huge annoyance; an unnecessary extra step. This is not the first time Mozilla has co-opted user settings, but at least, in the past, we've been given the option to re-set. Apparently, that's not the case this time. Please fix this ASAP! I'm using Windows 7 Professional.

more options

=== For those who do not want any preview ===

It's finally here. Firefox 101 has a preference to bypass the combined print preview/setup overlay and go straight to the system dialog. Here's how you can try it out:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the search box in the page, type or paste print.prefer_system_dialog and pause while the list is filtered

(3) Double-click the preference to switch the value from false to true

If you need to restore the default display, you can call up the preference and double-click again to toggle the value back to false. There also will be a reset arrow at the right end of the row when the preference has a non-default value.

more options

Hi jscher2000,

Your config tweak works, BUT it totally disables any print preview at all, and that was not the original desired outcome. I simply wanted the system dialog window to be able to be selected with the Print button, while still getting an ordinary Print Preview window when pressing that button, as used to function flawlessly in Firefox 96. But now all print preview has been disabled and that is an application breaking defect. Please restore the ability to see a print preview window by pressing such a button, such as with the Print Preview Button by Button Guy. Thank you.

Modified by SadFirefoxUser

more options

Hi SadFirefoxUser, I had the same thought and I filed a bug requesting it last week. However, I have no idea whether it will move forward. Here's a link, but please refrain from commenting on bugs unless you can help implement them:

https://bugzilla.mozilla.org/show_bug.cgi?id=1770862

more options

Hi SadFirefoxUser, there is still a bug pending to configure an alternate keyboard shortcut for the system dialog:

https://bugzilla.mozilla.org/show_bug.cgi?id=1667950