ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Mozilla Startup Tab: how to eliminate

  • 16 ردًا
  • 1 has this problem
  • 30 views
  • آخر ردّ كتبه jscher2000

more options

On startup I get a Mozilla sales pitch tab that opens automatically. How do I stop this unsolicited advertisement tab?

All Replies (16)

more options

Try entering in the URL: about:preferences#home

Then set all two options to "blank pages".

Helpful?

more options

Your suggestion worked on the mobile firefox versions, but not on the laptop version 92. Thanks for the partial solution, that's 2 of 3 devices

Helpful?

more options

https://support.mozilla.org/en-US/kb/how-to-set-the-home-page

Type about:config<enter> in the address bar. If a warning screen comes up, press the I Accept the Risk button. At the top of the screen is a search bar. Type browser.startup.homepage

What is the value? Right-click and select Reset to restore its default value; about:home

Helpful?

more options

Note that Firefox supports multiple homepages separated by '|' (pipe) symbols.

You can check that those pages aren't set as multiple homepages.

You can check the homepage setting.

Helpful?

more options

Neither of the suggestions eliminate this url from opening:https://www.mozilla.org/en-US/ So I have blank selected in the homepage section, and I am seeing about:home as the default value. See attached screenshot. I thought Mozilla was going to harass us with the VPN add for awhile, but that they would eventually eliminate it as it violates their core principles. Now I am thinking seriously about switching to EDGE as my default browser. The sentiment is that these guys have caved in to the need for the mighty dollar.

Helpful?

more options

If you have Blank page as your home page on the Settings page, then in about:config it should say about:blank and not about:home. That's been working for me the past couple of years. You can double-click the preference and edit the address yourself and see whether that works.

I wonder whether your Firefox thinks it has just updated, every time it starts. Could you check whether you have a user.js file in your profile. There is a section on that in the following article: How to fix preferences that won't save.

Helpful?

more options

You can check the target line in the Firefox desktop shortcut (right-click: Properties) to make sure nothing is appended after the path to the Firefox program.

What URL does that page have ?

Can you attach a screenshot?

Helpful?

more options

Okay gents, here is where I am at: no user.js file in profile folder, now have "about:blank" in about:cinfig<enter>, and I am going to/but have not yet tried checking the shortcut target line. Thank You Both for continuing to try to solve this one with me. Cheers, Marc

Helpful?

more options

Shortcut path attached. looks fine to me

Helpful?

more options

If the homepage is blank and the URL is about:home then you may have the default Firefox Home with all items disabled. In that case you would have the cogwheel button to personalize the page in the top right corner.

Helpful?

more options

Still have the problem on my MS Laptop. See attached screenshots of settings and unwanted advertisement.

Helpful?

more options

Could this be an old session that Firefox keeps restoring? If you check the History menus, are these available, grayed out, or missing:

  • "3-bar" menu button > History > Restore Previous Session
  • (menu bar) History > Restore Previous Session

Helpful?

more options

Missing:No restore previous session option available, but they might have moved that command to another menu item as it sounds familar

Helpful?

more options

If those items are missing, it means either that Firefox did restore a previous session already, or that no session history files were found. But since old tabs appeared, it must be that Firefox did restore the session. So this could be a type of crash recovery using an older session history file. Let's hide the older files -- this is for when you are ready to quit Firefox:

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > Help > More Troubleshooting Information
  • (menu bar) Help > More Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, on the Profile Folder row, click the "Open Folder" button. This should launch a new window listing various files and folders in Windows File Explorer.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > Exit
  • (menu bar) File > Exit

Pause while Firefox finishes its cleanup, then:

Right-click the sessionstore-backups folder then Rename to something like sessionstore-backupsOLD and then click away or press Enter to save the change.

Start Firefox back up again. Do you just get your home page as expected?

Helpful?

more options

Missing:No restore previous session option available, but they might have moved that command to another menu item as it sounds familiar I think the current version has moved. See the attached screenshot of Histtory menu

Helpful?

more options

If those items are missing, it means either that Firefox did restore a previous session already, or that no session history files were found. Please refer to my previous reply for my suggestion.

Helpful?

اطرح سؤالا

عليك الولوج إلى حسابك للردّ على المشاركات. من فضلك اطرح سؤالًا جديدًا لو لم يكن لديك حساب بعد.