ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Getting 522 Timeout Just on Firefox (other browsers OK)

  • 20 ردًا
  • 1 has this problem
  • 101 views
  • آخر ردّ كتبه cor-el

more options

Recently I’ve been receiving a 522 timeout error in Firefox attempting to reach URL www.cocoontech.com. The 522 is returned from Cloudflare’s reverse proxy servers (see uploaded image). However, I can successfully reach that URL using Chrome and MS Edge browsers. Only Firefox receives the 522 error. I can access numerous other websites with Firefox, so it seems to be isolated to just www.cocoontech.com. I’ve looked at numerous settings in Firefox, but have not seen anything that seems relevant to this issue.

Any ideas where to look to resolve this issue?

Attached screenshots

All Replies (20)

more options

This is most odd. I had no problem connecting to http://www.cocoontech.com/ using Firefox v54 (my default). But, when I tried using the current Firefox v91.0.2 I got

Error 522 Ray ID: 687f74db7eef1895 • 2021-09-01 15:16:23 UTC
Connection timed out


Make sure you are not blocking content.

Diagnose Firefox issues using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?


https://support.mozilla.org/en-US/kb/enhanced-tracking-protection-firefox-desktop


Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

Helpful?

more options

Helpful?

more options

FredMcD,

Thanks for the suggestions. I am running Firefox version 91.0.2 and find it very interesting that you observed the same behavior with that version, but not with V54. I know this issue didn't exist in previous Firefox versions, but unfortunately I can't say for certain it was introduced in 91.0.2 as I don't access that URL on a frequent basis.

I have reviewed my firewall rules to ensure nothing is there that should be blocking this traffic. I can access this URL using Chrome or Edge browsers, so any blocking would need to be specific to Firefox.

I did put Firefox in Troubleshoot(safe) mode, but the problem persisted.

Helpful?

more options

This website only works with the HTTP protocol, so you need to disable HTTPS-Only mode by clicking the padlock. If you do not use HTTPS-Only then Firefox may insist in using HTTPS even if you click to go to the HTTP version and times out because the server doesn't respond.

Helpful?

more options

cor-el,

I did as you suggested and checked the status of HTTPS-Only which I verified is turned off in settings (see attached). When I hover over the padlock, I don't get an option of turning it off. Instead, it gives me an option to display information regarding the connection. I've included both screen shots of that also.

I've confirmed that both Chrome and Edge browsers successfully establish an HTTP (non-secure) connection. However, I can replicate the same behavior in Chrome and Edge and receive a 522 timeout if I specify establishing a secure connection via URL "https://www.cocoontech.com". I think what's happening is that Firefox will try to force an HTTPS connection even if I have HTTPS-Only turned off and even if I supply a non-secure URL of "http://www.cocoontech.com". It flips it back to "https".

I've tried turning HTTPS-Only on and then supplying cocoontech and Cloudflare IP's as exceptions, but that didn't have any effect.

Helpful?

more options

What I meant to say in my above reply is that you need to enable HTTPS-Only mode in Firefox and on the error page, shown by Firefox, that the website doesn't support HTTPS, you need to click the padlock and select the 'Off' value for HTTPS-Only like in the screenshot I attached above. Then you can click to continue to the HTTP website.

If you disable HTTPS-Only mode then Firefox will keep trying to upgrade the connection the HTTPS even if you click to continue to the HTTP website and that makes it fail consistently.

Modified by cor-el

Helpful?

more options

My HTTPS-Only mode was off. I turned it on and added cocoontech.com to the exceptions = off. Problem still there.

I even removes the S from https manually. Still a problem.

Helpful?

more options

Does Firefox show the error page that the website doesn't support HTTPS ? On that page you need to change 'On' to 'Off' instead of clicking "Continue to HTTP Site".

You may have to clear the disk cache or use "Forget About This Site" beforehand.

Modified by cor-el

Helpful?

more options

cor-el,

Thanks for the follow-up!

I enabled HTTPS-Only mode in the Firefox Privacy and Security screen and removed any exceptions. When I get the 522 timeout, the padlock does not have a slash through it. When I hover over it I am not provided with an option to turn off HTTPS-Only mode. I assume this is because Firefox thinks it has established a successful secure connection.

Helpful?

more options

You need to use the "http://" link to make Firefox try to open an HTTP connection.

That should make Firefox display the error page shown in the screenshot I posted above where you can disable HTTPS-Only mode via the padlock. If necessary, use "Forget About This Site" to clear the cache and possible exceptions.

Note that using "Forget About This Site" will remove all data stored in Firefox for this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data for that domain that you do not want to lose then make sure to backup this data or make a note.

Modified by cor-el

Helpful?

more options

cor-el,

I have tried numerous times to force Firefox to establish a non-secure connection by typing "http://www.cocoontech.com". But on every attempt Cloudflare returns a 522 error and "http://" is automatically changed to "https://".

I've also tried clearing the cache, cookies, etc. But this did not work.

Next I will try removing and reinstalling Firefox to see if that will change the behavior.

Helpful?

more options

cor-el said

Does Firefox show the error page that the website doesn't support HTTPS ?

No. Just what I posted above.


You may have to clear the disk cache or use "Forget About This Site" beforehand.

I checked, and that website is not recorded in history.

I even tried clear cookies, cache, and even Safe Mode.

No matter what, it keeps going to https:

Helpful?

more options

This is from v54

Helpful?

more options

Use the http:// link without the "www." prefix and either click "Continue to HTTP Site" or click the padlock and select HTTPS-Only -> Off.

The former creates a "Off temporarily" exception and using latter allows to create an "Off" exception (you can still click the padlock when the HTTP page has been loaded).

Helpful?

more options

When I went into Windows 10 to uninstall Firefox I was prompted to do a Firefox refresh instead. I figured "What the heck" and picked the refresh option. Now the problem appears to be resolved and Firefox is rendering "http://www.cocoontech.com" correctly!  :-)

Besides resetting various configuration settings back to the installation default, I have no idea what the refresh did to fix the issue. The HTTPS-Only settings look exactly as I tried them before. Perhaps some offending data was "stuck" in configuration files which was finally removed by this refresh.

FredMcD and cor-el, I really appreciate the help and support you both provided for this issue. Next time Firefox behaves badly, I'll try the refresh option first before posting!

Best Regards!

Helpful?

more options

That was very good work. Well Done. Please flag your last post as Solved Problem as this can help others with similar problems. Go to that post and click the 'Solved' button to its right.


Refreshing Firefox {web link} is a LAST RESORT ! !

Refreshing Firefox -- easily fix most problems

If you're having problems with Firefox, refreshing it can help. The refresh feature fixes many issues by restoring Firefox to its factory default state while saving your essential information like bookmarks and open tabs. Everything else, like user settings and add-ons, are removed. Note: Refresh saves your old profile to the desktop in a folder called Old Firefox.

Helpful?

more options

A follow-up: When I upgraded to version 92.0 of Firefox, the problem returned. I again did a refresh and that resolved the problem. I hope doing a refresh after every version upgrade won't become a common occurrence to correct this 522 timeout issue, but time will tell.

Helpful?

more options

Well, the "fix" didn't last more than a few minutes. After Norton reported the following 2 files were installed during/immediately after the refresh, the problem returned:

widevinecdm.dll - https://dll.website/widevinecdm-dll

gmpopenh264.dll - https://support.mozilla.org/bm/questions/1262714

The installation of these 2 files and the reappearance of the 522 timeout could simply be coincidence.

Helpful?

more options

Check with Norton support on that. https://support.norton.com

http://community.norton.com/

Helpful?

more options

widevinecdm.dll and gmpopenh264.dll are quite normal files and appear under "Add-ons -> Plugins" and shouldn't cause issues. The former is used for playing DRM protected media and the latter for WebRTC connections.

Note that the correct URL is the http: link without the wwww prefix.

Helpful?

اطرح سؤالا

عليك الولوج إلى حسابك للردّ على المشاركات. من فضلك اطرح سؤالًا جديدًا لو لم يكن لديك حساب بعد.