ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox will not connect to the internet when I install any add-ons...

  • 1 (رد واحد)
  • 1 has this problem
  • 5 views
  • آخر ردّ كتبه jscher2000

more options

Bear with me there's a bit of a story.

One of the apps I most use is MightyText. It allows me to send texts from my desktop computer's web browser. When FireFox automatically updated to the newest version, something didn't work right and MightyText stopped being able to connect.

My workaround was to use System Restore to go back in time so to speak. But FireFox is pretty aggressive with their updates, and eventually that stopped being a work around.

I tried to install an older version of FireFox manually but I couldn't ever get my profile to work right.

So, I've landed somewhere where FireFox has updated to the latest version, AND MightyText works just fine.

But now the problem is I cannot use any of my add-ons. Actually, I can re-fresh FireFox, and start it without any add ons. I can add all my add ons and everything works great, but if I restart my computer, FireFox will not connect to the internet (the wheel just spins) until I refresh again and wipe out all the add-ons. After doing so, all my tabs are restored, all my saved passwords, etc--and I can add back the add-ons and they will work until FireFox Crashes or I restart the computer, but then FF won't connect to the internet and around and around we go.

What's up?

All Replies (1)

more options

Next time Firefox won't connect, could you try Firefox's Safe Mode? In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart. A small dialog should appear. Click "Start in Safe Mode" (not Refresh, we know where that leads).

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.) A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Q: Any difference in whether Firefox can connect?

Q: If you check Add-ons at that point, have any unknown ones snuck in?

Helpful?

اطرح سؤالا

عليك الولوج إلى حسابك للردّ على المشاركات. من فضلك اطرح سؤالًا جديدًا لو لم يكن لديك حساب بعد.