ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

keyboard enter key is not working in address bar

  • 14 ردًا
  • 8 have this problem
  • 1403 views
  • آخر ردّ كتبه Bug Catcher

more options

I use:

Ubuntu 16.04 LTS Firefox 58.0.2 (64-bit


The keyboard enter key is not working in address bar

I write a url in address bar

Then press keyboard enter key ....

Nothing happens

I have to press go button (I hate that button... it is so Internet Explorer) to go to the typed url

I use: Ubuntu 16.04 LTS Firefox 58.0.2 (64-bit The keyboard enter key is not working in address bar I write a url in address bar Then press keyboard enter key .... Nothing happens I have to press go button (I hate that button... it is so Internet Explorer) to go to the typed url
Attached screenshots

Modified by feesgo

الحل المُختار

I think this problem occurs when all types of suggestions are disabled (bookmarks, history, open tabs, search). Can you tolerate at least one category appearing in the drop-down?

I don't know if this is scheduled to be fixed in an update, but hopefully.

Read this answer in context 👍 3

All Replies (14)

more options

الحل المُختار

I think this problem occurs when all types of suggestions are disabled (bookmarks, history, open tabs, search). Can you tolerate at least one category appearing in the drop-down?

I don't know if this is scheduled to be fixed in an update, but hopefully.

more options

I am having the same issue. All suggestions are gone.

Going to about:preferences#privacy Under Address Bar When using the address bar, suggest : Browing history Bookmarks Open tabs

^ all 3 are checked.

Also I cannot open the search section in the about:preferences

Modified by akshit-sharma

more options

Hi akshit-sharma, it seems your Firefox has a very different problem.

Is this a new installation, or was it working normally for a while?

Did you ever see the error message mentioned in the title of this article: Fix "The bookmarks and history system will not be functional" error message?

Could I suggest starting a new question:

https://support.mozilla.org/questions/new/desktop/fix-problems

Scroll down past article suggestions to continue with the form.

more options

Thanks for the reply. For some reason its working now.

Maybe rebooting fixed it, not sure though.

more options

I tried all of the suggestions, and Enter key still does not work in url box. Must still click on arrow on right side of box.

more options

Hi BugCatcher, could you test in Firefox's Safe Mode? In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

more options

Some time back, I disabled all of the extensions and then re-enabled them one at time. However, since I have your attention I followed the instructions. I started in both modes (many times), but there was no dialog box.

Also, when I click on the 3 bars, the popup box is only there momentarily and then disappears. No way to select anything. When I click the menu items at the top of the screen, nothing happens either. I assume menu items are related to the "no pop ups" problem.

Is this somehow related to the fact that I have no history, and have to type in a url and then press the arrow?

I have been using the program for 10+ years. I have even some problems over the years by checking about:config, but this is waaayyy beyond me.

You asked if there is "Any improvement?" I am afraid to report that things are now worse. Probably not your fault.


Thank you for your help.

p

more options

This only happens when all suggestions in the location bar drop-down list have been disabled. If you enable at least one suggestion then the Enter key should work immediately.

You can set what suggestions show when you enter an URL in the location/address bar bar.

  • Options/Preferences -> Privacy & Security
    Address Bar: When using the location bar, suggest:
    History
    Bookmarks
    Open tabs

Modified by cor-el

more options

BugCatcher said

Some time back, I disabled all of the extensions and then re-enabled them one at time. However, since I have your attention I followed the instructions. I started in both modes (many times), but there was no dialog box.

This could occur if one of the Firefox windows was still open. You could try it after a system restart.

Also, when I click on the 3 bars, the popup box is only there momentarily and then disappears. No way to select anything. When I click the menu items at the top of the screen, nothing happens either. I assume menu items are related to the "no pop ups" problem.

How long has that been going on? Perhaps your Firefox program files were damaged in the last update.

more options

"You can set what suggestions show when you enter an URL in the location/address bar bar.

   Options/Preferences -> Privacy & Security
   Address Bar: When using the location bar, suggest:
   History
   Bookmarks
   Open tabs "

All of those ARE clicked. Still no history, nor suggestions, nor "enter" key initiates process to go to entered web page.

more options

Hi BugCatcher, were you able to successfully invoke Firefox's Safe Mode for testing after a clean Windows startup?

more options

not running windows, so no.

more options

BugCatcher said

not running windows, so no.

I guess it's hopeless then, you need Windows in order to troubleshoot this problem.

Or you could restart whatever OS you're running so that you can be sure Firefox is not already running when you try to trigger Firefox's Safe Mode.

more options

I appreciate your attempt to help me, but Firefox does work on Linux as well as Winblows.