Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

This thread was closed and archived. Please ask a new question if you need help.

a web page is slowing down your browser

  • 9 replies
  • 6 have this problem
  • 225 views
  • آخر ردّ كتبه James

more options

Hi all,

     I'm using the latest version of FF 53.0.3 (32-bit) on Windows 7, and lately, every single tab loads slow with a momentary pop-up stating "a web page is slowing down your browser".  The pages do end up loading, and I see others have this problem as well.  I am wondering if it's because Flash (again using the latest version) no longer works as Firefox has done away with all add-ons??  Getting extremely frustrated with Firefox.  I don't get these error pop-ups in Chrome!

All Replies (9)

more options

”Webpage is slowing down your browser” This is the new way the browser tells you there is a problem with the script program(s). https://support.mozilla.org/en-US/kb/warning-unresponsive-script?cache=no

more options

I get that, but it's doing it on ALL tabs - ie, Google docs, Facebook, Gmail, even opening a new tab. So, since it's not just a particular website, and no extensions are enabled, the problem lies with Firefox itself.

more options

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

Type about:preferences<enter> in the address bar.

  • Cookies; Select Privacy. Under History, select

Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.

  • Cache; Select Advanced > Network. Across from

Cached Web Content, Press Clear Now.

If there is still a problem, Start Firefox in Safe Mode {web link} A small dialog should appear. Click Start In Safe Mode (not Refresh). While you are in safe mode;

Type about:preferences#advanced<enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Then restart. Poke around safe websites. Are there any problems?

more options

How can I fix the problem: "A web page is slowing down your browser?" None of these fixes fix the problem.

more options

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

more options

Tried that on day one. The problem is more complex. With the recent Firefox update, they forgot to lengthen the script run time. The solutions I have read are for me to go into the deep internals of page script coding and make configuration adjustments. This is not a finished product. I'll wait for the official correction with a new update rather than risk screwing things up worse getting into the autoconfig...

more options

You can consider uBlock Origin as a replacement for Adblock Plus to see if that works better (lower memory footprint).

Do pages where this happens use the Shockwave Flash plugin?

You can find a Lego block icon at the left end of the location bar indicating that the web page uses a plugin (Flash). You can click this Lego block icon to allow or block this plugin.

more options

No such Lego icon appears anywhere as you describe. Ad block on or off makes no difference, add-ons, plug-ins, extensions on or off or disabled or enabled makes no difference. Shockwave Flash plug-in on or off, enabled or disabled makes no difference.

No Firefox setting change or refresh or even uninstall and reload fresh with all add-ons disabled not even safe mode works.

No matter what I've tried, I keep getting the same message mainly on Youtube: A yellow bar across the top of the screen reading: " A web page is slowing down your browser..."

How long might it take to issue a new Firefox update with bug corrected? I am not the only one with the problem. Currently using IE to browse and finding it a more stable platform - doesn't freeze up every few minutes like Firefox. Is there a fix in the works please?

Modified by Rafael Lecuona

more options

rafaellecuona has been bumping old threads that have some relation while being a Nightly build Tester with 59.0.a1.