Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Firefox takes two minutes plus to load, apparant clash with Norton Internet Security

  • 19 replies
  • 22 have this problem
  • 5475 views
  • آخر ردّ كتبه divenow

more options

Today I tried to launch Firefox from the Norton Support menu, It took more than two minutes to load. After that it takes two minutes on restart. When it finally runs all websites a lightening fast, except for Norton, which is very slow if at all. Three sessions with norton chat support have not improved anything and following the Firefox troubleshoote including reinstallation have not solved either.

Chosen solution

I have just finished a chat session with Norton who showed me where to exclude things from Autoprotect and Firefox loads like greased lightening now. I attach a document wit a screenshot of the settings. Thank you for your support.

Read this answer in context 👍 11

All Replies (19)

more options

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All of them.

This will not stop the main Norton program from doing its job.

more options

FredMcD said

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All of them. This will not stop the main Norton program from doing its job.

I have very few addon and plug-ins, they are all disabled. They do include the Norton search bar which is disabled and has been for some months. Given the problem I would like to get rid of it to be certain but there is no easily visible way to do it. How does one delete a add-on or plug-in?

more options

There are two types of Add-ons. There are the Add-ons that you find and install. And there are also Plugins. These are from other programs that are on your system when Firefox starts. Like video players, anti-virus, and many more.

The only way to remove a plugin is to remove its program from your System. You can have the same effect by disabling that plugin.

As to Norton, go to your task bar and find its icon. Right click and select Disable for X minutes. Then test Firefox. Is the problem still there?

I've called the big guys to help you. Good luck.

more options

My Norton allows disabling two parts of Norton - Firewall and Autoprotect and has thus allowed me to identify that it is not the Firewall but prove it is Norton. I shall now go back to Norton and ask them what to do. Thank you.

more options

Right click on the Norton icon and select Get Support.

Good luck.

more options

Chosen Solution

I have just finished a chat session with Norton who showed me where to exclude things from Autoprotect and Firefox loads like greased lightening now. I attach a document wit a screenshot of the settings. Thank you for your support.

more options

Great to hear, Safe Surfing.

more options

For all others reading this;

Norton showed where to exclude things from Autoprotect Open Norton Administrative Settings. Under Performance Monitoring, find Program Exclusions. To its far right, press the Configure + link.

You will have to add each program one at a time from the Mozilla Firefox and Mozilla Maintenance Service folders.

more options

FredMcD said

For all others reading this; Norton showed where to exclude things from Autoprotect Open Norton Administrative Settings. Under Performance Monitoring, find Program Exclusions. To its far right, press the Configure + link. You will have to add each program one at a time from the Mozilla Firefox and Mozilla Maintenance Service folders.

Surely this only removes it from the Performance monitoring???

more options

Philip_Ebert said

I have just finished a chat session with Norton who showed me where to exclude things from Autoprotect and Firefox loads like greased lightening now. I attach a document wit a screenshot of the settings. Thank you for your support.

Sounds good and seems to do the trick, but hang on a minute - surely excluding Firefox and related elements from Autoprotect, SONAR etc exposes the system to the risk that these may get infected at a later time?

Personally, I would rather wait a bit for Firefox to open - The loading time already seems to have reduced significantly over the last couple of days.

more options

Check with Norton to be sure, but I believe the anti-virus will not interfere with the programs listed. As to another program (mal--ware) making changes, those programs would still be monitored, and hopefully stopped.

more options

There is some contradiction here: some of you are saying add exclusions from Performance Monitoring in Norton for 4 Mozilla items, but, what is actually being SHOWN is exclusions from AUTO-PROTECT Real Time Protection. Auto-protect is NOT the same as Performance Monitoring in Norton. So, could someone please clarify this contradiction

Modified by FlyBoy

more options

Maybe it is a matter of which Norton you have. My way into Norton Internet Security was Settings tab >Antivirus and SONAR exclusions (button on LHS)>Items to exclude from Autoprotect, SONAR and Download Intelligence Detection>Configure [+}. As I understand it these are three features which detect threats other than by scanning for signatures, the classic way. Since the files excluded are the Mozilla files and are scanned normally, the price does not seem to be too high for a quicker load. The interesting point is what is it makes them so slow to check Mozilla.

more options

Excluded 3 of those folders, do not have Thunderbird folder, and FF 36.0.1 works great again. I was curious how you would completely turn off NIS 21.6.0.32. Is there one switch? I turned off several in my trouble shooting to try to get FF36 to load in under a minute.

Thanks for the help

Bob

more options

Norton has a setting to disable it for a time. For more information, contact Norton.

https://support.norton.com

more options

If having problems with Norton it may be worth bearing in mind that Firefox provides some phishing and malware protection, and that is enabled by default.

Prior to Windows 8, MS will provide MSE free of charge, and for Windows 8 has built in protection. So MS provides the Firewall and AV.

more options

This problem seems to have cleared now - I have cleared the exclusions and Firefox now seems to open in a normal time

more options

Restore the extensions one at a time, restarting Firefox, and see if the issue returns. If it does, post the extension here.

more options

Cleared all extensions one at a time and FF works fine now.

Thank you