Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Unresponsive script error when clicking on slideshow image link

  • 31 uphendule
  • 8 zinale nkinga
  • 888 views
  • Igcine ukuphendulwa ngu pellky

more options

All of a sudden Flash slideshows I have installed are getting an "unresponsive script" error when you click on any of the hyperlinked slideshow images. After clicking on the image, it takes a long time for the page to change, then the "unresponsive script" warning window pops up identifying this page as the culprit with a :16 at the end.

Example: http://accessretirement.com/new

The slideshow itself works fine, it is the hyperlink that is a problem. I didn't change the script. This happens in Safe Mode as well. Also happens on Windows laptop. Does not happen in Safari. Clients are screaming, have tried asking this question before but didn't get an answer. Appreciate any thoughts.

Isisombululo esikhethiwe

Thanks a lot for trying, but it didn't work. I finally just replaced it with an HTML5 slideshow.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (20)

more options

I don't get any unresponsive script. It's best that the consumer contacts us as each case is different.

Some things you can suggest:

  • Update to the latest version of Adobe Flash
  • Clear cache and cookies

Okulungisiwe ngu Andrew

more options

Did both multiple times over last few days. Still get same error on both iMac and Windows laptop, but not in Safari.

more options

See also this previous thread.

more options

That was also my post. I didn't get a satisfactory answer so I rewrote/reposted the question.

more options

A good place to ask advice about web development is at the mozillaZine "Web Development/Standards Evangelism" forum.

The helpers at that forum are more knowledgeable about web development issues.
You need to register at the mozillaZine forum site in order to post at that forum.

more options

This is not a development issue. It worked fine until the last Firefox update...

more options

Things change and specifications can change between updates. Also it can happen that previously a -moz prefix was required and that now an unprefixed version is supported.

more options

This is simply a hyperlink issue. It has nothing to do with running a script.

more options

Hi pellky, you wrote:

This is simply a hyperlink issue. It has nothing to do with running a script.

I think it's not an ordinary HTML hyperlink, but navigation generated by ActionScript in your Flash media. If you dump Flash and switch to a JavaScript slider with ordinary hyperlinks, that may well solve your problem.

(For the record, as I noted in the other thread, I don't get an error message, just a delay in navigation.)

more options

I got rid of the warning window by changing something in about:config but it doesn't solve the problem of it taking forever to get to the new page once the image link is clicked. The navigation is in an XML script. It works fine in Safari, why not Firefox? I have at least 15 of these kind of slideshows, not inclined to change them all out just for Firefox.

more options

I am having the same issue as pellky, but in this case it's a swf file that streams FLV files with a link. Clicking on the video normally takes users to a new page. In FF it throws up the Unresponsive script error, while on Chrome and Safari it works fine. This is a very recent issue and nothing was changed in the code.

Tried the safe FF mode, that didn't fix it.

more options

Hi designjockey, if it's a Windows Vista - 7 -8 system, does it make any difference if you disable the Flash player plugin's protected mode? See this support article from Adobe under the heading "Last Resort": Adobe Forums: How do I troubleshoot Flash Player's protected mode for Firefox?

This might solve some Flash-related script errors, but might not have any effect on the slow navigation.

more options

Hey jscher2000,

This was tested on multiple machines including Mac Snow Leopard, Mac Lion, Win 7. There is no error in the Flash itself, the script error is coming from the browser when clicked on the banner to invoke a link.

more options

Same problem on Mountain Lion. Works fine in both Chrome and Safari. This is a very recent error, within a couple of weeks.

more options

Yes it is very recent, pellky, we only noticed it today so it can't be that old.

more options

Someone who is good with debuggers/profilers could investigate where the delay is.

more options

jscher2000, I already tried debugger, with no luck.

more options

I first reported this on 8/5. Is that considered "very recent" when clients are screaming because their customers can't get to the landing pages that sell their products?

more options

Has anyone filed a bug on this? I can't find one. https://bugzilla.mozilla.org/

more options

I am not a Flash developer, but based on trying to understand how Flash is interacting with Firefox, it might be helpful to indicate:

(1) Whether you are using the ActionScript 2 getURL() method or the ActionScript 3 navigateToURL() method, or some other method; and

(2) Whether the destination URL is known to your script at the time of the click or must be retrieved using a network request.

  1. 1
  2. 2