X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Unable to enter URL into location bar

Kuphostiwe

Steps to reproduce:

This issue is sporadic on starting Firefox and I cannot determine any pattern to reproduce the problem...sometimes it persists, other times there is no issue


Actual results:

On starting Firefox the entire location bar is greyed-out. All windows work but it is impossible to enter a URL, only follow links.

It is possible to Ctrl+A the URL and paste into, say, Notepad, but you cannot paste into the location bar, delete or alter it. This applies to all tabs including new (Ctrl+T) tabs. However, a new window (Ctrl+N) opens and the location bar then works properly. On-page fields work as well, so you can navigate say by going to Google and entering the URL into the on-page input field and following the link provided and I can get to Google via the bookmarkes toolbar which leads to the next issue...

The bookmarks and navigation bar can simply not appear; you open Fx and it's in something like a locked-down popped window format with no nav or bookmark toolbars. They are enabled in the View menu, but are not visible, and switching them off and on again does not help things.

Often closing down FF/Fx and restarting the machine cures the issue(s), but sometimes it's necessary to Ctrl+N and drag your remembered tabs to the new window to get back to a workable browser.

This has happened through numerous FF/Fx versions and is on Win 7 fully patched. It is NOT related to the specific version of Firefox.


Expected results:

It would be nice just to have a consistent working browser. There seems no rhyme nor reason to this. One time everything is fine. Close down the machine, restart, opend Fx and look an unusable location bar. Restart and it may go...or it may not in which case Ctrl+N, drag yours tabs over to the new working window and ditech the non-working window. Very frustrating....

Steps to reproduce: This issue is sporadic on starting Firefox and I cannot determine any pattern to reproduce the problem...sometimes it persists, other times there is no issue Actual results: On starting Firefox the entire location bar is greyed-out. All windows work but it is impossible to enter a URL, only follow links. It is possible to Ctrl+A the URL and paste into, say, Notepad, but you cannot paste into the location bar, delete or alter it. This applies to all tabs including new (Ctrl+T) tabs. However, a new window (Ctrl+N) opens and the location bar then works properly. On-page fields work as well, so you can navigate say by going to Google and entering the URL into the on-page input field and following the link provided and I can get to Google via the bookmarkes toolbar which leads to the next issue... The bookmarks and navigation bar can simply not appear; you open Fx and it's in something like a locked-down popped window format with no nav or bookmark toolbars. They are enabled in the View menu, but are not visible, and switching them off and on again does not help things. Often closing down FF/Fx and restarting the machine cures the issue(s), but sometimes it's necessary to Ctrl+N and drag your remembered tabs to the new window to get back to a workable browser. This has happened through numerous FF/Fx versions and is on Win 7 fully patched. It is NOT related to the specific version of Firefox. Expected results: It would be nice just to have a consistent working browser. There seems no rhyme nor reason to this. One time everything is fine. Close down the machine, restart, opend Fx and look an unusable location bar. Restart and it may go...or it may not in which case Ctrl+N, drag yours tabs over to the new working window and ditech the non-working window. Very frustrating....

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Shockwave Flash 11.7 r700
  • Google Update
  • VLC media player Web Plugin 2.0.6
  • Next Generation Java Plug-in 10.21.2 for Mozilla browsers
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.02
  • The plugin allows you to have a better experience with Microsoft Lync
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • Nokia Suite Enabler Plugin

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 6.1; rv:22.0) Gecko/20100101 Firefox/22.0

Eminye Imininingwane

philipp
  • Top 25 Contributor
  • Moderator
5320 izisombululo 23495 izimpendulo
Kuphostiwe

hello, can you try to replicate this behaviour when you launch firefox in safe mode once? if not, maybe an addon is interfering here...

Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems

hello, can you try to replicate this behaviour when you launch firefox in safe mode once? if not, maybe an addon is interfering here... [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]]

Umnikazi wombuzo

Just typeed an extensive answer which was lost during a preview. Damn!

Basically all the info is at https://bugzilla.mozilla.org/show_bug.cgi?id=890745 as this is IMHO a *bug* and not a support issue.

But:

  1. I can have one window with the location bar disabled in all tabs, and
  2. a second window where the location bar works just fine

So same Fx, same config, same Add-Ons, different behaviour.

The problem is not predicable and so at the moment, since a crash and reatart last night, Fx is working fine and so I can't test to see whether a Safe-Mode start fixes a problem that isn't showing right now.

It's very erratic behaviour...

Just typeed an extensive answer which was lost during a preview. Damn! Basically all the info is at https://bugzilla.mozilla.org/show_bug.cgi?id=890745 as this is IMHO a *bug* and not a support issue. But: # I can have one window with the location bar disabled in all tabs, and # a second window where the location bar works just fine So same Fx, same config, same Add-Ons, different behaviour. The problem is not predicable and so at the moment, since a crash and reatart last night, Fx is working fine and so I can't test to see whether a Safe-Mode start fixes a problem that isn't showing right now. It's very erratic behaviour...
cor-el
  • Top 10 Contributor
  • Moderator
17566 izisombululo 158879 izimpendulo
Kuphostiwe

It is usually best to move all tabs to a new or another existing window that works if the location bar in a specific window isn't working or if there are otherwise problems in a specific window.
Then close the misbehaving window and possibly close and restart Firefox.

It is usually best to move all tabs to a new or another existing window that works if the location bar in a specific window isn't working or if there are otherwise problems in a specific window.<br /> Then close the misbehaving window and possibly close and restart Firefox.

Impendulo Ewusizo

Yes this is what I usually do although sometimes the new window is forced to be a single pane and a Ctrl+T in the new window actually opens a new tab in the original window and so inherits the greyed-out location bar problem.

I've been working around this for a time but it's a bug; Fx shouldn't be locking out the location bar and so I reported it as a bug, but the dev people seem totally disinterested in diagnosing this and moved it to support...for what purpose? Sorry, IMHO it wastes people's time. I'd really hoped someone would take an interest in this behaviour, but it seems not.

To me the software is not functioning as it should. I've been in software for 30-something years now and using and developing on the web since before Spry Mosaic was out, so what I really needed was someone to want to fix the issue, not shunt it off to a support group who can give advice but sadly not fix the code which is what needs to be done.

Oh well...

Yes this is what I usually do although sometimes the new window is forced to be a single pane and a Ctrl+T in the new window actually opens a new tab in the original window and so inherits the greyed-out location bar problem. I've been working around this for a time but it's a bug; Fx shouldn't be locking out the location bar and so I reported it as a bug, but the dev people seem totally disinterested in diagnosing this and moved it to support...for what purpose? Sorry, IMHO it wastes people's time. I'd really hoped someone would take an interest in this behaviour, but it seems not. To me the software is not functioning as it should. I've been in software for 30-something years now and using and developing on the web since before Spry Mosaic was out, so what I really needed was someone to want to fix the issue, not shunt it off to a support group who can give advice but sadly not fix the code which is what needs to be done. Oh well...
the-edmeister
  • Top 25 Contributor
  • Moderator
5411 izisombululo 40287 izimpendulo
Kuphostiwe

Comment 2 in your Bug report: "If this ocuured after adding an add-on it would make more sense to do this, but it comes and it goes on a sporadic basis with the same add-ons ..."

But are your add-ons exactly the same since before this started?
One add-on getting updated could be causing that "bug". Or the wrong mix of add-ons in combination with add-ons being updated.

Basic troubleshooting, as philipp mentioned in the first response here, is the starting point for diagnosing your problem.

Another thing that might be helpful for us to help you, is a list of all your installed extensions. One of us might be able to spot an extension that we have heard mentioned as being problematic, or maybe identify a combination of extensions which might be causing that problem.

Comment 2 in your Bug report: '''"If this ocuured after adding an add-on it would make more sense to do this, but it comes and it goes on a sporadic basis with the same add-ons ..."''' But '''''are''''' your add-ons '''exactly''' the same since before this started? <br /> One add-on getting updated could be causing that "bug". Or the wrong mix of add-ons in combination with add-ons being updated. Basic troubleshooting, as '''''philipp''''' mentioned in the first response here, is the starting point for diagnosing your problem. Another thing that might be helpful for us to help you, is a list of all your installed extensions. One of us might be able to spot an extension that we have heard mentioned as being problematic, or maybe identify a combination of extensions which might be causing that problem.
cor-el
  • Top 10 Contributor
  • Moderator
17566 izisombululo 158879 izimpendulo
Kuphostiwe

If Ctrl+T opens a link in the original window then you are likely in a pop-up window opened from that originating window.

See also these articles on how to prevent websites from disabling the location bar and other toolbars:

If Ctrl+T opens a link in the original window then you are likely in a pop-up window opened from that originating window. See also these articles on how to prevent websites from disabling the location bar and other toolbars: *http://kb.mozillazine.org/Prevent_websites_from_disabling_new_window_features *http://kb.mozillazine.org/JavaScript#Advanced_JavaScript_settings

Okulungisiwe ngu cor-el

Umnikazi wombuzo

When Fx is having one of 'these turns' a new window (Ctrl+N can indeed look like a pop-up sometimes with no bookmarks bar (despite it being shown an enabled) and sometimes without back and forward buttons, BUT the window is not in fact a pop-up but created by Ctrl+N or File:New Window

When Fx is having one of 'these turns' a new window (Ctrl+N can indeed look like a pop-up sometimes with no bookmarks bar (despite it being shown an enabled) and sometimes without back and forward buttons, BUT the window is not in fact a pop-up but created by Ctrl+N or File:New Window

Umnikazi wombuzo

Yes, the Add-Ons are *exactly* the same in all cases. I tend not to add and remove them and so all will be well...no issues. Shut the machine down, restart, start Fx and it *may* start with a greyed out/inactive location bar in all restored tabs. Open a new window (Ctrl+N) and the location bar will be fine...so two windows running side by side, same Add-Ons, different behaviour. I'muncertain whether the two windows run in separate address space??

Shut down Fx, restart the machine, restart Fx and it may well all be fine...same Add-Ons, but now all working.

And then on one occasion Fx started with the restored tabs with the greyed-out location bar but a new window (only single pane - Ctlr+T would only open new tabs in the original window) working fine. As I had stuff to do I worked in this mode and then Fx crashed. And then the big surprise. It autorestarted and now the original window with the multiple tabs worked fine and it was the second single pane window that had the greyed out location bar. So same Add-ons, same Windows OS boot, just a Fx restart after a crash report and the behaviour swapped windows.

Now as to diagnosing, yes agreed. I am in fact a senior Internet service archirect and so I diagnose issues all the time, but you might also now see that a flippant; 'It's your last add-on man' does not fit the observed behaviour. There is something deeper going on, particularly the issues flipping windows case.

Listing add-ons is a good idea, so...

Active...
Akamai Headers 1.0.10
CodeBurner for Firefox 1.6
CSS Usage 0.3.2
Firebug 1.11.4
Flagfox 4.2.10
Garmin Communicator 4.0.4
Good Website Inspector 1.0RC2
HttpFox 0.8.12
Live HTTP Headers 0.17
LogMeIn Remote Access Plugin 1.0.0.1024
Norton Toolbar 2013.4.1.2
PDF Architect Converter for Firefox 1.0
Places Maintence 1.3
Pocket 3.0.4
SearchPreview 6.3
Tamper Data 11.0.1
ToolbarBrowser 1.3.2
TotalValidator 8.1.0
Web Metrics Framework 0.1.2
YBS Account Aggregation 1.0.0.197 (don't use this really so maybe one for the bin)
YSlow 3.1.4 (which doesn't appear to work with Fx v22)

Disabled...
Download Youtube Videos + 12.9.6
Flash and Video Download 1.35
Norton Vulnerability Protection 11.3.0.9 - 5 (not yet compatible with v22)
Yontoo 1.20.02 (not sure why this is there...another likely to go in the bin)
Yes, the Add-Ons are *exactly* the same in all cases. I tend not to add and remove them and so all will be well...no issues. Shut the machine down, restart, start Fx and it *may* start with a greyed out/inactive location bar in all restored tabs. Open a new window (Ctrl+N) and the location bar will be fine...so two windows running side by side, same Add-Ons, different behaviour. I'muncertain whether the two windows run in separate address space?? Shut down Fx, restart the machine, restart Fx and it may well all be fine...same Add-Ons, but now all working. And then on one occasion Fx started with the restored tabs with the greyed-out location bar but a new window (only single pane - Ctlr+T would only open new tabs in the original window) working fine. As I had stuff to do I worked in this mode and then Fx crashed. And then the big surprise. It autorestarted and now the original window with the multiple tabs worked fine and it was the second single pane window that had the greyed out location bar. So same Add-ons, same Windows OS boot, just a Fx restart after a crash report and the behaviour swapped windows. Now as to diagnosing, yes agreed. I am in fact a senior Internet service archirect and so I diagnose issues all the time, but you might also now see that a flippant; 'It's your last add-on man' does not fit the observed behaviour. There is something deeper going on, particularly the issues flipping windows case. Listing add-ons is a good idea, so... <pre><nowiki>Active... Akamai Headers 1.0.10 CodeBurner for Firefox 1.6 CSS Usage 0.3.2 Firebug 1.11.4 Flagfox 4.2.10 Garmin Communicator 4.0.4 Good Website Inspector 1.0RC2 HttpFox 0.8.12 Live HTTP Headers 0.17 LogMeIn Remote Access Plugin 1.0.0.1024 Norton Toolbar 2013.4.1.2 PDF Architect Converter for Firefox 1.0 Places Maintence 1.3 Pocket 3.0.4 SearchPreview 6.3 Tamper Data 11.0.1 ToolbarBrowser 1.3.2 TotalValidator 8.1.0 Web Metrics Framework 0.1.2 YBS Account Aggregation 1.0.0.197 (don't use this really so maybe one for the bin) YSlow 3.1.4 (which doesn't appear to work with Fx v22) Disabled... Download Youtube Videos + 12.9.6 Flash and Video Download 1.35 Norton Vulnerability Protection 11.3.0.9 - 5 (not yet compatible with v22) Yontoo 1.20.02 (not sure why this is there...another likely to go in the bin) </nowiki></pre>

Okulungisiwe ngu cor-el

jscher2000
  • Top 10 Contributor
8783 izisombululo 71825 izimpendulo
Kuphostiwe

Impendulo Ewusizo

Although your symptoms are inconsistent and unusual, it might a corrupted settings file. You can rename the file that store toolbar customization and window layout data and customize from scratch.

Open your current Firefox settings (AKA Firefox profile) folder using

Help > Troubleshooting Information > "Show Folder" button

Switch back to Firefox and Exit

Pause while Firefox finishes its cleanup, then rename localstore.rdf to something like localstore.old

Restart Firefox. Does this have any effect (over time, obviously)?

Although your symptoms are inconsistent and unusual, it might a corrupted settings file. You can rename the file that store toolbar customization and window layout data and customize from scratch. Open your current Firefox settings (AKA Firefox profile) folder using Help > Troubleshooting Information > "Show Folder" button Switch back to Firefox and Exit Pause while Firefox finishes its cleanup, then rename '''localstore.rdf''' to something like localstore.old Restart Firefox. Does this have any effect (over time, obviously)?

Umnikazi wombuzo

Thanks @jscher2000. I do recall recreating my profile before, but this would be worth a try. The bit I find the most intriging is the creash and restart and the swapping of behaviour. It's as if the two windows where in a race condition to read something like a profile property and and the 'new' window won the race and so picked up the defective location bar.

Now there's a clue here. What property in the profile store gets read by a window starting up and then rewritten, e.g. the window that won the race (and ended up with the defective location bar) read the defective property but then rewrote it so the 'losing' window then read a corrected value and opened properly?

I'd have to pull the store apart to see what is done to it when a window opens, but then this is the kind of thing I thought the dev team would be interested in because if there is an opportunity for this to happen, really the code should be more defensive and so not go into the hobbled state due to reading some presumed corrupt profile property.

I am just so disappointed that no one wanted to look at this issue so as to build a more resilient product :-(

Thanks @jscher2000. I do recall recreating my profile before, but this would be worth a try. The bit I find the most intriging is the creash and restart and the swapping of behaviour. It's as if the two windows where in a race condition to read something like a profile property and and the 'new' window won the race and so picked up the defective location bar. Now there's a clue here. What property in the profile store gets read by a window starting up and then rewritten, e.g. the window that won the race (and ended up with the defective location bar) read the defective property but then rewrote it so the 'losing' window then read a corrected value and opened properly? I'd have to pull the store apart to see what is done to it when a window opens, but then this is the kind of thing I thought the dev team would be interested in because if there is an opportunity for this to happen, really the code should be more defensive and so not go into the hobbled state due to reading some presumed corrupt profile property. I am just so disappointed that no one wanted to look at this issue so as to build a more resilient product :-(
cor-el
  • Top 10 Contributor
  • Moderator
17566 izisombululo 158879 izimpendulo
Kuphostiwe
See also: *http://kb.mozillazine.org/Prevent_websites_from_disabling_new_window_features *http://kb.mozillazine.org/JavaScript#Advanced_JavaScript_settings
jscher2000
  • Top 10 Contributor
8783 izisombululo 71825 izimpendulo
Kuphostiwe

I see you are disappointed about the bug report being closed, but in order to get a bug queued up for resolution, they need a set of steps that will repeatably cause the condition. Otherwise, it's a needle in a haystack and those tend to languish behind major crashers and all the other high-priority work that demands attention. Although it may seem like a detour, referring it here for troubleshooting is the best way to pin it down and shape it up for fixing.

I see you are disappointed about the bug report being closed, but in order to get a bug queued up for resolution, they need a set of steps that will repeatably cause the condition. Otherwise, it's a needle in a haystack and those tend to languish behind major crashers and all the other high-priority work that demands attention. Although it may seem like a detour, referring it here for troubleshooting is the best way to pin it down and shape it up for fixing.

Umnikazi wombuzo

Okay, so a little more feedback.

Norton did an update and demanded a restart. Restarted Win7 at which point Flash wanted an update. This completed with launching a browser window to confirm installation. Fx then opened two windows, one being the multi-tab restored session prior to the shut-down and the one a single pane being the Flash confirmation.

Going to the 'main' window, e.g. the multi-tab restored window from the session prior to the restart, Ctrl+T opened a new window each time, hence why the Flash confirmation had started in a new window.

So I then closed the Flash single pane window, then closed the 'main' multi-tab window and restarted Fx. Fx started with the 'main' multi-tab window plus it restored the single pane that the Flash confirmation had opened. Any clues in the 'session restoration' opening a window close prior to the last window close of Fx??

Then of more interest, the location bar worked in both windows, but the bookmarks menu was missing from the 'main' window. This is another of the 'funnies' Fx likes to throw at me once and a while.

So closed Fx and simply restarted and the bookmarks toolbar was back in the multi-tab window, but now the location bar is greyed-out again. The location bar works fine if I open a new window (Ctrl+N) but opening a new tab (Ctrl+T) in the new window actually opens a new tab in the 'main' multi-tab window with the location bar greyed-out again.

I will try another close and reopen to Fx which may well fix things, but the point of me going through all this is there's been suggestions of trying Fx in Safe Mode and working through which add-on might be causing the problem. BUT... my issue is that as the behaviour is so erratic and indeed a simple restart often curing the problem, I'll never know whether the change is due to a change I've made (add-on disabled or removed) or simply the roll of the dice on how things start.

Note how sinple closing and restarting Fx in the sequence explained above gives different results each time. How then do I draw a conclusion on running in Safe Mode or disabling/removing an Add-On when a close and restart might have resolved the issue anyway.

I'll likely post some more 'exciting adventures' shortly...

Okay, so a little more feedback. Norton did an update and demanded a restart. Restarted Win7 at which point Flash wanted an update. This completed with launching a browser window to confirm installation. Fx then opened two windows, one being the multi-tab restored session prior to the shut-down and the one a single pane being the Flash confirmation. Going to the 'main' window, e.g. the multi-tab restored window from the session prior to the restart, Ctrl+T opened a new window each time, hence why the Flash confirmation had started in a new window. So I then closed the Flash single pane window, then closed the 'main' multi-tab window and restarted Fx. Fx started with the 'main' multi-tab window plus it restored the single pane that the Flash confirmation had opened. Any clues in the 'session restoration' opening a window close prior to the last window close of Fx?? Then of more interest, the location bar worked in both windows, but the bookmarks menu was missing from the 'main' window. This is another of the 'funnies' Fx likes to throw at me once and a while. So closed Fx and simply restarted and the bookmarks toolbar was back in the multi-tab window, but now the location bar is greyed-out again. The location bar works fine if I open a new window (Ctrl+N) but opening a new tab (Ctrl+T) in the new window actually opens a new tab in the 'main' multi-tab window with the location bar greyed-out again. I will try another close and reopen to Fx which may well fix things, but the point of me going through all this is there's been suggestions of trying Fx in Safe Mode and working through which add-on might be causing the problem. BUT... my issue is that as the behaviour is so erratic and indeed a simple restart often curing the problem, I'll never know whether the change is due to a change I've made (add-on disabled or removed) or simply the roll of the dice on how things start. Note how sinple closing and restarting Fx in the sequence explained above gives different results each time. How then do I draw a conclusion on running in Safe Mode or disabling/removing an Add-On when a close and restart might have resolved the issue anyway. I'll likely post some more 'exciting adventures' shortly...

Umnikazi wombuzo

Okay, so a restart on Win7 did *not* cure the problem and so have now started in Safe Mode...same results! So the 'main' multi pane window, no bookmarks bar and the location is grey-out again.

Close and restart Fx and bookmarks are back but the location bar is still greyed-out.

Opening a new window (Ctrl+N) and the location bar is fine, but opening a new tab (Ctrl+T) in the new window actually opens a new tab in the original main window, complete with greyed-out location bar.

But I think the one conclusion I would draw from this is that isn't not an Add-On issue, otherwise Safe Mode would have been expected to cure all, and it didn't.

That to me points towards something like profile, but why is the location greyed-out in one window and not a new window?

Okay, so a restart on Win7 did *not* cure the problem and so have now started in Safe Mode...same results! So the 'main' multi pane window, no bookmarks bar and the location is grey-out again. Close and restart Fx and bookmarks are back but the location bar is still greyed-out. Opening a new window (Ctrl+N) and the location bar is fine, but opening a new tab (Ctrl+T) in the new window actually opens a new tab in the original main window, complete with greyed-out location bar. But I think the one conclusion I would draw from this is that isn't not an Add-On issue, otherwise Safe Mode would have been expected to cure all, and it didn't. That to me points towards something like profile, but why is the location greyed-out in one window and not a new window?
jscher2000
  • Top 10 Contributor
8783 izisombululo 71825 izimpendulo
Kuphostiwe

Have you tried renaming the localstore.rdf file and allowing Firefox to regenerate it as described in this post: https://support.mozilla.org/en-US/questions/964456#answer-456049

Have you tried renaming the localstore.rdf file and allowing Firefox to regenerate it as described in this post: https://support.mozilla.org/en-US/questions/964456#answer-456049
cor-el
  • Top 10 Contributor
  • Moderator
17566 izisombululo 158879 izimpendulo
Kuphostiwe

Safe Mode would also Firefox makes use a localstore-safe.rdf.

Create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

If the new profile works then you can transfer some files from an existing profile to the new profile, but be careful not to copy corrupted files.

Safe Mode would also Firefox makes use a localstore-safe.rdf. Create a new profile as a test to check if your current profile is causing the problems. See "Creating a profile": *https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles *http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Profile_issues If the new profile works then you can transfer some files from an existing profile to the new profile, but be careful not to copy corrupted files. *http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox

Umnikazi wombuzo

Yes, will try the profile ideas. This seems the most likely source of the problems given the Add-Ons seem to have been exclused, BUT...

You say in Safe Mode Fx would use localstore-safe.rdf. I presume this is the reasoninf for the bookmark bar disappearing? But then if the hypothosis is it's the store causing the problem and a different store was used in Safe Mode yet the location being greyed-out continued that rather points to the issue not being the profile store?

Yes, will try the profile ideas. This seems the most likely source of the problems given the Add-Ons seem to have been exclused, BUT... You say in Safe Mode Fx would use localstore-safe.rdf. I presume this is the reasoninf for the bookmark bar disappearing? But then if the hypothosis is it's the store causing the problem and a different store was used in Safe Mode yet the location being greyed-out continued that rather points to the issue not being the profile store?
cor-el
  • Top 10 Contributor
  • Moderator
17566 izisombululo 158879 izimpendulo
Kuphostiwe

Did you visit websites that may have opened a popup window, possibly in a Firefox tab?

Websites can disable specific elements in the user interface via JavaScript like listed in the MozillaZine KB article that I listed above.

Did you visit websites that may have opened a popup window, possibly in a Firefox tab? Websites can disable specific elements in the user interface via JavaScript like listed in the MozillaZine KB article that I listed above. *http://kb.mozillazine.org/Prevent_websites_from_disabling_new_window_features