X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

on firefox, my bengali fonts fragment. how can i fix it

Kuphostiwe

when i browse facebook on firefox, bangla fonts fragment. I cannot read and understand. how can i solve it?

when i browse facebook on firefox, bangla fonts fragment. I cannot read and understand. how can i solve it?

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Shockwave Flash 11.7 r700
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.02

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 6.1; rv:20.0) Gecko/20100101 Firefox/20.0

Eminye Imininingwane

David Tenser 30 izisombululo 310 izimpendulo
Kuphostiwe

Impendulo Ewusizo

Hi there,

I'm not too familiar with this type of problems, but let me ask you some questions to try to get closer to a solution:

  • Is this a recent problem for you - did you have this problem in your previous version of Firefox or are you a new Firefox user?
  • Have you tried the Encoding options in the View menu? You can press the Alt key on your keyboard to reveal the Firefox menu. From there, you should be able to find the View menu.

Cheers, David

Hi there, I'm not too familiar with this type of problems, but let me ask you some questions to try to get closer to a solution: * Is this a recent problem for you - did you have this problem in your previous version of Firefox or are you a new Firefox user? * Have you tried the Encoding options in the View menu? You can press the Alt key on your keyboard to reveal the Firefox menu. From there, you should be able to find the View menu. Cheers, David
cor-el
  • Top 10 Contributor
  • Moderator
17416 izisombululo 157344 izimpendulo
Kuphostiwe

You can use this extension to see which fonts are used for text that is selected (right-click context menu: Show fonts in selection).

You can try different default fonts and temporarily disable website fonts to test the selected default font.

  • Tools > Options > Content : Fonts & Colors > Advanced
  • [ ] "Allow pages to choose their own fonts, instead of my selections above"
You can use this extension to see which fonts are used for text that is selected (right-click context menu: Show fonts in selection). *fontinfo: https://addons.mozilla.org/firefox/addon/fontinfo/ You can try different default fonts and temporarily disable website fonts to test the selected default font. *Tools > Options > Content : Fonts & Colors > Advanced *[ ] "Allow pages to choose their own fonts, instead of my selections above"
Ferdous_Zahid 0 izisombululo 1 izimpendulo
Kuphostiwe
  1. Please, download Windows 7 font "Shonar Bangla". Then copy it in C:\WINDOWS\Fonts folder.
  2. Please, disable website fonts to see the selected default Bengali font by following the below steps.
  • Go to: Tools > Options > Content : Fonts & Colors > Advanced
  • Please, selct the below.
  • Fonts for: Select "Bengali"
  • Serif: Select "Shonar Bangla"
  • Sans-serif: Select "Shonar Bangla"
  • Size: 30
  • Please, uncheck the box: [ ] "Allow pages to choose their own fonts, instead of my selections above"
# Please, '''download''' Windows 7 font "'''Shonar Bangla'''". Then copy it in C:\WINDOWS\Fonts folder. # Please, disable website fonts to see the selected default Bengali font by following the below steps. * Go to: '''Tools > Options > Content : Fonts & Colors > Advanced''' * Please, selct the below. * '''Fonts for:''' Select "Bengali" * '''Serif:''' Select "Shonar Bangla" * '''Sans-serif:''' Select "Shonar Bangla" * '''Size:''' 30 * Please, '''uncheck''' the box: [ ] "Allow pages to choose their own fonts, instead of my selections above"

Okulungisiwe ngu Ferdous_Zahid

Ahbab 0 izisombululo 1 izimpendulo
Kuphostiwe

Impendulo Ewusizo

To fix it in your latest firefox versions (22.0 or later) simply go to

tools > options > content

there you will see the fonts & color menu in the mid section

click on advanced and you will go to advanced fonts field

select the following:

font for: Bengali size:16

proportional: Sans Serif

serif: Siyam Rupali

sans serif: Siyam Rupali

Monospace: Siyam Rupali size:14

DO NOT UNCHECK "Allow pages to select their own fonts, ..." checkbox

and then at the bottom

Set Fallback Character Encoding: Western (ISO-8859-15)

Click ok and ok and voila there you are. All of your problems has been fixed :)

To fix it in your latest firefox versions (22.0 or later) simply go to tools > options > content there you will see the fonts & color menu in the mid section click on advanced and you will go to advanced fonts field select the following: font for: Bengali size:16 proportional: Sans Serif serif: Siyam Rupali sans serif: Siyam Rupali Monospace: Siyam Rupali size:14 DO NOT UNCHECK "Allow pages to select their own fonts, ..." checkbox and then at the bottom Set Fallback Character Encoding: Western (ISO-8859-15) Click ok and ok and voila there you are. All of your problems has been fixed :)
introvert_munna 0 izisombululo 1 izimpendulo
Kuphostiwe

I have posted a post about this problem solution with video tutorial. You can read The post . I hope your problem will be resolved.

I have posted a post about this problem solution with video tutorial. You can read [http://bdinfoguide.blogspot.com/2013/07/bangla-font-problem-solution-in-firefox.html#more The post ] . I hope your problem will be resolved.

Okulungisiwe ngu introvert_munna

ArunangshuPal 0 izisombululo 1 izimpendulo
Kuphostiwe

The solution is: Kalpurush.

Probably the font Siyam Rupali does not work in the latest version of Firefox. Change the Bengali font to Kalpurush, and it will work.

Just go to Options and change the font to Kalpurush under Fonts & Colors. Click on Advanced and make all the font options as Kalpurush.

It has worked for me and now I can read Bengali text on websites without any problem.

The solution is: Kalpurush. Probably the font Siyam Rupali does not work in the latest version of Firefox. Change the Bengali font to Kalpurush, and it will work. Just go to Options and change the font to Kalpurush under Fonts & Colors. Click on Advanced and make all the font options as Kalpurush. It has worked for me and now I can read Bengali text on websites without any problem.