Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox 7.0.1 ignoring custom settings for 'Clear History'

  • 19 uphendule
  • 1 inale nkinga
  • 31 views
  • Igcine ukuphendulwa ngu Holmemoss

more options

I have a MacBook Pro with OS 10.6.8 and Firefox 7.0.1

Under Preferences > Privacy, I have custom settings to clear browsing history every time Firefox closes.

However, when I relaunch Firefox, the 'Restore Previous Session' is highlighted under the History menu and I can restore the previous session.

How is this happening?

Thank you.

All Replies (19)

more options

On Windows, there are two places for the "clearing history" option for FF, there's a second one under "Advanced" and "Security".

Do you have that option on Mac?

more options

No, there is no 'Security' tab under the Advanced Preferences on the Mac version.

more options

Sorry, but I have Windows...hopefully somebody will roll out of bed and help you soon!

Good luck!

more options

It is possible that there is a problem with the files sessionstore.js and sessionstore.bak in the Firefox Profile Folder.

Delete the files sessionstore.js [2] and sessionstore.bak in the Firefox Profile Folder.

If you see files sessionstore-##.js with a number in the left part of the name like sessionstore-1.js then delete those as well.
Deleting sessionstore.js will cause App Tabs and Tab Groups and open and closed (undo) tabs to get lost, so you will have to create them again (make a note or bookmark them).

See also:

more options

Thank you.

There is a sessionstore.js file in the Profile Folder but no sessionstore.bak file nor any other sessionstore files.

I quit Firefox, deleted the sessionstore.js file, relaunched Firefox and went to one web site. I quit Firefox again, relaunched Firefox but 'Restore Previous Session' was still highlighted and did remember the one web site.

more options
  • Try this.
  • Type in the address bar about:config.
  • Accept the warning.
  • In the page that appears, in the Filter box, type browser.sessionstore.restore_on_demand
  • Change the boolean value to false (which is probably set to true in your case).
  • Close the about:config page.
  • Restart the browser

Okulungisiwe ngu amkeew

more options

Thank you but when I type browser.sessionstore.restore_on_demand in the Filter box there is nothing there.

more options

May be it's different in mac. Try typing just "restore" and what it brings.

more options

There is browser.sessionstore.restore_hidden_tabs but it is set to false

more options

If you have private browsing mode, enable it and see what happens.

more options

No history and no 'Restore Previous Session' is maintained in Private Browsing mode.

more options

Are any sessionstore pref user set (bold) on the about:config page to indicate that they got changed?

more options

There are the following boolean type files under browser.sessionstore, none of which are in bold

.restore_hidden_tabs set to false

.resume_from_crash set to true

.resume_session_once set to false

There are several integer files including

.privacy_level, the integer being 0

.privacy_level_deferred, the integer being 1

more options

Change .resume_from_crash to false and see what happens.

more options

No difference, 'Restore Previous Session' is still there.

more options

Then I suggest a clean reinstall of FF. Use a free program like revo uninstaller to remove the old FF. Export your bookmarks to a html file before you uninstall the old FF.

more options

Thank you. I have AppDelete so I shall give it a try.

One question before I do; will this also delete my add-ons?

more options

Yes, the add-ons will be deleted. Better to save your add-ons page so that you can re-install them.

more options

I tried that but it is still the same with 'Restore Previous Session' still being there.

Thank you astrocatlady, cor-el and amkeew for trying to help. There is something amiss so I have gone into permanent Private Browsing mode.