X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox did an automatic update to 6.01, and now my middle mouse button is not working in the browser. It doesn't close tabs, it doesn't open new tabs by middle clicking a link, it doesn't allow me to middle click to scroll the page...

Kuphostiwe

Firefox did an automatic update to 6.01, and now my middle mouse button is not working in the browser. It doesn't close tabs, it doesn't open new tabs by middle clicking a link, it doesn't allow me to middle click to scroll the page..

Firefox did an automatic update to 6.01, and now my middle mouse button is not working in the browser. It doesn't close tabs, it doesn't open new tabs by middle clicking a link, it doesn't allow me to middle click to scroll the page..

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Google Talk Plugin Video Accelerator version:0.1.44.9
  • Version 2.2.2.0
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.3"
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Google Update
  • Unity Player 3.4.0f5
  • Shockwave Flash 10.1 r85
  • Shockwave Flash 10.3 r183
  • Next Generation Java Plug-in 1.6.0_26 for Mozilla browsers
  • 4.0.60310.0
  • Office Authorization plug-in for NPAPI browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • Version 1.1.8, copyright 1996-2011 The VideoLAN Teamhttp://www.videolan.org/
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:6.0.1) Gecko/20100101 Firefox/6.0.1

Eminye Imininingwane

Zerabp 0 izisombululo 3 izimpendulo
Kuphostiwe

I have this problem too, I can't even press it down any more let alone use it to open new tabs etc. I use a logitech wireless mx5500 revolution desktop if that helps.

I have this problem too, I can't even press it down any more let alone use it to open new tabs etc. I use a logitech wireless mx5500 revolution desktop if that helps.
Qbert 0 izisombululo 1 izimpendulo
Kuphostiwe

I've disabled csfire_1.0.1 addon and after that it's working. (For me at least) Try safe mode without addons enabled.

I've disabled csfire_1.0.1 addon and after that it's working. (For me at least) Try safe mode without addons enabled.
the-edmeister
  • Top 25 Contributor
  • Moderator
5395 izisombululo 40084 izimpendulo
Kuphostiwe

Try the Firefox SafeMode to see how it works there.
A troubleshooting mode, which disables most Add-ons.
(If you're not using it, switch to the Default Theme.)

  • You can open the Firefox 4/5/6/7 SafeMode by holding the Shft key when you use the Firefox desktop or Start menu shortcut.
  • Or use the Help menu item, click on Restart with Add-ons Disabled... while Firefox is running.

Don't select anything right now, just use "Continue in SafeMode."

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before using the Firefox shortcut (without the Shft key) to open it again.

If it is good in the Firefox SafeMode, your problem is probably caused by an extension, and you need to figure out which one.
http://support.mozilla.com/en-US/kb/troubleshooting+extensions+and+themes

Try the Firefox SafeMode to see how it works there. <br /> ''A troubleshooting mode, which disables most Add-ons.'' <br /> ''(If you're not using it, switch to the Default Theme.)'' * You can open the Firefox 4/5/6/7 SafeMode by holding the '''Shft''' key when you use the Firefox desktop or Start menu shortcut. * Or use the Help menu item, click on '''Restart with Add-ons Disabled...''' while Firefox is running. <br /> ''Don't select anything right now, just use "Continue in SafeMode."'' ''To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before using the Firefox shortcut (without the Shft key) to open it again.'' If it is good in the Firefox SafeMode, your problem is probably caused by an extension, and you need to figure out which one. <br /> http://support.mozilla.com/en-US/kb/troubleshooting+extensions+and+themes
last 0 izisombululo 1 izimpendulo
Kuphostiwe

This is my first post, so please forgive any mistakes. I used to have this problem, as well, and at least in my case, it turned out to be unrelated to Firefox, even though it did coincide with the 6.0.1 stable release.

One thing I noticed is that my Windows key shortcuts (ie. Windows key + R to bring up the "run" dialog) stopped working, but the key binding for the windows key itself was still intact (ie. hitting the windows key on Win 7 Pro would still bring up the start menu but none of the shortcut would work).

What did do the trick for me was re-installing the keyboard driver, even though the device manager did not show any conflicts. Hope this helps. :)

Edit: Oh, and running FF with add-ons disabled and with a fresh profile did not resolve the issue for me (which you'd expect since the problem wasn't related to FF, in my case).

This is my first post, so please forgive any mistakes. I used to have this problem, as well, and at least in my case, it turned out to be unrelated to Firefox, even though it did coincide with the 6.0.1 stable release. One thing I noticed is that my Windows key shortcuts (ie. Windows key + R to bring up the "run" dialog) stopped working, but the key binding for the windows key itself was still intact (ie. hitting the windows key on Win 7 Pro would still bring up the start menu but none of the shortcut would work). What did do the trick ''for me'' was re-installing the keyboard driver, even though the device manager did not show any conflicts. Hope this helps. :) Edit: Oh, and running FF with add-ons disabled and with a fresh profile did not resolve the issue for me (which you'd expect since the problem wasn't related to FF, in my case).

Okulungisiwe ngu last

Tenchi-San 0 izisombululo 1 izimpendulo
Kuphostiwe

My Middle Mouse button/wheel works on every thing but opening links in new tabs.

-What works- Opening rss links in new tabs Opening bookmarks in new tabs Opening a closed tab by clicking the middle button/wheel in the tab area Closing a tab

-What doesn't work- Opening a link on a web page in a new tab

I tried opening firefox in safemode and it does work but when I opened it again in normal mode and disabled all of the add-ons it doesn't work. Now, I updated it last night and while it worked before the update now it doesn't. Please help

My Middle Mouse button/wheel works on every thing but opening links in new tabs. -What works- Opening rss links in new tabs Opening bookmarks in new tabs Opening a closed tab by clicking the middle button/wheel in the tab area Closing a tab -What doesn't work- Opening a link on a web page in a new tab I tried opening firefox in safemode and it does work but when I opened it again in normal mode and disabled all of the add-ons it doesn't work. Now, I updated it last night and while it worked before the update now it doesn't. Please help
Zerabp 0 izisombululo 3 izimpendulo
Kuphostiwe

Mine is working again and for me, seems to be related to the foxtabs addon once I removed it it has been working fine.

Mine is working again and for me, seems to be related to the foxtabs addon once I removed it it has been working fine.
teawaste 0 izisombululo 1 izimpendulo
Kuphostiwe

Starting in safe mode, then switching back to normal seems to have resolved the issue for me.

Restarting in safe mode, things were fine, then stayed fine as I tried each add-on afterwards. I'm now running with both add-ons enabled (https-everywhere 1.0.1 and Adblock plus 1.3.9 on mac 10.6.8), and things are back to normal.

Starting in safe mode, then switching back to normal seems to have resolved the issue for me. Restarting in safe mode, things were fine, then stayed fine as I tried each add-on afterwards. I'm now running with both add-ons enabled (https-everywhere 1.0.1 and Adblock plus 1.3.9 on mac 10.6.8), and things are back to normal.
AvohkahTamer 0 izisombululo 1 izimpendulo
Kuphostiwe

Impendulo Ewusizo

[BUG FIXED, see "EDIT 2" at the end of my post]

I'm on Firefox 3.6.21, and I got this problem today after a Greasemonkey update (To version 0.9.10, apparently).

Disabling Greasemonkey solved the problem, and re-enabling it reproduced the problem (middle-clicking links to open in new tab did not work, merely highlighted the link).

I should also note that while Greasemonkey was enabled and the bug was affecting me, Ctrl+Click to open links in new tabs was also broken.

I hope this helps!

EDIT: It appears this is a known incompatibility/conflict bug between current versions of Greasemonkey and Tab Mix Plus. Read more here: https://github.com/greasemonkey/greasemonkey/issues/1406

EDIT 2: GREASEMONKEY HAS NOW BEEN UPDATED with a workaround to fix the problem. Go to https://addons.mozilla.org/en-US/firefox/addon/greasemonkey/versions/ to install the update manually. It hasn't been reviewed by Mozilla yet, so it won't be an automatic update for another day or two. All credit to "cannonfodder" below for noticing this; please mark his post as helpful!

[BUG FIXED, see "EDIT 2" at the end of my post] I'm on Firefox 3.6.21, and I got this problem today after a Greasemonkey update (To version 0.9.10, apparently). Disabling Greasemonkey solved the problem, and re-enabling it reproduced the problem (middle-clicking links to open in new tab did not work, merely highlighted the link). I should also note that while Greasemonkey was enabled and the bug was affecting me, Ctrl+Click to open links in new tabs was also broken. I hope this helps! EDIT: It appears this is a known incompatibility/conflict bug between current versions of Greasemonkey and Tab Mix Plus. Read more here: https://github.com/greasemonkey/greasemonkey/issues/1406 EDIT 2: GREASEMONKEY HAS NOW BEEN UPDATED with a workaround to fix the problem. Go to https://addons.mozilla.org/en-US/firefox/addon/greasemonkey/versions/ to install the update manually. It hasn't been reviewed by Mozilla yet, so it won't be an automatic update for another day or two. All credit to "cannonfodder" below for noticing this; please mark his post as helpful!

Okulungisiwe ngu AvohkahTamer

keith0718 0 izisombululo 4 izimpendulo
Kuphostiwe

Thanks for the help "the-edmeister". My issue was that the automatic update rendered my mouse unable to middle-click to open a link in a new tab. With your directions I discovered that if I disabled the GREASEMONKEY extension, my mouse's middle-click capabilities were restored. Thanks.

Thanks for the help "the-edmeister". My issue was that the automatic update rendered my mouse unable to middle-click to open a link in a new tab. With your directions I discovered that if I disabled the GREASEMONKEY extension, my mouse's middle-click capabilities were restored. Thanks.

Okulungisiwe ngu keith0718

cbhall 0 izisombululo 2 izimpendulo
Kuphostiwe

@keith0718: My problem was Greasemonkey too. I disabled it, restarted, and the middle-click worked again. Thanks for the tip.

@keith0718: My problem was Greasemonkey too. I disabled it, restarted, and the middle-click worked again. Thanks for the tip.
cbhall 0 izisombululo 2 izimpendulo
Kuphostiwe

Double-post. Sorry.

Double-post. Sorry.

Okulungisiwe ngu cbhall

cannonfodder 0 izisombululo 1 izimpendulo
Kuphostiwe

Impendulo Ewusizo

Just install version 0.9.11 of greasemonkey here:

https://addons.mozilla.org/en-US/firefox/addon/greasemonkey/versions/

No need to disable it.

Just install version 0.9.11 of greasemonkey here: [https://addons.mozilla.org/en-US/firefox/addon/greasemonkey/versions/ https://addons.mozilla.org/en-US/firefox/addon/greasemonkey/versions/] No need to disable it.
Taarruz 0 izisombululo 1 izimpendulo
Kuphostiwe

Yeah greasemonkey makes problem. i had same problem i couldnt click with middle mouse on links and couldnt open new tab. i disabled greasmonkey its solved. im using firefox 6.0.1.

Yeah greasemonkey makes problem. i had same problem i couldnt click with middle mouse on links and couldnt open new tab. i disabled greasmonkey its solved. im using firefox 6.0.1.

Okulungisiwe ngu Taarruz