Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox regards StartCom SSL connections as "Untrusted"

  • 5 uphendule
  • 49 zinale nkinga
  • Igcine ukuphendulwa ngu cbrandle

more options

StartCom is an SSL certificate authority which issues free class1 SSL certificates for websites. I have installed their SSL certificates on a few websites and each of them when accessed in firefox, presents an error entitled, "This Connection is Untrusted." Having tried to access the websites in all other popular browsers, including: IE 8.0, IE 9.0RC, Safari, Opera and Google Chrome, I have had no issues and the websites' SSl pages were displayed in these browsers without any issues.

All Replies (5)

more options

Firefox has the StartCom root certificate.

  • Tools > Options > Advanced : Encryption: Certificates - View Certificates

Are you sending all required intermediate certificates?

more options

Many thanks cor-el for your reply, I have checked the site URL using the link you posted above. All seems fine but firefox still displays the same "untrusted" message.

The answer to your question is yes. I have downloaded all relevant intermediate certificates and uploaded them in one single bundle. Firefox still doesn't like it.

The site's URL is:

Okulungisiwe ngu marxam

more options

No problems here with that website.
I've seen such issues before and it helps in such cases if you remove the stored intermediate certificates that are used by that connection, in this case the "GeoTrust DV SSL CA".

Stored intermediate certificates show as "Software Security Device" in the Security Device column in the Certificate Manager.

  • Tools > Options > Advanced : Encryption: Certificates - View Certificates
more options

You see no problem now because after trying everything I possibly could with the StartSSL certificates, I ditched the idea of a free cert and opted for a new GeoTrust certificate, got it in a couple of hours and I had the site up and running in all browsers in no time.

There are other sites I am managing that use startssl where the problem still persists.

Here's a link to another example: [CAUTION: CONTENT WARNING]

Okulungisiwe ngu marxam

more options

You have a problem with implementing the StartSSL keys on your server. To test use this command: echo GET | openssl s_client -connect -state -showcerts

Basically it says you have imported the wrong StartSSL root public key on your server.