Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Websites like Youtube always tell me I must upgrade my Firefox, as the one I have is not supported. But I have 3.6, and have uninstalled and reinstalled twice now. What can I do?

  • 5 uphendule
  • 40 zinale nkinga
  • 142 views
  • Igcine ukuphendulwa ngu spaghettihead

more options

For example, Youtube says: "Your browser is no longer supported. Please upgrade to a modern browser. "

However when I go to Help > About Mozilla Firefox, it says that I have version 3.6.13.

Usually I just deal with these annoying messages, but I'm currently being blocked out of a database I need to access because of this issue, so I really need help!

Thanks!

Isisombululo esikhethiwe

This can happen if you have an incorrect user agent string (identifies the version of Firefox). Some add-ons modify the user agent string causing it to show an old version of Firefox even if you have the latest version installed.

You need to reset the user agent string so that it will correctly identify the version of Firefox that you have installed, for details of how to do that see https://support.mozilla.com/kb/Websites+or+add-ons+incorrectly+report+incompatible+browser

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 4

All Replies (5)

more options

I have just randomly selected a YouTube page with video content and it played ok for me. ( I have Flash Player installed)

The latest current version of firefox is 3.6.15, so there is another update you may be able to download. I also note there are a couple of articles about YouTube, one of which suggests that YouTube are testing a proprietary codec that firfox does not natively support.

more options

Thanks, but actually it's not just Youtube that does this for me, and it's not just videos either, so I don't think it's a problem with that. Right now I'm trying to access the Factiva.com news database, and it's giving me the same error, which makes me think it must be an issue with my Firefox not being recognized as above a 3.0 (which is what the site says is the minimum required). I'm just not sure why this would be the case, and what I can do to have websites recognize that my browser is indeed upgraded.

more options

Isisombululo Esikhethiwe

This can happen if you have an incorrect user agent string (identifies the version of Firefox). Some add-ons modify the user agent string causing it to show an old version of Firefox even if you have the latest version installed.

You need to reset the user agent string so that it will correctly identify the version of Firefox that you have installed, for details of how to do that see https://support.mozilla.com/kb/Websites+or+add-ons+incorrectly+report+incompatible+browser

more options

That solved it, thanks so much!!

more options

I tried your suggestion but the "reset" option was greyed out. Vidxden videos do not play for me anymore since upgrading to 3.6.14 and 3.6.15 before that they played great. Vidxden hangs f/f everytime making it impossible to use at all which is really annoying as it's my main preference. I did notice however upon searching only "user" in the filter box that "extensions.update.notifyUser" was listed in bold as false. What does that mean??

I have f/f mac os x.