Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

I've downloaded 3.6 countless times but I still get warnings. Why?

  • 1 baphendule
  • 3 zinale nkinga
  • 1 view
  • Igcine ukuphendulwa ngu the-edmeister

more options

I have this warning: URGENT! Your version of Firefox is no longer protected against online attacks. Get the upgrade - it’s fast and free!

And I've upgraded several times. However, the warning is still flashing.

Thank you

All Replies (1)

more options

The information provided by the browser that you used to post here indicates you still have that old 3.0.11 version installed. Did you actually install 3.6.x, or just download it?

If you are sure that you installed 3.6.x, see this:
https://support.mozilla.com/en-US/kb/websites+or+add-ons+incorrectly+report+incompatible+browser