Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

hey. i have created my own website in frontpage 2003 and i added a video in .swf format. it plays ok and all the stuff. howvever, it behaves differently in IE than in Mozzila. more details bellow

  • 2 uphendule
  • 7 zinale nkinga
  • 34 views
  • Igcine ukuphendulwa ngu moonshadow222

more options

the HTML of said video is this

<object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="http://fpdownload.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,0,0" width="320" height="240" id="player1" align="middle"> 
<param name="movie" value="razor_test.swf"/> 
<param name="quality" value="High"/> 
<param name="bgcolor" value="#ffffff"/> 
<param name="play" value="false">
<param name="loop" value="false">
<noscript><a href="http://newfreescreensavers.com/download-free-screensavers.html">screensavers free</a></noscript> 
<embed src="razor_test.swf" menu="true" quality="high" bgcolor="#FFFFFF" width="320" height="240" name="player" align="middle" allowScriptAccess="sameDomain" type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/go/getflashplayer"/> 
</object>  

in IE it works like a charm. does not auto play, does not loop and waits for me to right click on it to play/loop

in mozzila it does autoplay, it does loop, unless the user right cliks it to stop auto play and loop. it starts as soon as the page finishes loading.'bold text'

mozzila also seems to be unable to play bacground sounds from webpages, and IE can.

the HTML of said video is this <pre><nowiki><object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="http://fpdownload.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,0,0" width="320" height="240" id="player1" align="middle"> <param name="movie" value="razor_test.swf"/> <param name="quality" value="High"/> <param name="bgcolor" value="#ffffff"/> <param name="play" value="false"> <param name="loop" value="false"> <noscript><a href="http://newfreescreensavers.com/download-free-screensavers.html">screensavers free</a></noscript> <embed src="razor_test.swf" menu="true" quality="high" bgcolor="#FFFFFF" width="320" height="240" name="player" align="middle" allowScriptAccess="sameDomain" type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/go/getflashplayer"/> </object> </nowiki></pre> in IE it works like a charm. does not auto play, does not loop and waits for me to right click on it to play/loop in mozzila it does autoplay, it does loop, unless the user right cliks it to stop auto play and loop. it starts as soon as the page finishes loading.''''''bold text'''''' mozzila also seems to be unable to play bacground sounds from webpages, and IE can.

Okulungisiwe ngu cor-el

Isisombululo esikhethiwe

Your EMBED code doesn't have the play and loop parameters (not sure if embed support those).

Maybe use an object instead for Firefox.

<object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="http://fpdownload.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,0,0" width="320" height="240" id="player1" align="middle"> 
<param name="movie" value="razor_test.swf"/> 
<param name="quality" value="High"/> 
<param name="bgcolor" value="#ffffff"/> 
<param name="play" value="false">
<param name="loop" value="false">

<!--[if !IE]>-->
<object data="razor_test.swf" width="320" height="240" type="application/x-shockwave-flash">
<param name="allowScriptAccess" value="SameDomain">
<param name="quality" value="High"/> 
<param name="bgcolor" value="#ffffff"/> 
<param name="play" value="false">
<param name="loop" value="false">
</object>
<!--<![endif]-->

</object>


BGSOUND doesn't work in Firefox: http://kb.mozillazine.org/Background_music_does_not_play

You need to use an object instead:

<object data="music.mp3" type="application/x-mplayer2" width="0" height="0"><param name="filename" value="music.mp3"> <param name="autostart" value="1">
</object>


Or:

<embed type="application/x-mplayer2" src="file.mp3" height="0" width="0" autostart="1">
<noembed><bgsound src="file.mp3" loop=-1></noembed>
Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (2)

more options

Isisombululo Esikhethiwe

Your EMBED code doesn't have the play and loop parameters (not sure if embed support those).

Maybe use an object instead for Firefox.

<object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="http://fpdownload.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,0,0" width="320" height="240" id="player1" align="middle"> 
<param name="movie" value="razor_test.swf"/> 
<param name="quality" value="High"/> 
<param name="bgcolor" value="#ffffff"/> 
<param name="play" value="false">
<param name="loop" value="false">

<!--[if !IE]>-->
<object data="razor_test.swf" width="320" height="240" type="application/x-shockwave-flash">
<param name="allowScriptAccess" value="SameDomain">
<param name="quality" value="High"/> 
<param name="bgcolor" value="#ffffff"/> 
<param name="play" value="false">
<param name="loop" value="false">
</object>
<!--<![endif]-->

</object>


BGSOUND doesn't work in Firefox: http://kb.mozillazine.org/Background_music_does_not_play

You need to use an object instead:

<object data="music.mp3" type="application/x-mplayer2" width="0" height="0"><param name="filename" value="music.mp3"> <param name="autostart" value="1">
</object>


Or:

<embed type="application/x-mplayer2" src="file.mp3" height="0" width="0" autostart="1">
<noembed><bgsound src="file.mp3" loop=-1></noembed>

Okulungisiwe ngu cor-el

more options

thanks for your help!