Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

How can i disable Private Browsing?

  • 9 uphendule
  • 567 zinale nkinga
  • Igcine ukuphendulwa ngu mtmkjr

more options

I want to disable the Private Browsing feature from my computer. How do I do that?

All Replies (9)

more options

There is no built-in way to disable private browsing. You can remove the menu items but that will not stop it being launched by using the keyboard shortcut. For details of how to hide the menu items see this forum thread.

Even if you hide the menu items, browsing history can still be removed by using the clear recent history option.

more options

Note that removing or disabling "Private Browsing" will not make it impossible to delete private data like visited websites (history) or cache or cookies.
There are a lot of ways to clear such data, either via Delete browsing, search and download history on Firefox or directly by deleting the History in the Library or sidebar.
Private Browsing makes it easier because all data is kept in memory and nothing is saved to disk, so nothing needs to be removed.

If you want to see which sites have been visited then you should look at others means outside Firefox like a router or firewall with a password protected logging feature that can't be bypassed.

See also

more options

I just published an extension to disable private browsing here. Do note that it is trivial for a savvy user to disable this add-on. But it might help some users in some cases. Please give feedback on the add-on page if the add-on does or does not work for you.

more options

Sorry, but the Firefox button menu items aren't hidden in Firefox 5.0 for me and still work to enter the Private Browsing mode. Review provided on the download page as requested.

I really like the feature of yours where the extension is hidden in the installed extensions list, except when you're in the Firefox SafeMode. But you might want to consider hiding the Help menu item for Restart with Add-ons Disabled..., as the person who installed your extension could always use the Shft key to open the Firefox SafeMode to access your extension when they might need to.

You might want to review this page for some ideas about PB disabling.

Once you create that extension and save it as an XPI, using the data:application/octet-stream;base64, data string provided there, take a look at the pbdisable.css file in the \chrome\content\ folder to see how it differs from what you used.

more options

Be aware that you only need to add a -private switch to the Firefox desktop shortcut to start in Private Browsing mode or set a check mark in "Automatically start Firefox in a private browsing session". That will make Firefox switch immediately to PB mode (you can check the cookies to see that).

more options

Is it possible that Firefox in-private browsing could be made to require a password to activate it? I am concerned about this feature as well. I can't always sit beside my child & monitor his use of his computer while he is doing his schoolwork (we homeschool for secular reasons) as well as complete my housework, etc. Thanks so much for any help with this matter Firefox team. =) Oh, and I need to mention that my child's schoolwork websites won't work on that's not an option for us.

more options

Try the extension that RichieB2B posted about.

There is no Bug filed (at least that I can find) about adding a password feature to the Firefox Private Browsing mode, without a Bug a feature won't even be considered as needed. Plus there are two other Bugs related to PB that haven't been addressed yet, beyond discussion. So the bottom line is, work with what's already available. Although that extension can be by-passed, a youngster would need to be a computer whiz to discover how that can be accomplished.

Okulungisiwe ngu the-edmeister

more options

Try changing some of your "Private" "History" from "Never remember history" to "Remember history".

more options

Thank you so much RichieB2B! This actually works. The only problem is, I have no way of disabling the add-on. Even when in safe mode, there is no button to disable... That's ok with me, because if I can't do it, my kids probably can't either. But if I ever do need to get rid of it, I'm not sure what I would do.

Okulungisiwe ngu mtmkjr