X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Can't input foreign language after update

Kuphostiwe

I use a mac. After updating firefox a while ago, I can't really type foreign language (Chinese & Japanese) in firefox anymore. I can change to foreign language input when firefox first opens, but after a while, it automatically changes to English and i can't change the input source back (the words become grey and I can't select them). I've tried uninstalling and reinstalling firefox, still doesn't work. Please help me.

This happened

Every time Firefox opened

== after firefox update to 3.6.6

I use a mac. After updating firefox a while ago, I can't really type foreign language (Chinese & Japanese) in firefox anymore. I can change to foreign language input when firefox first opens, but after a while, it automatically changes to English and i can't change the input source back (the words become grey and I can't select them). I've tried uninstalling and reinstalling firefox, still doesn't work. Please help me. == This happened == Every time Firefox opened == after firefox update to 3.6.6

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • -Gecko default plugin
  • Runs Java applets using the latest installed versions of Java. For more information: Java Embedding Plugin. Run version test: Java Information.
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • Office Live Update v1.0
  • iPhoto6
  • Java Plug-In 2 for NPAPI Browsers
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 10.1 r53

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.6) Gecko/20100625 Firefox/3.6.6

Eminye Imininingwane

Umnikazi wombuzo

Yeah, it's not BIG deal, but still I'm starting to type in other langauges more and I can't do it anymore for some reason. I 'was' using 3.6.6 but due to a custom persona bug that's been going on with that version, I switched back to the earlier version before that and thankfully that worked, but at least the language thing seems to not work for any firefox now? I even tried 3.0.12 and that had the same results, too.

Tested the language bar for Safari and that worked normally. Why did this randomly not work for Firefox?

Yeah, it's not BIG deal, but still I'm starting to type in other langauges more and I can't do it anymore for some reason. I 'was' using 3.6.6 but due to a custom persona bug that's been going on with that version, I switched back to the earlier version before that and thankfully that worked, but at least the language thing seems to not work for any firefox now? I even tried 3.0.12 and that had the same results, too. Tested the language bar for Safari and that worked normally. Why did this randomly not work for Firefox?

Umnikazi wombuzo

Yes same problem here. Trying to type with Korean worked fine all along then all of a sudden it stopped working...

Yes same problem here. Trying to type with Korean worked fine all along then all of a sudden it stopped working...

Umnikazi wombuzo

No answer on this?

No answer on this?

Umnikazi wombuzo

i use mac as well and have the same problem. and it's kind of crucial to switch to another language because i'm not an english native and i work using my language. can somebody advise something? really got used to firefox.

i use mac as well and have the same problem. and it's kind of crucial to switch to another language because i'm not an english native and i work using my language. can somebody advise something? really got used to firefox.

Umnikazi wombuzo

You know what's weird, right now (this very second as I'm typing this), it's working, the options are there I can type in Japanese or Korean fine, but like eventually it'll just like, not be available to choose another day. Which is really weird. It HAS to be something with firefox though, cause even if I don't have firefox open at all, the language bar is ALWAYS there, there's never any issue with using it in other programs or renaming files, etc.

The issue has to be with firefox, and not another browser even cause they work fine apparently. Not sure if it could be some bug or some issue with something someone installed like an add-on of some sort. I hope someone answers this soon though, it's really kind of annoying.

You know what's weird, right now (this very second as I'm typing this), it's working, the options are there I can type in Japanese or Korean fine, but like eventually it'll just like, not be available to choose another day. Which is really weird. It HAS to be something with firefox though, cause even if I don't have firefox open at all, the language bar is ALWAYS there, there's never any issue with using it in other programs or renaming files, etc. The issue has to be with firefox, and not another browser even cause they work fine apparently. Not sure if it could be some bug or some issue with something someone installed like an add-on of some sort. I hope someone answers this soon though, it's really kind of annoying.

Umnikazi wombuzo

I just realized recently what's wrong (at least in my case...) there's this web page game i go to a lot, and whenever it asks for my password to login, the input automatically changes to english and other foreign languages are disabled. But then when I login into the game, for some reason firefox thinks I'm still at that password input stage, so it doesn't allow me to switch to other languages. If I happen to avoid going to that game and inputting that password, I can input foreign language fine with firefox.

I wonder if this is what happened to you guys too.

I just realized recently what's wrong (at least in my case...) there's this web page game i go to a lot, and whenever it asks for my password to login, the input automatically changes to english and other foreign languages are disabled. But then when I login into the game, for some reason firefox thinks I'm still at that password input stage, so it doesn't allow me to switch to other languages. If I happen to avoid going to that game and inputting that password, I can input foreign language fine with firefox. I wonder if this is what happened to you guys too.

Umnikazi wombuzo

Same problem here, but just started an hour ago. Was typing in Japanese and it suddenly switched to US English and won't allow me to change it back.

Same problem here, but just started an hour ago. Was typing in Japanese and it suddenly switched to US English and won't allow me to change it back.

Umnikazi wombuzo

Oh, I thought my Mac was problematic. Glad that I am not alone.

Oh, I thought my Mac was problematic. Glad that I am not alone.

Umnikazi wombuzo

Same here. The problem started after update and now I can't type in Korean and Japanese. This is so frustrating. Anyone found a solution?

Same here. The problem started after update and now I can't type in Korean and Japanese. This is so frustrating. Anyone found a solution?
Klord123 0 izisombululo 1 izimpendulo
Kuphostiwe

I HAVE FOUND AN ANSWER

Firefox only disables it when you go to an online game where you have to input a password within a flash game. It will disable it and sometimes will not automatically enable the languages again. All you need to do is to quit Firefox (totally) and start it up again.

I HAVE FOUND AN ANSWER Firefox only disables it when you go to an online game where you have to input a password within a flash game. It will disable it and sometimes will not automatically enable the languages again. All you need to do is to quit Firefox (totally) and start it up again.
pinklover 0 izisombululo 1 izimpendulo
Kuphostiwe

I have been able to type in Japanese forever, and suddenly I can't do it!

I have been able to type in Japanese forever, and suddenly I can't do it!
Shoh Ueno 0 izisombululo 1 izimpendulo
Kuphostiwe

Same problem.

I get a slim box at the bottom of my screen.

DEAR FIREFOX, I LOVE YOU. PLEASE DON'T MAKE ME SWITCH TO CHROME!!

Same problem. I get a slim box at the bottom of my screen. '''DEAR FIREFOX, I LOVE YOU. PLEASE DON'T MAKE ME SWITCH TO CHROME!!'''
frommingriver 0 izisombululo 1 izimpendulo
Kuphostiwe

Impendulo Ewusizo

Windows 7 pro. Microsoft Pinyin ABC style IME. Once switched, all the English characters became numbers. Can copy &paste 中文 into, but cannot type in. IE and Chrome didn't have this problem

Windows 7 pro. Microsoft Pinyin ABC style IME. Once switched, all the English characters became numbers. Can copy &paste 中文 into, but cannot type in. IE and Chrome didn't have this problem
knotsland 0 izisombululo 1 izimpendulo
Kuphostiwe

I just did a clean installation of Windows 7 along with a new Firefox. After successfully added Chinese and Japanese input I got this funny problem. The keys respond with strange, unpredictable letters. Even repetitive strokes on the same key generates a series of different letters. I tried Explorer and it works fine.

I just stumble onto this posting...

Did you get to solve this problem? Or, anyone else with any idea?

Thanks!

I just did a clean installation of Windows 7 along with a new Firefox. After successfully added Chinese and Japanese input I got this funny problem. The keys respond with strange, unpredictable letters. Even repetitive strokes on the same key generates a series of different letters. I tried Explorer and it works fine. I just stumble onto this posting... Did you get to solve this problem? Or, anyone else with any idea? Thanks!
xuchongang 0 izisombululo 2 izimpendulo
Kuphostiwe

Impendulo Ewusizo

Same problem here. I have used firebox since 2004 and its a fantastic browser. But with new updates, it becomes more and more bulky and slowly. In addition, the biggest issue is that I cannot input any Chinese now....Both chrome , Apple Safari and IE (need to turn off protected mode) do not have this problem. I thought I have to leave Firefox and just realized how good and how fact Apple Safari are.....Goodbye firefox and I do appreciate all your work for the past several years that you bring to me....

Same problem here. I have used firebox since 2004 and its a fantastic browser. But with new updates, it becomes more and more bulky and slowly. In addition, the biggest issue is that I cannot input any Chinese now....Both chrome , Apple Safari and IE (need to turn off protected mode) do not have this problem. I thought I have to leave Firefox and just realized how good and how fact Apple Safari are.....Goodbye firefox and I do appreciate all your work for the past several years that you bring to me....
xuchongang 0 izisombululo 2 izimpendulo
Kuphostiwe

I just found out what cause this problem. Uninstall Comcast Constant Guard and everything will be back to normal......I assume nobody will notice this since the Constant Guard is install by default when you order comcast services.

I just found out what cause this problem. Uninstall Comcast Constant Guard and everything will be back to normal......I assume nobody will notice this since the Constant Guard is install by default when you order comcast services.
lalatrue 0 izisombululo 1 izimpendulo
Kuphostiwe

most like the case, since I have Comcast body guard as well.

press pause/break key can enter Chinese, but hard with one hand to type.

most like the case, since I have Comcast body guard as well. press pause/break key can enter Chinese, but hard with one hand to type.
dayang 0 izisombululo 1 izimpendulo
Kuphostiwe

Problem solved on my PC, it is not a Firefox issue.

Thank you, xuchongang. My problem is exactly the case kindly pointed out by xuchongang.

I had Comcast Constant Guard and cannot type in Chinese but only numbers. I uninstalled the Comcast software and everything works now. Note the Norton suite from Comcast which requires Constant Guard to install, is still working. I am glad I tried this.

Good luck to everyone.

Problem solved on my PC, it is not a Firefox issue. Thank you, xuchongang. My problem is exactly the case kindly pointed out by xuchongang. I had Comcast Constant Guard and cannot type in Chinese but only numbers. I uninstalled the Comcast software and everything works now. Note the Norton suite from Comcast which requires Constant Guard to install, is still working. I am glad I tried this. Good luck to everyone.