Join the AMA (Ask Me Anything) with Firefox leadership team to talk about Firefox priorities in 2024. Mark your calendar! Thursday, June 13, 17:00 - 19:00 UTC.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Hyperlinked text does not paste into Thunderbird email

  • 11 uphendule
  • 0 zinale nkinga
  • Igcine ukuphendulwa ngu NoahSUMO

more options

Hyperlinked text does not paste into Thunderbird email. Only the text pastes in. The hyperlinks do not. If I paste in text that has several hyperlinks already embedded, only the text pastes in. The hyperlinks are lost. I must paste the hyperlinked text with the URLs. How do I do this? All searches are irrelevant. I know how to insert URL into new text but that is not the issue. My text to be pasted already has many hyperlinks in the text and I do not want to laboriousness do them all again. When I paste in a paragraph of text that already has several hyperlinks I want that ALL to paste in. How to I do this?

Hyperlinked text does not paste into Thunderbird email. Only the text pastes in. The hyperlinks do not. If I paste in text that has several hyperlinks already embedded, only the text pastes in. The hyperlinks are lost. I must paste the hyperlinked text with the URLs. How do I do this? All searches are irrelevant. I know how to insert URL into new text but that is not the issue. My text to be pasted already has many hyperlinks in the text and I do not want to laboriousness do them all again. When I paste in a paragraph of text that already has several hyperlinks I want that ALL to paste in. How to I do this?

Okulungisiwe ngu NoahSUMO

All Replies (11)

more options

I don't see that on my setup. In the attached picture, I pasted (Ctrl+V) the content of your topic into a message after selecting it and copying (Ctrl+C). Make sure the message format is HTML.

more options

This response is incomprehensible. I don’t have a clue what you are trying to communicate. Did you understand the question?

I don't see that on my setup. (What “that” in your set up?)

In the attached picture, (the attached picture is WAY too small to see no matter how deep I scroll.) ) I pasted (Ctrl+V) the content of your topic into a message after selecting it and copying (Ctrl+C).

What are you talking about? Why would you paste the content of my topic into a message to test the issue? How is that relevant? Since neither “content” my “topic” heading nor the “content” of query contains any hyperlinked text it could not possibly address the issue of hyperlinked text pasting into a Thunderbird email. You are just pasting in non-hyperlinked text. How is that relevant?

Make sure the message format is HTML. (You mean in Settings? My settings are set to HTML and text and have tested all other options. Only plain text pastes in sans hyperlink.) I do not have a clue what you are trying to say.

more options

It sounds like you're experiencing an issue with Thunderbird not preserving hyperlinks when pasting text into emails. This can be frustrating, but there are a few potential solutions you could try: Use Plain Text Mode: 'Sometimes, rich text formatting can interfere with hyperlinks. Try composing your email in plain text mode (if Thunderbird supports it) and then paste your text with hyperlinks. This might ensure that the links are preserved.

Paste as HTML: Instead of directly pasting the text, try pasting it as HTML. You can do this by right-clicking in the email body and selecting "Paste as HTML" or by using the keyboard shortcut (Ctrl+Shift+V in some applications). This should retain the formatting, including hyperlinks.

Use an External Text Editor: If Thunderbird's built-in functionality isn't preserving hyperlinks, you might try composing your email in a separate text editor like Notepad (Windows) or TextEdit (Mac). Once you've added the hyperlinks there, copy the entire text (including hyperlinks) and paste it into Thunderbird.

Check Thunderbird Settings: Ensure that Thunderbird's settings are configured to allow rich text formatting and hyperlinks. Sometimes, these settings can inadvertently affect how text is pasted.

Update Thunderbird: Make sure you're using the latest version of Thunderbird. Updates often include bug fixes and improvements that might address issues like this.

If none of these solutions work, you might consider reaching out to Thunderbird support or checking their online forums for further assistance. They may have specific troubleshooting steps tailored to your issue.

more options

More information may help. Is the source document with the links an HTML document? Seeing the content layout could be useful. I usually see links in HTML format and it pastes readily into thunderbird if composing in HTML

more options

Yes. Of course! The original source is hyperlinked. Why would anyone paste in non HTML hyperlinked text and expect it to contain active hyperlinks? ISSUE and example: See the following text:

B. Bathroom paint 1. Google: how to stop paint from peeling 2. How to Stop Paint Peeling in a Bathroom 3. How to fix and stop paint peeling with Peel Stop 4. Interior Moisture Damage Is Peeling the Paint and Drywall 5.

Each one of those items is hyperlinked in the original pasted text. When clicked each blue hyperlink takes (jumps) you to a different web page. This text is from a hyperlinked Word Perfect document and it pastes with the blue active hyperlinks into an Outlook email just fine but I want to dump Outlook. In Tbird all that pasted in is the text with no hyperlinks.

That is just an example. The source of the hyperlinked text is not relevant. I can copy any hyperlinked text from a Word or Word Perfect document, from any email, or from a web page. That text (sometimes containing several hyperlinks) copied from any source can be easily pasted into an Outlook email and the text will paste into the Outlook email with all blue and active hyperlinks– not just thee black text stripped of the active hyperlinks. That does not happen in Tbird

In Thunderbird, no matter what I do, just the black text pastes into the email sans hyperlinks. Yes, I do know how to tediously edit each text to insert the hyperlink but that is EXACTLY what I do not want to have to do. I do not want to tediously embed each of several URLs into the text that already contained those hyperlinks.

more options

Thank you but, for the most part, you are telling me to is what I have already done but does not work which is why I posted this query in the first place.

I do not understand why it is so difficult to comprehend a simple question and provide a clear and relevant answer. If the question is how much is 2 + 2 the answer is 4 However and ‘btw 2 + 5 = 7' is not helpful or relevant. For instance, ‘you can also create a hyper linked text by...’ is irrelevant and not helpful. That is an answer to a different question. Please stay focused on the singular issue and do not provide answers to questions not presented. In Thunderbird I know how to insert a hyperlink into text. That is not the question and not the issue. Please stay on point.

ISSUE and example: See the following text:

B. Bathroom paint 1. Google: how to stop paint from peeling 2. How to Stop Paint Peeling in a Bathroom 3. How to fix and stop paint peeling with Peel Stop 4. Interior Moisture Damage Is Peeling the Paint and Drywall 5.

Each one of those items is hyperlinked in the original HTML pasted text. In the original, when clicked, each blue hyperlink takes (jumps) you to a different web page. This text is from a hyperlinked Word Perfect document and it pastes with the blue active hyperlinks into an Outlook email just fine but I want to dump Outlook. In Tbird all that pastes in is the text with no hyperlinks.

That is just an example. The source of the hyperlinked text is not relevant. I can copy any hyperlinked text from a Word or Word Perfect document, from any email, or from a web page. That text (sometimes containing several hyperlinks) copied from any source can be easily pasted into an Outlook email and the text will paste into the Outlook email with all blue and active hyperlinks– not just thee black text stripped of the active hyperlinks.

In Thunderbird, no matter what I do, just the black text pastes into the email sans hyperlinks.

Yes, I do know how to tediously edit each text to insert the hyperlink but that is EXACTLY what I do not want to have to do. I do not want to tediously recreate the original to embed each of several URLs into the text that already contained those hyperlinks.

What do you mean, “if Thunderbird supports it”. This is a Thunderbird query. If you do not know what Thunderbird supports why are you responding to ths query?

Finally, you wrote “Paste as HTML: Instead of directly pasting the text, try pasting it as HTML. You can do this by right-clicking in the email body and selecting "Paste as HTML" or by using the keyboard shortcut (Ctrl+Shift+V in some applications). This should retain the formatting, including hyperlinks.”

Please. Don’t tell me... show me. That IS what I have been trying to do but does not work. That is WHY I posted this query. If you are familiar with Tbird you should know (see attached screen shot) I right click in the body of the email does not offer the HTML option you suggest. So please show me rather than just tell me. The only options I see on a right click are shown in the screen shot and all of those options just paste in plain text with no hyperlinks. If you are not actually familiar with these Tbird facts why are you responding to this query?

Exactly (show me the settings) what are you doing to paste hyperlinked HTML text into a Tbird email in a way that preserves the blue hyperlinks for no matter what I try I only paste text with no hyperlinks and, as you can see from the attached, "Paste as HTML" is not an option. So show me where that option exists.

more options

It does not appear that you want an answer. People here are attempting to assist. Hyperlinked text in DOC files and in HTML files copies and pastes with no problems. The only way to assist you is to see what you are attempting to do, the actual source. Continuing to debate how to support pasting content without seeing the content accomplishes nothing.

more options

What are you talking about? People are giving answers to totally different questions. not mine. The 'relevant' answers are simply wrong. The options suggested do not exist. Screen shots prove that. No response provided here solved the problem.

more options

JPM g said

What are you talking about? People are giving answers to totally different questions. not mine. The 'relevant' answers are simply wrong. The options suggested do not exist. Screen shots prove that. No response provided here solved the problem.

Your assertion is Pasting does not work. I read lots of folk trying to work out why that is happening for you and you only. It is not a general problem, but they are long time Thunderbird and open source users on the whole.

I think it is working, just you have Microsoft expectations, not Thunderbird ones so are here asserting it is broken.

Save your message to drafts close it and reopen it from the draft. Working now?

more options

Pardon me? I do not care what you “think” but what is, in fact, demonstrably true or false. Nor do I care how long these people have been giving advice. I only care about what actually works in my experience with this program when I do as directed, and the fact of what does not happen when none of these ported solutions work. Period. Please do not misrepresent me. I never made the ‘assertion’ that “Pasting (sic) does not work.” Pasting the text DOES work but the embedded hyperlink URL does not paste with the text. Only the text pasted. This only happens when I use Tbird so, ergo, the bug is demonstrably Tbird's

No, saving as a draft (a purported work-around commonly parroted in several forums) also does not work. Obviously if no URL is pasted with the text then nothing is saved in the draft. Nothing comes from nothing. Once the draft is pulled up no blue hyperlink appears and when sent no hyperlink is sent– just the plain text. Nothing begets nothing. Conversely the fact that exact same method of copy and paste hyperlinked text works in Outlook just fine clearly demonstrates the problem is with Tbird. “Microsoft expectations” is nonsense.

Elementary deduction: that copying and pasting the exact same hyperlinked text DOES work fine in Outlook but does not work in Tbird demonstrates the defect lies with Tbird and the argument that “lots of folk” who are “long time Thunderbird and open source users” do not experience the same issue only proves "lots of folk" do not have a workable answer to this problem and their answer is simply wrong in fact. So if you do not have a solution please do not troll me with the arguments about what “lots of folk” experience. I am not interested in winning an argument over purported “Microsoft expectations’ but in solving this problem. We are not here to verify “other folks’” experience but to solve this problem and if you do not have the answer please do not inject yourself into this query; but simply admit there might be something you do not know rather than insist on the validity of answers that do not work.

more options

I'm sorry, I'm afraid I'm going to have to close your question.

There are many times in support where not every mysterious glitch or bug can be determined quickly & easily. Sometimes more time, testing & troubleshooting is needed to learn what is causing the issue.

But rather than offer you more steps to try then watch you return, get defensive & berate others saying you've already tried that and did we understand the question and so on & so forth, I'm just going to close this question & leave you with these final thoughts (of which may anger you, simply for trying to help you troubleshoot your problem).

The main problem: “Paste as HTML: Instead of directly pasting the text, try pasting it as HTML. You can do this by right-clicking in the email body and selecting "Paste as HTML" or by using the keyboard shortcut (Ctrl+Shift+V in some applications). This should retain the formatting, including hyperlinks.”

Observations: Your Thunderbird version is unknown. For all we know, you could be using a older version of TB which is missing the "Paste as HTML" option from the right-click context menu.

You could have a addon installed that is breaking the context menu & hiding the "Paste as HTML" choice from you. You would need to disable ALL your addons in Thunderbird, restart the program then test again to see if the option was returned to the context menu. You might angrily retort you don't have any addons installed. Are you sure? You better check. If confirmed no addons are installed, move on to the next troubleshooting idea.

Could your Thunderbird profile be broken somehow? Is it very old profile & a settings file got damaged thus hiding this option? Or again, are you using a very old version of Thunderbird where this option is not present?

Finally, no support forum anywhere on Earth can guarantee your problem will be solved. It takes lots of patience, lots of testing, lots of troubleshooting and lots of time. Sometimes if you work thru a premade list of common fixes it can help you narrow down the problem faster. If a support forum can't solve your issue, we are never happy about it & continue to think about it in the future in case we finally find the obscure resolution to your problem. Endlessly talking about the problem can not magically produce a solution. Real troubleshooting work must be done.

I suggest you slow down, stop getting very frustrated, analyze the problem with a calm mind & try different ideas to see what may be causing the issue. Even something like 3rd party programs have been known to inject themselves in Firefox & Thunderbird causing maddening issues that take us a long time to finally find out they were the cause.

So I leave it to you, to analyze, troubleshoot & test this problem until you find a solution. I wish you the best of luck, I truly do.

Thanks to everyone who offered their ideas to fix the solution here. I really appreciate your patience in dealing with issues like this.