Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Webpages are not loading, at all on FF for Android

  • 38 uphendule
  • 270 zinale nkinga
  • 11213 views
  • Igcine ukuphendulwa ngu Aesirgn

more options

I have no idea what is happening... But after restarting, clearing my cache, making sure I have data and it is working for other apps... Still no results.

No matter what, whether I try to type in a URL, click on a link in the google app, or refresh a page I already have open, the app doesn't even attempt to load a page or throw up an error. Just a blank background, no loading bar, no error messages, and no redirects...

FF for Android Version 112.2.0 Build #2015946691

I have no idea what is happening... But after restarting, clearing my cache, making sure I have data and it is working for other apps... Still no results. No matter what, whether I try to type in a URL, click on a link in the google app, or refresh a page I already have open, the app doesn't even attempt to load a page or throw up an error. Just a blank background, no loading bar, no error messages, and no redirects... FF for Android Version 112.2.0 Build #2015946691

Isisombululo esikhethiwe

Assuming that you have no data in Firefox for Android that you would wish to keep, have you tried uninstalling and then reinstalling Firefox for Android from the Google Play store?

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 3

All Replies (20)

more options

Hi John

What level of enhanced tracking protection do you have set?

Do you have any add-ons installed in Firefox for Android?

Do you have an example of a web address that will not open?

Are you able to get online with other apps on your Android device?

more options

Paul said

Hi John What level of enhanced tracking protection do you have set? Do you have any add-ons installed in Firefox for Android? Do you have an example of a web address that will not open? Are you able to get online with other apps on your Android device?

Strict

No

Any, even google.com

Yes

more options

Isisombululo Esikhethiwe

Assuming that you have no data in Firefox for Android that you would wish to keep, have you tried uninstalling and then reinstalling Firefox for Android from the Google Play store?

more options

Paul said

Assuming that you have no data in Firefox for Android that you would wish to keep, have you tried uninstalling and then reinstalling Firefox for Android from the Google Play store?

I hate that a simple re-install fixed it, but it indeed did work.

more options

I had the same problem with Firefox, running Android 14 Beta. I thought it might be to do with the beta, but after reading this, I clear the data for Firefox under Settings -> Apps and that resolved it. Something had obviously got corrupted and it was unfortunate having to delete all that data, but it did fix the problem.

more options

I have the same problem with 114.1.0 Build #2015955411

I tried clearing all data except for open tabs, browsing history and site data, and downloads. I wouldn't mind deleting site data, but I would like to keep my browsing history and unfortunately the two are tied together in a single checkbox.

Is it possible to back up this data from FF / Android, reinstall the app, then re-import the backed up data like you would on a computer?

I also can't load the Add-ons menu to try removing any in case they are causing problems, can't set up Sync because it redirects to a page to log in (which doesn't load), and can't load any "about:" pages.

For now I'll install Firefox Beta :)

more options

114.2.0 #2015957435 Nothing loads. Clearing cache doesn't help. It just randomly stopped working, no Idea what caused it.

more options

The same problem for me. Pages don't load at all, and add-ons panel as well.

more options

Has happened to me 3 times now. I have to keep deleting all data and reset ff to get it to work. I have now reluctantly started using Chrome as my primary browser.

more options

I've been using Firefox for Android for years and this exact issue occurred for me moments ago for the first time.

Even pages that were already loaded come up blank as @trigger337 posted above.

Please don't make me reject thousands of cookies again.

Firefox 114.2.0 OnePlus Nord 2T OxygenOS CPH2399_11_A.19 (Android 12)

more options

Looks like it is not a single case. It happened me to as well 2 day ago (Android 12, OnePlus 7T). As already mentioned above clearing cache doesn't help and removing all data/uninstalling/installing back not a proper solution for this case.

Okulungisiwe ngu aleksandr.halturin

more options

Same problem. Android 11, FF 114.2.0, deleting cache and settled data has helped, but I hate I lost local history and need to log in again. For me it seems like the browser has hailed to update since after data reset and restart the UI has changed.

more options

trigger337 said

114.2.0 #2015957435 Nothing loads. Clearing cache doesn't help. It just randomly stopped working, no Idea what caused it.

This is exactly what my screen looks like as well, seemed to happen at around the same time. Don’t really wanna delete some tabs and it looks like that doesn’t help anyway. Clearing cache, and deleting cookies didn’t do anything either

more options

Same problem here. A few hours ago it was working. I didn't change any settings.

About 2 weeks ago I also had this problem. I ended up deleting the data from Firefox. Not a good solution cause I want to keep it.

I hope for a quick fix!

more options

I've just witnessed the exact same issue on my Android 13 phone.

If I launch Firefox to navigate to a webpage or launch a search (I've even tried changing the built in search engines), Firefox just refuses to progress. No webpage is displayed.

I have tried clearing the browser's cache - Firefox refuses to launch webpages, appears stuck.

Placed phone in flight mode and then one by one enabled WiFi &/or Mobile data - Firefox still refuses to launch pages.

I've tried logging out of my account within browser settings. Now I can't log back in. Launching the sync options on my desktop, "Connect another device" QR code is displayed and presented to mobile phone's FireFox app, it identifies the QR code, but it doesn't respond further to that. The option to input details manually also doesn't respond, as it won't launch the page to allow me to input my credentials.

I've noticed that the phone gets warm when running Firefox since this bug appeared this morning.

I've tried rebooting the phone, but FireFox still refuses to resolve webpages.

Mozilla - please post a fix and pronto. Other browsers work on the same device - so it's a FireFox Android app issue.

Common answer seems to be uninstall the app and reinstall. BUT, there's a flaw in that plan, as it will mean losing various inactive and other opened tabs - which now can't be sync'd with another instance of FireFox because the Android app won't allow me to sign in to sync.

more options

I am having this very issue on Firefox 114.2.0 for Android on Android 13. It happened 2-3 days ago, since I am abroad I initially thought it could have been a roaming data issue. Glad to hear I am not the only one.

more options

I've never experienced this before but unfortunately now I am facing the same issue as well. And since I have Firefox as the default (and only) browser installed/enabled it also affects those "in app" views apps like Telegram or Facebook like to use by default, as these are surprisingly also handled by Firefox.

Unfortunately, I've also seen this issue mentioned many times in the recent Google Play store reviews :/, so it must be affecting quite a lot of people.

Also, it doesn't look like the GitHub page would have "Issues" enabled. So is this the official tracking for the issue?

more options

I have the same problem. Uninstalled Firefox, reinstalled it and the problem was fixed....for 3 days. Now it's returned. I'll repeat this "fix" but it's annoying to have to reinstall every few days. Personally I think Alphabet is f'ing with you.

more options

I have this problem too. Tried restarting my phone, tried clearing the cache, tried turning off app optimilisation in android settings. Tried different WiFi networks, and mobile data.

The only thing that fixes this is a full app reset / reinstall.

more options

Same here. Did a full reinstall but it has stopped working again with 114.2.0 Build #2015957435 :(

  1. 1
  2. 2