Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

disable Google request to use Google login for many websites

  • 5 uphendule
  • 1 inale nkinga
  • 246 views
  • Igcine ukuphendulwa ngu pccobbler

more options

Google offers to use a Google login for many websites in the top-right corner of Firefox, for example, when I start Twitter. I don't remember this behavior more than a few months ago. This is on desktop Firefox, not mobile. I never login to Google unless I want to use Gmail or Blogspot, and then I logoff and kill the browser when done. Can this offer be disabled?

Google offers to use a Google login for many websites in the top-right corner of Firefox, for example, when I start Twitter. I don't remember this behavior more than a few months ago. This is on desktop Firefox, not mobile. I never login to Google unless I want to use Gmail or Blogspot, and then I logoff and kill the browser when done. Can this offer be disabled?

Isisombululo esikhethiwe

This can possibly be the consequence of using Total Cookie Protection that isolates (partitions) cross-site cookies and uses a separate cookie jar for each website you visit.

Selecting "Cross-site tracking cookies" sets network.cookie.cookieBehavior to '4' and does not partition/isolate cross-site cookies, but still keeps Enhanced Tracking Protection enabled.

Selecting "Cross-site tracking cookies, and isolate other cross-site cookies" sets network.cookie.cookieBehavior to '5' and enables Total Cookie Protection.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (5)

more options

Since you have a G account, you can disable the login in the settings on the accounts page.

more options

@Terry

Um, well, no. I never surf while logged into any service to prevent data-scarfing. I see that message while not logged into Google.

Okulungisiwe ngu pccobbler

more options

Isisombululo Esikhethiwe

This can possibly be the consequence of using Total Cookie Protection that isolates (partitions) cross-site cookies and uses a separate cookie jar for each website you visit.

Selecting "Cross-site tracking cookies" sets network.cookie.cookieBehavior to '4' and does not partition/isolate cross-site cookies, but still keeps Enhanced Tracking Protection enabled.

Selecting "Cross-site tracking cookies, and isolate other cross-site cookies" sets network.cookie.cookieBehavior to '5' and enables Total Cookie Protection.

more options

@cor-el

Funny, when I read your answer, I thought that 4 would be the solution, albeit with worse privacy, but 5 is actually the solution. And when I looked at Settings->Privacy&Security, my initial settings of Cookies->all-third-party-cookies and tracking-content->all-windows remained as I set them, so there's no reduction in privacy.

Thanks a bunch for that.

more options

Never mind. When I powered-up my PC this morning, "Cross-site tracking cookies" was set to 0 (zero). After some cursory testing, I found that it resets with every restart of Firefox

Okulungisiwe ngu pccobbler