Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Other Linux browsers can load websites, but FireFox is problematic.

  • 1 baphendule
  • 0 zinale nkinga
  • 7 views
  • Igcine ukuphendulwa ngu S.A. Birl

more options

FireFox 102.6.0esr on Debian 11 with a 5.10.0-20-amd64 kernel. (http://security.debian.org/debian-security stable-security/main amd64 firefox-esr amd64 102.6.0esr-1~deb11u1 )

My problem initially started out on a profile migrated from Windows (with some extensions installed), but Ive reproduced from a brand-new profile. Similar to https://support.mozilla.org/en-US/kb/firefox-cant-load-websites-other-browsers-can

Although the problem is sporadic, it occurs more way frequently than I would like. I have done quite a bit of troubleshooting with different profiles, used the --profile flag, sometimes --safe-mode, sometimes called around strace -- the results are pretty much the same.

Launch FF (as a new profile), and it will display the two tabs:

Sometimes I am able to load in an additional website (which is short-lived), but ultimately traffic peters out and tabs are just spinning endlessly. No network timeouts. Firefox's just waiting on ... something.

Other times, when loading the profile with extensions enabled (NoScript, Multi-Containers, etc), clicking on a extension's drop-down menu (eg: Multi-Containers) it's not a full rendered drop-down but instead a thin (~2px) vertical line.

Errors from commandline:

  • Missing chrome or resource URL: resource://gre/modules/UpdateListener.jsm
  • Missing chrome or resource URL: resource://gre/modules/UpdateListener.sys.mjs

(The clean up of FireFox on normal quit can take up to 30 seconds)

When wrapped in strace I see ridiculous amounts of

  • recvmsg(4, {msg_namelen=0}, 0) = -1 EAGAIN (Resource temporarily unavailable)

interspersed with

  • recvmsg(4, {msg_name=NULL, msg_namelen=0, msg_iov=[{iov_base="\16\0y\n+\0`\1\0\0>\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\

0\0\0\0\1\2z\n\0\0\0\0,\0`\1\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0", iov_len=4096}], msg_iovlen=1, msg_controllen=0, msg_flags=0},

0) = 64

Im not sure why this occurs with only FireFox. Ive ran instances SeaMonkey, Pale Moon, WaterFox, Epiphany, Google Chrome, Brave and Vivaldi without seeing these issues.

I highly suspect there's a conflict with something else I run. Already disabled fail2ban and apparmor. Are there any system calls from the strace that I should look for?

FireFox 102.6.0esr on Debian 11 with a 5.10.0-20-amd64 kernel. (http://security.debian.org/debian-security stable-security/main amd64 firefox-esr amd64 102.6.0esr-1~deb11u1 ) My problem initially started out on a profile migrated from Windows (with some extensions installed), but Ive reproduced from a brand-new profile. Similar to https://support.mozilla.org/en-US/kb/firefox-cant-load-websites-other-browsers-can Although the problem is sporadic, it occurs more '''way''' frequently than I would like. I have done quite a bit of troubleshooting with different profiles, used the --profile flag, sometimes --safe-mode, sometimes called around strace -- the results are pretty much the same. Launch FF (as a new profile), and it will display the two tabs: * tab 1: "FireFox starts here" image of Soraya Osorio. * tab 2: https://www.mozilla.org/en-US/privacy/firefox/ Sometimes I am able to load in an additional website (which is short-lived), but ultimately traffic peters out and tabs are just spinning endlessly. No network timeouts. Firefox's just waiting on ... ''something''. Other times, when loading the profile with extensions enabled (NoScript, Multi-Containers, etc), clicking on a extension's drop-down menu (eg: Multi-Containers) it's not a full rendered drop-down but instead a thin (~2px) vertical line. Errors from commandline: * Missing chrome or resource URL: resource://gre/modules/UpdateListener.jsm * Missing chrome or resource URL: resource://gre/modules/UpdateListener.sys.mjs (The clean up of FireFox on normal quit can take up to 30 seconds) When wrapped in strace I see ridiculous amounts of * recvmsg(4, {msg_namelen=0}, 0) = -1 EAGAIN (Resource temporarily unavailable) interspersed with * recvmsg(4, {msg_name=NULL, msg_namelen=0, msg_iov=[{iov_base="\16\0y\n+\0`\1\0\0>\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\ 0\0\0\0\1\2z\n\0\0\0\0,\0`\1\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0", iov_len=4096}], msg_iovlen=1, msg_controllen=0, msg_flags=0}, 0) = 64 Im not sure why this occurs with '''only''' FireFox. Ive ran instances SeaMonkey, Pale Moon, WaterFox, Epiphany, Google Chrome, Brave and Vivaldi without seeing these issues. I highly suspect there's a conflict with something else I run. Already disabled fail2ban and apparmor. Are there any system calls from the strace that I should look for?

All Replies (1)

more options

After much (re)installing to a clean Debian system, restoring backups, and a long-winded process-of-elimination, I have found a culprit: snoopy (currently v2.4 for the curious). Snoopy is something I installed many times over various *n?x OSes over the years.

Out of the box, there's something that snoopy is doing that interferes with FireFox. Once removed from the system (or perhaps just removed from dynamic linker library, ld.so) FireFox is responsive once again.

Snoopy has no binary, therefore no configuration options. So ... is this a bug with Snoopy or FireFox or what?