Where did you install Firefox from? Help Mozilla uncover 3rd party websites that offer problematic Firefox installation by taking part in our campaign. There will be swag, and you'll be featured in our blog if you manage to report at least 10 valid reports!

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

secure connection failed

  • 2 uphendule
  • 1 inale nkinga
  • 1 view
  • Igcine ukuphendulwa ngu Terry

more options

please help me

please help me

All Replies (2)

more options

Try this: Go to settings, General, and at the very bottom you'll see network settings. Open the settings menu for that. Now you should see a window pop up inside the browser. At the bottom uncheck "Enable DNS over HTTPS". I had the same problem a few months ago, and this seems to have fixed it.

more options