Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

You are using an unsupported browser version?????

  • 5 uphendule
  • 1 inale nkinga
  • 14 views
  • Igcine ukuphendulwa ngu James

more options

On many, many, websites when logging in I am getting the above message.

These sites work no issues but why is Firefox not recognized as a accepted browser.

Firefox says I am using the current release, and is up to date?

All this sites are important log on, like BofA, OptumRx, etc.

I am using an iMac, Mac OS 10.11.6.

It is still a really good machine.

Comments???

On many, many, websites when logging in I am getting the above message. These sites work no issues but why is Firefox not recognized as a accepted browser. Firefox says I am using the current release, and is up to date? All this sites are important log on, like BofA, OptumRx, etc. I am using an iMac, Mac OS 10.11.6. It is still a really good machine. Comments???
Ama-screenshot ananyekiwe

All Replies (5)

more options

You are running an old version of mac. That's the most current version of Firefox for that version of Mac OS. My mac is from 2012 and I'm able to run the current version of Firefox which is 101.0.1. Time to upgrade to a newer mac. I just bought a used laptop on eBay and I saw several old macs in excellent condition.

Helpful?

more options

Thanks for responding. A new iMac brings me no new value. I find Apple's policy of frequently continuing to change OS's to sell new machines annoying. This Mac will do everything a new Mac will do.

Mac El Capitan is still a very good OS, and Firefox is still the best browser.

However a lot of these sites even with newer computers do not list Firefox as an approved browser.


Thanks

Helpful?

more options

rlmrlm said

However a lot of these sites even with newer computers do not list Firefox as an approved browser.

Without knowing what the sites are - this doesn't tell anyone much here. Also sites are based on the O/S how up to date or latest version is verified by sites and if they don't match they will deny access for their Security purpose not yours in-general.

Okulungisiwe ngu Dropa

Helpful?

more options

rlmrlm said

Thanks for responding. A new iMac brings me no new value. I find Apple's policy of frequently continuing to change OS's to sell new machines annoying. This Mac will do everything a new Mac will do. Mac El Capitan is still a very good OS, and Firefox is still the best browser. However a lot of these sites even with newer computers do not list Firefox as an approved browser. Thanks

No one mentioned new, but your OS is old and tech moves on. Here's a sample of what I see on eBay.

The last time I bought a new computer was my wife's mac book pro in 2012. It's the same story for phones, the industry wants to you keep buy new hardware. My current phone is 5yrs old and still works fine. Anyway... you need to consider your options if you want to use a newer version of Firefox. Good luck.  ;-)

Helpful?

more options

rlmrlm said

I am using an iMac, Mac OS 10.11.6.

Firefox has required at least macOS 10.12 (ten.twelve) since Fx 79.0 to current versions.

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.