Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Gmail - OAuth2 - repeated "Authentication failure while connecting to the server imap.gmail.com". Works ONLY work safe-mode.

  • 17 uphendule
  • 3 zinale nkinga
  • 30 views
  • Igcine ukuphendulwa ngu thegoodguy

more options

Hi,

I, like a gjillion other people, received a notice from Google/gmail saying I'm likely to lose access through Thunderbird unless ... blah blah.

I was running TB v59. If stuff works I don't make changes. It makes life simpler. I did a heap of online reading and research about this and found lots of advice. I did the following;

  • allowed cookies
  • removed passwords
  • changed authentication to OAuth2 in both IMAP and SMTP

I got the pop-up gmail/Google window asking me to login. My password is accepted. I am asked to allow access to gmail through Thunderbird. I allow. TB hangs sending security information and then crashes.

I assumed that it must be because I was on an older version of TB. I updated to the latest v91 and checked that the OAuth2 settings are as they should be. All good.

I got the pop-up gmail/Google window asking me to login. My password is accepted. I am asked to allow access to gmail through Thunderbird. I allow. TB waits of a bit and pops up a failure notification. This happens every time. If I click on "Get Messages" or I click on any of my folders, I get the gmail login popup, and I am asked to allow TB, AGAIN, and then failure. I cannot get past this.

I have done enough searching again, but I cannot find anything that helps. Can anyone here help with some guidance please.

I have uploaded shots of the various windows.

Thanks.

Hi, I, like a gjillion other people, received a notice from Google/gmail saying I'm likely to lose access through Thunderbird unless ... blah blah. I was running TB v59. If stuff works I don't make changes. It makes life simpler. I did a heap of online reading and research about this and found lots of advice. I did the following; * allowed cookies * removed passwords * changed authentication to OAuth2 in both IMAP and SMTP I got the pop-up gmail/Google window asking me to login. My password is accepted. I am asked to allow access to gmail through Thunderbird. I allow. TB hangs sending security information and then crashes. I assumed that it must be because I was on an older version of TB. I updated to the latest v91 and checked that the OAuth2 settings are as they should be. All good. I got the pop-up gmail/Google window asking me to login. My password is accepted. I am asked to allow access to gmail through Thunderbird. I allow. TB waits of a bit and pops up a failure notification. This happens every time. If I click on "Get Messages" or I click on any of my folders, I get the gmail login popup, and I am asked to allow TB, AGAIN, and then failure. I cannot get past this. I have done enough searching again, but I cannot find anything that helps. Can anyone here help with some guidance please. I have uploaded shots of the various windows. Thanks.
Ama-screenshot ananyekiwe

Okulungisiwe ngu Wayne Mery

Isisombululo esikhethiwe

Starting TB in safe-mode worked. The problem must be one of the add-ons transferred from the installation of the older TB. Now I just have to work out which one.

Thanks for your time and efforts.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (17)

more options

No thoughts? Anyone?

more options

See if Thunderbird is an allowed program in the Firewall. The Firewall may be the default one for computer or may be controlled by your Anti-Virus product. You were quite correct to update Thunderbird. It is possible the Firewall/Anti-Virus product thinks the new Thunderbird is something different and is blocking access to internet.

Exit Thunderbird, Access Firewall If Thunderbird is listed as allowed, block it, ok it. then access Firewall again and allow it.

Start Thunderbird.

What Anti-Virus are you using ?

re: allowed cookies

I presume you did this: Menu app icon > Preferences > Privacy & Security Under 'Web content' select checkbox 'allow cookies from sites'


re: removed passwords In same area as mentioned above... Note: I did not remove any passwords because once OAuth2 is set up gmail creates it's own token and stores it in a new OAuth line which it then uses from then onwards.

Passwords section Click on 'Saved Passwords' Click on 'Show Passwords' Did you right click and select 'Edit Pasword' then completely remove your normal gmail password? If yes, it is ok to enter the normal password again. I keep it because it reminds me what I set up as normal password when trying to logon to webmail. OR did you select the mailbox gmail lines and click on 'Remove' ? That is the method to remove the password.

more options

Thanks for your reply Toad-Hall.

  • Thunderbird is allowed through the firewall and AV. I thought this may have been a problem after I updated to the latest version and so made sure the firewall and AV are happy with the new TB.
  • Yes, cookies are allowed. As I mentioned, I read that this needed to be done.
  • I selected the gmail line and clicked on 'Remove'

I have done everything that you have suggested, and still ... :-(

I just checked on the actual saved cookies. There isn't a Google cookie in sight. Is this normal? There are only Mozilla cookies.

more options

re : I just checked on the actual saved cookies. There isn't a Google cookie in sight. Is this normal?

No. In Thunderbird: My web content is selected as follows:

  • Selected: Remember web sites and links I've visited
  • Selected: Accept cookies from sites
  • Accept third-party cookies: Always
  • Keep until : they expire
  • Not selected: 'Send web sites 'Do not track'.....

Cookies include mozilla, thunderbird and these google cookies:

Please try this in same 'Privacy & Security' area. Create an exception: click on the 'Web content' 'Exceptions' button Under address of website, Enter: https://accounts.google.com set to 'Allow'. click on 'Save Changes'

Exit Thunderbird and then start Thunderbird to ensure all gets properly updated to files. Then enter info at the gmail prompt.

Do you have any software on your computer which cleans up files eg: CCleaner, WiseCleaner or even your Anti-Virus can be set to clean up temp files which may include cookies, session files etc? If yes, then you must create an exception for Thunderbird - those types of products must not be allowed access to any Thunderbird profile file or folder.

What Anti-Virus are you using ?

more options

* Selected: Remember web sites and links I've visited * Selected: Accept cookies from sites * Accept third-party cookies: Always * Keep until : they expire * Not selected: 'Send web sites 'Do not track'....

Exactly the same here

Please try this in same 'Privacy & Security' area. Create an exception: click on the 'Web content' 'Exceptions' button Under address of website, Enter: https://accounts.google.com set to 'Allow'. click on 'Save Changes

I have done this now and restarted TB.

I have no "cleaning" software. I also do not have AV software. Instead have NoScript on my browsers. I am the only one who touches my PC and am VERY vigilant. Never had a virus problem [touches wood].

Subsequent to the above cookie exception, the behaviour of TB is unchanged :-( . Still failing in the same way. Still no Google cookie present.

I have tried with the firewall switched off completed, but still no-go.

Hmmmm ...

Maybe I'll try booting up in Safe Mode, without extraneous driver, and see if TB succeeds.

Thanks.

Okulungisiwe ngu thegoodguy

more options

I tried safe-mode (with networking). TB still failing :-(

more options

Isisombululo Esikhethiwe

Starting TB in safe-mode worked. The problem must be one of the add-ons transferred from the installation of the older TB. Now I just have to work out which one.

Thanks for your time and efforts.

more options

Nope. TB will ONLY work safe-mode. I removed all add-ons ... TB fails. I started in safe-mode, checked "disable all add-ons" and Reset toolbars and controls" ... still TB fails. It literally only works in safe-mode :-(

more options

See if it is due to hardware acceleration as this is auto switched off in safe mode. Start as normal so it gets switched on.

  • Menu app icon > Preferences > General
  • Scroll to bottom
  • uncheck 'Use hardware acceleration when available'

then exit Thunderbird, wait a few moments and then start Thunderbird as normal.

more options

See if it is due to hardware acceleration as this is auto switched off in safe mode.

Just tried. No joy. Same failure. :-(

Safe Mode temporarily affects the following:

   All extensions are disabled. 
   The default theme is used, without a persona. 
   The Just-in-time (JIT) JavaScript compiler is disabled. 
   The userChrome.css and userContent.css files are ignored. 
   The default toolbar layout is used. 
   Hardware acceleration is disabled.

Items 1,2 and 6 I can control through settings. What about the other three? Can I set those manually?

Thanks

more options

With Thunderbird shut down:

  • Rename userChrome.css and userContent.css files if they exist.
  • Delete extensions.json, addons.json and extensions directory
more options

With Thunderbird shut down:

Rename userChrome.css and userContent.css files if they exist. Delete extensions.json, addons.json and extensions directory

No joy I'm afraid. Still failing. There's something else that safe-mode disables, obviously.

I've just changed the TB shortcut icon so that it now starts up in safe-mode. Annoyingly it won't start without the pop-up asking me stuff :-(

I'm feeling like jumping the TB ship, after 20 odd years, is my only option now :-(

Okulungisiwe ngu thegoodguy

more options

Menu app icon > Help > More Troubleshooting Information Under 'Application Basics' - Profile Folder - click on 'Open Folder' This opens a new window showing the contents of your current in use profile name folder.

Exit Thunderbird now - this is important.

Some time ago, it was discovered the pkcs11.txt was causing an issue. It makes you wonder if this has returned. Perhaps you do not even have that pkcs.txt file - it should be there.

Look for the following files and delete them.

  • cert8.db - obselete file
  • key3.db - obselete file
  • pkcs11.txt
  • secmod.db - obselete file
  • session.json
  • xulstore.json

NOTE: For this first test do NOT delete:

  • key4.db
  • cert9.db
  • logins.json

Because we need to find out if this is the pkcs.txt file issue first. Let us know if the 'pkcs.txt' file existed or not, so we know whether the 'pkcs.txt' being missing caused problem.

Start Thunderbird. New pkcs11.txt, session.json, xulstore.json files will get created.

Report back on results.

Okulungisiwe ngu Toad-Hall

more options

cert8.db - obselete file - existed/deleted key3.db - obselete file - existed/deleted pkcs11.txt - existed/deleted secmod.db - obselete file - existed/deleted session.json - existed/deleted xulstore.json - 2 of these existed, one the profile folder and one in a chrome-debugger folder. Deleted both

Sent test email from another account and restarted TB in "normal" mode ......

It only bloody worked !!! :-) No more fail! There is a God and his name is Toad-Hall

Thank you so much. There is no way that I could possibly have figured out which (seemingly) random files to eleminate/refresh.

One last question: The older version of TB (v59) that I updated from from, thinking it would solve my authentication problem, is something I'd like back again because there was one extension that I miss (minimise to tray). If I were to go through the same files removal/refreshing process, do you think v59 may work too?

Thanks again.

more options

Many thanks for your feedback, it is very useful as I believe I've found a solution to a very specific situation and your response has helped to confirm it.

It was also interesting to note that in your case, you say the 'pkcs.txt' file did exist as in some other cases this file did not exist, which is very wrong.

I'm glad to hear it's all sorted and up and running again.

more options

re :One last question: The older version of TB (v59) that I updated from from, thinking it would solve my authentication problem, is something I'd like back again because there was one extension that I miss (minimise to tray). If I were to go through the same files removal/refreshing process, do you think v59 may work too?

Since version 78.0, Minimize to tray support was added for Windows - whenever you minimize Thunderbird window it will not be closed. So, there is no need to use old versions requiring old addon.

  • Menu app icon (or 'Tools' on 'Menu bar') > Preferences > General
  • Under 'System Integration'
  • select check box: 'When Thunderbird is minimised, move it to the tray'
  • Then restart Thunderbird.

Okulungisiwe ngu Toad-Hall

more options

Toad-Hall said

re :One last question: The older version of TB (v59) that I updated from from, thinking it would solve my authentication problem, is something I'd like back again because there was one extension that I miss (minimise to tray). If I were to go through the same files removal/refreshing process, do you think v59 may work too? Since version 78.0, Minimize to tray support was added for Windows - whenever you minimize Thunderbird window it will not be closed. So, there is no need to use old versions requiring old addon.
  • Menu app icon (or 'Tools' on 'Menu bar') > Preferences > General
  • Under 'System Integration'
  • select check box: 'When Thunderbird is minimised, move it to the tray'
  • Then restart Thunderbird.

Brilliant. Thanks v much :-)