Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

AD Blocker Message

  • 15 uphendule
  • 3 zinale nkinga
  • 102 views
  • Igcine ukuphendulwa ngu ericbates

more options

Firefox Browser uprated to 92.0 today. Previously whilst browsing Ad's were showing; today I have no Ad's displayed but have not enabled an Ad Blocker on Firefox. A site I use extensively cannot now be properly viewed; I get a message to turn off Ad Blocker. I have set Enhanced Tracking Protection to 'Off' but am still unable to obtain full functionality, I am using standard Firefox Privacy settings otherwise. I am able to browse the site properly using MS Edge. I have deliberately refrained from using any AD Blocking on my part so as to ensure the site in question can be properly viewed. The only Firefox extension being used is Kaspersky Protection; I get the turn off Ad Blocker message both when Kaspersky Protection is on or off.

Isisombululo esikhethiwe

This seems to be about a new feature in Firefox called smartblock that replaces some tracking scripts with a limited local version. If I disable this smartblock feature via the about:config page then the ads appear and the website works.

It would be nice if you could disable this feature on websites that aren't working properly with it enabled.

See also:

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (15)

more options

If the ad blocker was enabled before the update, it should still be enabled.


Load the web page. After the page is loaded, click the AdBlock icon. Now select Disable on <website>. After, reload the page.

Helpful?

more options

Make sure you are not blocking content.

Diagnose Firefox issues using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?


https://support.mozilla.org/en-US/kb/enhanced-tracking-protection-firefox-desktop


Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

Helpful?

more options

Hi Fred Thanks for your response. I have tried each of the steps suggested but without success. I also tried a refresh of Firefox and a renaming of the Prefs Java file within my profile just in case. The bottom line is that even without an Ad Blocker I am not seeing any Ad's when using Firefox. As such my access to the site mentioned earlier is restricted. Do you have any other suggestions. Do you think deleting Firefox and reinstalling might help?? Best regards Eric

Helpful?

more options

Start your Computer in safe mode with network support. Then start Firefox. Try Secure websites. Is the problem still there?

Starting Any Computer In Safe Mode (web link) Free Online Encyclopedia

https://www.bleepingcomputer.com/tutorials/how-to-start-windows-in-safe-mode/

https://www.digitalcitizen.life/4-ways-boot-safe-mode-windows-10/ +++++++++++++++++++++++++++++++++++++++++++++++ If the problem goes away with the computer in Safe Mode, the problem is with one of the other programs on the system.

As a test, disable your protection programs.

Helpful?

more options

The problem persists whilst the computer is in safe mode. I would also advise that as a test I downloaded Firefox to my wife's computer; the same no Ad's problem occured. To complete the picture I have also tried Firefox with my Kaspersky Internet Security disabled, I have also reset KIS settings to their default yet the issue continues.

Helpful?

more options

I called for more help.

Helpful?

more options

Can you post a link to a publicly accessible page (i.e. no authentication or signing on required)?

You can check the Web Console (Tools -> Web Developer) for messages about blocked content and about the presence of mixed or unsafe content.

You can check the Network Monitor to see if content is blocked or otherwise fails to load.

If necessary use "Ctrl+F5" or "Ctrl+Shift+R" (Mac: Command+Shift+R) to reload the page and bypass the cache to generate a fresh log.

Helpful?

more options

Have a look at https://www.purposegames.com Ad's ought to appear on the right hand side of the page under 'Your Skills & Rank'. If you try a quiz say https://www.purposegames.com/game/united-states-slide-quiz then after a few seconds the following message is shown:- Hello! We are really sorry to do this but PurposeGames uses ads. We, like many others, are trying to keep making a living out of running our website. It would help us a lot if you turned off any ad blocker when using PurposeGames. Again, we are really sorry for the inconvenience and hope you will understand! Thank you for your continued support! The PurposeGames Team I'm sorry but Web Console etc is too technical for me

Helpful?

more options

Hello! We are really sorry to do this but PurposeGames uses ads.


This is not an ad per-sey, it is part of the webpage. No blocker can remove this.

Helpful?

more options

I think we are at cross purposes here. With Firefox 91 I saw commercial Ad's on the site in question, they were displayed as mentioned on the right hand side of the page under 'Your Skills & Rank'. When I played quizzes there were no issues or messages. With Firefox 92 I no longer see Ad's on the site page; if I try a quiz I get the message 'Hello! We are really sorry to do this but PurposeGames uses ads....' it is no longer possible to complete quizzes. I have not changed any settings in Firefox; there is clearly something in the upgrade from version 91 to version 92 that is stopping the normal Ads being displayed. This in turn leads to the error message 'Hello! We are really sorry to do this but PurposeGames uses ads...' Obviously the error message is part of the webpage and it is not in itself an Ad, I am not trying to remove this. I have the same issue with Firefox 92 on my wife's laptop, my old laptop and my tablet, with each I get the site error message because normal commercial Ad's are no longer seen. I an not trying to block any Ad's on the site; I don't run an Ad Blocker but there is something within Firefox 92 which differs from Firfox 91 which causes ordinary commercial Ad's to be blocked. As mentioned I have no issues with the PurposeGames site using MS Edge; I simply see the normal Ads I used to see with Firefox 91 Do you see normal Ad's on PurposeGames site with Firefox 92?

Helpful?

more options

Isisombululo Esikhethiwe

This seems to be about a new feature in Firefox called smartblock that replaces some tracking scripts with a limited local version. If I disable this smartblock feature via the about:config page then the ads appear and the website works.

It would be nice if you could disable this feature on websites that aren't working properly with it enabled.

See also:

Okulungisiwe ngu cor-el

Helpful?

more options

Note that you may have to reload and bypass the cache after disabling smartblock.

You can reload webpage(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Helpful?

more options

Thanks. I have regained the Ad's by disabling Smartblock. The site in question now works as it used to.

Helpful?

more options

Clicking the "Shield Icon" Tracking Protection and choosing "Enhanced Tracking Protection" OFF solved my problem of unwanted warning to "turn off Ad Blocker" even though an Active Intentional Ad Blocker was NOT running! Clicking the "Shield Icon" Tracking Protection and choosing "Enhanced Tracking Protection" OFF solved the issue. However, the popup might erratically reappear. Simply refresh the page and popup disappears. Hope this helps alleviate this damnable issue!!

Helpful?

more options

Stephen Thanks for your suggestion

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.