Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Fonts Not Displaying on Some But Not All Sites

  • 4 uphendule
  • 1 inale nkinga
  • 21 views
  • Igcine ukuphendulwa ngu info5858

more options

My desktop Mac suddenly (July 28) quit displaying page specified fonts, in some - not all - instances, using Inspector reveals affected sites defaulting to Helvetica Last Resort, or failing to display Open Sans via gstatic.com. For comparison, my laptop - same FF v.78.12.0esr, using the same (advanced - default) fonts and colors settings - displays everything properly, as do those same sites on mobile. This is a local problem.

Those sites affected work fine using Chrome, Safari, which indicates system level fonts are loading properly.

Of the sites affected, one thing in common seems to be that they are WordPress/PHP dynamic sites.

I use FontExplorerX font management, which has been stable for years. There aren't any reported conflicts.

Application and system font caches have been flushed.

Firefox has been freshened.

I feel like this may be a corrupted prefs file somewhere, but have no idea how to proceed.

Attached images show different page display results using same search term in Google, DuckDuckGo, and two sites that are affected.

Ama-screenshot ananyekiwe

Isisombululo esikhethiwe

Problem solved.

  1. Cleaned up FontExplorerX database, removed duplicate fonts, emptied app, user, and system caches. The only remaining anomalies are an occasional glitch displaying characters styled as italic.
  2. Ran Disk Utility Repair Permissions several times, which seems to have fixed the FF display of WordPress sites.
Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (4)

more options

Do you have local copies installed of these problematic fonts ?

This can happen if you have these fonts installed in a location that is blocked by the sandbox on Mac. The solution would be to move these fonts to system fonts.

Helpful?

more options

Not sure what you mean. The fonts not showing properly (in FF) run the gamut, some sites still work fine, others don't. Considering that most sites run some form of @font-face the number of fonts that could be causing the problem would be significant, if that were the problem.

The problem is confined to FF, and doesn't affect Chrome or Safari, nor does it affect my laptop FF.

Helpful?

more options

I seem to have two issues: 1) FF not loading styled fonts, but Chrome does. 2) FF not interpreting styled fonts in Wordpress, but Chrome does. I'm working through the former, and some issues seem to relate to FontExplorer and Apple System fonts.

Helpful?

more options

Isisombululo Esikhethiwe

Problem solved.

  1. Cleaned up FontExplorerX database, removed duplicate fonts, emptied app, user, and system caches. The only remaining anomalies are an occasional glitch displaying characters styled as italic.
  2. Ran Disk Utility Repair Permissions several times, which seems to have fixed the FF display of WordPress sites.

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.