Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwavalwa lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

I have updated my O/S from Ubuntu 18.04 to 20.10. Nothing else. Now Firefox is nearly useless

  • 1 baphendule
  • 1 inale nkinga
  • Igcine ukuphendulwa ngu Seburo

more options

This is basically a copy of what I put in the Ubuntu forum. The problem is the same, no matter where I post it.

Originally I was using Ubuntu 18.04 LTS.

I thought it would be good to update to GG (20.10) though I did briefly try FF (20.04).

As the install was done on an existing 18.04 version things remained the same for programs, book marks, etc.

Ok, now the crunch: I USE Firefox ""A LOT"". When it loads, there are...... 8 x 6 windows of FireFox and each of those have anywhere from one to ""THIRTY"" tabs loading.

Believe me: ""It worked!!""

I could use it, also run other tasks as well - though a VM was pushing it with the RAM. But the entire machine worked.

Now, I am lucky if FireFox loads at all. Let alone let me browse.

When it loads some of the window's tops are flashing. A screen shot does not really show this. (I tried)

All that has changed is the O/S from 18.04 and Firefox from (what ever it was) to 83.0

I don't want this to be a finger pointing exercise between Mozilla and Ubuntu. I would prefer it is helpful to all.

What have I tried? I've tried starting FireFox with all addons disabled. Still happens.

I am going to try to remember to (next time) launch FireFox from a Terminal and pipe the output to a file to look for things.

The machine I am using has shown it is well up to being able to have this running. I have had it working for a few years like this.

This post is (for now) to establish there is a problem. I will post more information when I get it, rather than waiting to get it then post, as I feel there are a lot of people who have very similar problems and I want it known: ""You are not alone!""

Now a bit of extra stuff.

Other things which are weird: When I am watching stuff - youtube for example - the playback is/WAS jerky. I hadn't touched anything in the settings.

After digging around, I discovered that I had to turn ""OFF"" the hardware acceleration for the graphics. Question: How did it get turned on? (Semi rhetorical)

I have a lot of local pages I open with passwords. When I load them the CPU load goes through the roof and nearly invariably the program just exits. No crash report.

Which is a good 50% of how it happens. The other 50% is the machine just locks up and I have to power it down.

All Replies (1)

more options


I am going to lock this thread as it appears to be a duplicate of: