Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Mouse pointer keeps spinning for up to 40 seconds after launch

  • 1 baphendule
  • 1 inale nkinga
  • 11 views
  • Igcine ukuphendulwa ngu jsamcr

more options

I am running Debian 10 Linux and recently upgraded Firefox ESR to version 78.3.0 . I noticed that whenever I launch Firefox that the mouse pointer "spins" for up to 40 seconds after launch. This does not seem to affect usability but is visually unpleasant. I have done the following things: 1. Start in Safe Mode: The spinning mouse pointer is no longer spinning after launch. 2. Disabled all plugins and extension and launch Firefox: The pointer keeps spinning. 3. Downloaded Firefox 80 and launched: Pointer keeps spinning. 4. Changed home page to a blank screen: Pointer keeps spinning. 5. Uninstalled Firefox ESR and re-installed: Pointer keeps spinning. 6. Checked for viruses, trojans, and other malware: none found.

Interestingly, if I launch Firefox ESR from a terminal (eg "firefox-esr &") the spinning mouse pointer is not present. HMMMM! This is the command that is used in the desktop icon: /usr/lib/firefox-esr/firefox-esr %u . Is there a problem with that command. I may modify that command and see what happens. Feedback would be appreciated.

Isisombululo esikhethiwe

It appears that the problem, at least in the case of firefox-esr on Debian 10 (with XFCE and Lightdm), is the last line in the /usr/share/applications/firefox-esr.desktop file. The last line of the file is StartupNotify=true . If that is changed to StartupNotify=false the problem goes away.

However, changing that file would not be a permanent fix since the next update would probably overwrite the file.

My solution was to create a desktop launcher where I have the command "firefox-esr". This solution was easy as I am using XFCE and Lightdm. I don't know how easy it would be to implement with other desktops and display managers. Also, I have no idea how one would implement the solution for other OS's such as Windows or the Mac OS but it shouldn't be that hard.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (1)

more options

Isisombululo Esikhethiwe

It appears that the problem, at least in the case of firefox-esr on Debian 10 (with XFCE and Lightdm), is the last line in the /usr/share/applications/firefox-esr.desktop file. The last line of the file is StartupNotify=true . If that is changed to StartupNotify=false the problem goes away.

However, changing that file would not be a permanent fix since the next update would probably overwrite the file.

My solution was to create a desktop launcher where I have the command "firefox-esr". This solution was easy as I am using XFCE and Lightdm. I don't know how easy it would be to implement with other desktops and display managers. Also, I have no idea how one would implement the solution for other OS's such as Windows or the Mac OS but it shouldn't be that hard.

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.