Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Extensions no longer functioning after firefox refresh

  • 7 uphendule
  • 1 inale nkinga
  • 16 views
  • Igcine ukuphendulwa ngu bshirakawa

more options

I refreshed Firefox, now Lastpass and Ghostery don't show up in my toolbar or work anymore (Mac OS 10.9.5). I removed the Lastpass extension, then reinstalled to no avail. Oddly, Adblock Plus is in my toolbar and works fine. Attached photo shows Adblock, but no Lastpass or Ghostery icons in my toolbar.

Ama-screenshot ananyekiwe

Isisombululo esikhethiwe

What kind of preference changes? I have one in mind that could have unintended consequences.

If you change Firefox to using automatic private browsing -- on the Preferences page, Privacy & Security panel, History section, either:

  • Firefox will: Never remember history
  • Firefox will: Use custom settings for history + [x] Always use private browsing mode

-- then your extensions need to be enabled for private windows or they will not run.

On the Add-ons page, if there isn't a purple mask icon next to the extension's name, click the name to view the Details panel, then scroll down to where you can grant permission to run in private windows.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (7)

more options

It’s possible that there is a problem with the file(s) that store the extensions registry.

Type about:support in the address bar and press enter.

Under the page logo on the left side, you will see Application Basics. Under this find Profile Folder. To its right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder

Linux: Under the page logo on the left side, you will see Application Basics. Under this find Profile Directory. To its right press the button Open Directory.

Delete all extensions* files and compatibility.ini in the Firefox profile folder to reset the extensions registry.

New files will be created when required.

After, restart Firefox.

See "Corrupt extension files":

+++++++++++++++++++++++++++ You will have to approve the updating one last time.

Helpful?

more options

Did as you recommended, but no go. Removed the extension files, etc, reinstalled Lastpass and Ghostery, but they still do not show up in the toolbar (see attached). Lastpass, Ghostery show up as "enabled" in my Add Ons manager. Was unsure what you meant by "you will have to approve updating one last time." Appreciate your help, thanks!

Helpful?

more options

Look at the far right of the toolbar. Do you see a double arrow? Press it.

Helpful?

more options

No, no double arrow. I trashed Firefox, including any folders. After reinstalling I was able to add Lastpass, Ghostery and Adblock Plus. But after making changes to some preferences in firefox, they disappeared again. I trashed Firefox a second time and re-added the extensions. for the moment, they are showing up in my toolbar area, but I have not made any preference changes. Not sure what the heck is going on, but thanks for your assistance!

Helpful?

more options

You may have ad/mal-ware. Further information can be found in this article; https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-caused-malware?cache=no

Run most or all of the listed malware scanners. Each works differently. If one program misses something, another may pick it up.

Helpful?

more options

Isisombululo Esikhethiwe

What kind of preference changes? I have one in mind that could have unintended consequences.

If you change Firefox to using automatic private browsing -- on the Preferences page, Privacy & Security panel, History section, either:

  • Firefox will: Never remember history
  • Firefox will: Use custom settings for history + [x] Always use private browsing mode

-- then your extensions need to be enabled for private windows or they will not run.

On the Add-ons page, if there isn't a purple mask icon next to the extension's name, click the name to view the Details panel, then scroll down to where you can grant permission to run in private windows.

Helpful?

more options

Thanks Jscher2000 ! I was changing that setting for History, and think that's what kicked my add ons off my toolbar. Appreciate it!

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.