Scheduled maintenance: Thursday, September 24, between 11:30am and 13:30pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @FirefoxSupport on Twitter

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Input delay in search field on Google-related sites

  • 1 baphendule
  • 1 inale nkinga
  • 12 views
  • Igcine ukuphendulwa ngu Daniela Chris

more options

I'm using Firefox 79.0 on Win10 x64. When I'm searching on Google, Facebook or Youtube, there is a 10-20 seconds delay between my input and its display in search field, and it's displaying symbols I entered at 1 symbol in 1-2 seconds. After around a minute the delay cuts to minimal and I can use the search normally (but by that time site is already responding to the earlier input which sometimes can be in wrong keyboard layout or misspelled because I didn't see what I was typing until 1 minute after I typed it). I don't have this problems at the websites that are not Google-related, also I don't have it in other browsers. I've tried restarting Firefox (obviously, as this problem persists for weeks now) and/or clearing cache, didn't help.

All Replies (1)

more options

It seems that the problem was caused by Kaspersky. I did some more searching and found this fix in Kaspersky settings: Settings → Additional → Network Settings → Uncheck “Inject scripts into web traffic to interact with web pages” Then I restarted Firefox and now the search seems to be running just fine.

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.