Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Firefox Wifi Login Connection Does Nothing (see description)

  • 7 uphendule
  • 2 zinale nkinga
  • 34 views
  • Igcine ukuphendulwa ngu hrefnam

more options

I often connect to a public wifi network. I find I have to use an alternate browser to get to the connection page because Firefox refuses to load it. Basically, I get the message that I have to login to the network; I click the "Connection" button, and a page loads that tells me the wifi login page isn't secure. I click the "Advanced" link, and I can then either 1) Cancel, 2) View the Certificate, or 3) Proceed at my own risk. I choose 3, and Firefox does nothing. I click the link, and the link seems to be dead ... it literally just does nothing.

This is really annoying. I connect to this network daily. I understand the network isn't configured properly, but I'm not the admin and I can't do anything about it. I resent FF for preventing me from connecting while seeming to give me the opportunity to connect. I've tried changing settings in about:config, but nothing works. I end up loading Chrome just to get to the login page for the network, where I then connect, and then immediately kill Chrome and go back to whatever I was trying to do. It's so annoying I have considered just abandoning Firefox, but I've been using it since 2005 and really don't want to use Chrome.

How can I get around this behaviour and connect to the wifi network using Firefox? Please let me know if you need screenshots or more information and I'll see what I can do.

All Replies (7)

more options

That is frustrating. Perhaps a blockup is supposed to appear and is being blocked?

Per this: https://www.auslogics.com/en/articles/fix-public-wifi-login-page-not-showing-up/ Firefox:

   Launch the browser.
   Click the Menu icon (the horizontal three dots).
   Click on Preferences > Content.
   Unmark the checkbox for ‘Block pop-up windows.’
   Close the Preferences tab or re-launch the browser.

Also, after you’ve disabled the option in your browser settings, make sure to turn off any third-party pop-up blocker that’s active on your PC.

Helpful?

more options

@Eve - Hi, sorry it's taken so long for me to respond. I'll try this. Thanks.

Helpful?

more options

Hi

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select Network. Look for Configure How Firefox Connects and press the Settings button. If you are using a proxy, make sure those settings are correct. If there is no proxy, first use No Proxy. If there is a problem, then try System Proxy.

Helpful?

more options

Tested, and, no, no change. :/

Eve said

That is frustrating. Perhaps a blockup is supposed to appear and is being blocked? Per this: https://www.auslogics.com/en/articles/fix-public-wifi-login-page-not-showing-up/ Firefox: Launch the browser. Click the Menu icon (the horizontal three dots). Click on Preferences > Content. Unmark the checkbox for ‘Block pop-up windows.’ Close the Preferences tab or re-launch the browser. Also, after you’ve disabled the option in your browser settings, make sure to turn off any third-party pop-up blocker that’s active on your PC.

Okulungisiwe ngu hrefnam

Helpful?

more options

Here's a screenshot of the connection page. It's in French (sorry, I keep my second language alive by configuring my computer's primary language to be French), but you should be able to recognize that screen and what those buttons are, etc. Popups are unblocked at this point. Clicking either of those buttons does nothing. It's like clicking an HTML link where the href is "#" (i.e. it's a link to nothing).

I'd love to know why it's doing this. I have a workaround by loading another browser to get to the wifi page, but, it's really annoying having to do so.

Okulungisiwe ngu hrefnam

Helpful?

more options

Is DNS over HTTPs enabled in Options > General > Network Settings? If so, try disabling it, perhaps that might work.

Okulungisiwe ngu Nisarg

Helpful?

more options

Nisarg said

Is DNS over HTTPs enabled in Options > General > Network Settings? If so, try disabling it, perhaps that might work.

Ok. I disabled it. Will test and get back to you.

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.