Search Support

FF 74.0.1: Recurring "Error: WebGL context was lost"

  • 8 uphendule
  • 1 inale nkinga
  • 56 views
  • Igcine ukuphendulwa ngu MozMi

more options

Hi,

Since some days I get an recurring error: "Error: WebGL context was lost". (see attached screenshot from the console) This happens when I try to log in into one specific website only. I'm using FF 74.0.1 portable. It does not happen with the local installed instance or a new FF portable instance (also 74.0.1). When I migrate my profile into the other (new) FF portable instance the problem happens in the new FF portable instance, too. Restart with disabled AddOns didn't do the trick. I search the internet and found something about hardware acceleration and graphics drivers, but for the reason that it is working with the other two FF it seems to be a problem in my current profile (I also checked unsuccessful on another device). I don't like to start configuring a new profile, because I'm using many blocking AddOns which I configured during long usage (time consuming to redo....).

I had a look into about:config and have seen that there are some settings regarding "WebGL" but I do not want to start over with more trial and error.

Any ideas?

Many thanks!!!! :-)

Ama-screenshot ananyekiwe

Isisombululo esikhethiwe

You can remove all data stored in Firefox for a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox for this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data for that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data for that website will be saved once again.


You can check for problems with preferences. You can delete possible user.js and numbered prefs#-##.js files and rename/remove the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in current Firefox releases.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.


You can create a new profile as a quick test to see if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (8)

more options

How many WebGL elements are there on the web page ?

Firefox only supports a maximum of 16 per principal. If there are more then you get this error.

Helpful?

more options

Hi, I don't know how to count them, but for the reason that it is working with another instances of FF, I don't think, that this is the cause of the problem.

Helpful?

more options

Did this work properly in previous Firefox versions ?

Do you otherwise have problems with WebGL ?

Any specific WebGL related messages in the Web Console ?

See also the graphics section on the "Help -> Troubleshooting Information" (about:support) page.

Can you post a link to a publicly accessible page (i.e. no authentication or signing on required) if that only happens on that website ?

Helpful?

more options

Hi,

It didn't happen before with previous versions of FF, even with the same version, but other instance (see above). I don't have other problems with WebGL.

I would like to send you the log, but I haven't found how to export it or where to grab it. I didn't see something in the console now with WEGGL but an XHR error: 403. See attached a new screenshot... I don't what I shell look in the about:config/graphics section for.

-(

It happens only with this site: https://www.ebay-kleinanzeigen.de/m-einloggen.html?targetUrl=/

Many thanks for further help! :-)

Helpful?

more options

The link you posted requires to login (I get a login page), so I can't check this.

The screenshot shows that the Firefox limit of 16 live WebGL contexts for this principal has been exceeded. Reloading the page may not free unused WebGL contexts and might even magnify this issue and you may have to close the tab and retry.

Helpful?

more options

OK, I try to explain again: The page is reloading by itself continously and automatically every two seconds in my FF! You/me do not have to login. It's this page...

Helpful?

more options

Isisombululo Esikhethiwe

You can remove all data stored in Firefox for a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox for this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data for that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data for that website will be saved once again.


You can check for problems with preferences. You can delete possible user.js and numbered prefs#-##.js files and rename/remove the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in current Firefox releases.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.


You can create a new profile as a quick test to see if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

Helpful?

more options

Hi,

"Forget About This Site" didn't work. I didn't had a user.js, but 5 prefs#-##.js. I deleted them manually after closing FF in the profiles folder and this did the trick!!!

Many many thanks for you patience and help and also for the help you are doing for all the other guys here in the forum!!!

Warm regards MozMi

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.