Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

I can't translate a page on Firefox using Google translation. what can be done?

more options

When I try to translate a page on Firefox using Google translation, I just can't. But, if I mark text, I can translate it.

Isisombululo esikhethiwe

Hi Gad Feldan, I'm not sure about the extensions you've tried, but there are three possible strategies:

(1) Send the URL of the page to Google Translate (leave the page or open a new tab)

Google will attempt to independently retrieve the page and translate it. This may fail for numerous reasons. I think that might be what is happening in your first screenshot.

(2) Use an official Google Translate API to translate the page "in place"

This may require a paid developer account with Google, so I don't know if it is used in free extensions. But this should work as long as the API key is valid.

(3) Insert the Google Translate Widget to translate the page "in place"

The widget script was released for website authors to add translation to their own pages, but you actually can inject it into any site that doesn't block external Google scripts.

Mozilla recently blocked/removed a number of these extensions due to a new policy that doesn't allow extensions to inject external scripts -- all scripts need to be included with the extension to be approved.

A partial workaround for the block is to user one of the userscript extensions (Tampermonkey or Violentmonkey) and a userscript to inject Google's script. I posted such a userscript over here:

https://greasyfork.org/en/scripts/391935-inject-google-translate-widget

I tested in on the bild article and it worked for me (screenshot attached), although I admit I'm blocking a lot of content in that page, so if our blocking strategies are different, the result also could be different.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 2

All Replies (16)

more options

Please explain in detail what you are doing to translate the page.

more options

Translate a webpage in Firefox

To add a new language-

   01.Click on the menu button on the top right corner of your browser
   02.Go to Preferences 
   03.Then click on ‘Choose in the Language and Appearance section’.
   04.Select any language you want and click OK.

For translation in Firefox,have to install the Firefox Translation extensions. Some of the most popularly used add-ons are GoogleTranslatorforFirefox or ToGoogleTranslate.

more options

I have an addon called Simple Translate. In the past, I used to get a translation of the page, but now I get a blank page with the headline "Translating" and no translation appears. Or I get a message: "There has been an error translating this page". But, if I mark text, I can translate it.

Okulungisiwe ngu Gad Feldan

more options

Senali Madawala said

Translate a webpage in Firefox To add a new language- 01.Click on the menu button on the top right corner of your browser 02.Go to Preferences 03.Then click on ‘Choose in the Language and Appearance section’. 04.Select any language you want and click OK. For translation in Firefox,have to install the Firefox Translation extensions. Some of the most popularly used add-ons are GoogleTranslatorforFirefox or ToGoogleTranslate.

I'm sorry, but that's not what I asked. Anyway, thank you very much.

more options

Sounds that your extension is currently broken.

You can try to disable/enable and uninstall/reinstall the extension to see if this makes the extension work again.

You can also check the Browser Console for related messages.

  • "3-bar" menu button or Tools -> Web Developer
more options

I disabled all add-ons except Simple Translate and it didn't help. Then I uninstalled and reinstalled Simple Translate (when the other add-ons are disabled) and that didn't help either.

more options

Sorry for the previous answer.Trying with another Translater may help to solve this. Because I tried to translate that web page with the 'to google translate' and it's working to me.

Okulungisiwe ngu Senali Madawala

more options

Senali Madawala said

Trying with another Translater, may help to solved this. Because I tried to translate that web page with the 'to google translate' and it's working to me.

Thanks. I tried, but it didn't work to me

more options

Isisombululo Esikhethiwe

Hi Gad Feldan, I'm not sure about the extensions you've tried, but there are three possible strategies:

(1) Send the URL of the page to Google Translate (leave the page or open a new tab)

Google will attempt to independently retrieve the page and translate it. This may fail for numerous reasons. I think that might be what is happening in your first screenshot.

(2) Use an official Google Translate API to translate the page "in place"

This may require a paid developer account with Google, so I don't know if it is used in free extensions. But this should work as long as the API key is valid.

(3) Insert the Google Translate Widget to translate the page "in place"

The widget script was released for website authors to add translation to their own pages, but you actually can inject it into any site that doesn't block external Google scripts.

Mozilla recently blocked/removed a number of these extensions due to a new policy that doesn't allow extensions to inject external scripts -- all scripts need to be included with the extension to be approved.

A partial workaround for the block is to user one of the userscript extensions (Tampermonkey or Violentmonkey) and a userscript to inject Google's script. I posted such a userscript over here:

https://greasyfork.org/en/scripts/391935-inject-google-translate-widget

I tested in on the bild article and it worked for me (screenshot attached), although I admit I'm blocking a lot of content in that page, so if our blocking strategies are different, the result also could be different.

more options

Thank you very much. The problem is that Firefox prevents the page from connecting to translate.googleusercontent.com . That's why I changed the value of accessibility.blockautorefresh in about: config to false as your suggestion at https://support.mozilla.org/en-US/questions/1178877. It solved almost the whole problem for me. There is yet a site https://www.thewindowsclub.com/ that when I am trying to translate, I get a message "The page is invalid upload. There was an error connecting to translate.googleusercontent.com". Other pages I can translate now.

Okulungisiwe ngu Gad Feldan

more options

Try coping the text, pasting it into google translate, coping the translation, and then pasting it back into the sight. I know that it might not be easy, but it might work.

more options

Try copying the text, pasting it into google translate, copying the translation, and then pasting it back into the sight. I know that it might not be easy, but it might work.

more options

ali.rogers3608 said

Try copying the text, pasting it into google translate, copying the translation, and then pasting it back into the sight. I know that it might not be easy, but it might work.

Thank you. I tried and it didn't work.

more options

jscher2000 said

Hi Gad Feldan, I'm not sure about the extensions you've tried, but there are three possible strategies: (1) Send the URL of the page to Google Translate (leave the page or open a new tab) Google will attempt to independently retrieve the page and translate it. This may fail for numerous reasons. I think that might be what is happening in your first screenshot. (2) Use an official Google Translate API to translate the page "in place" This may require a paid developer account with Google, so I don't know if it is used in free extensions. But this should work as long as the API key is valid. (3) Insert the Google Translate Widget to translate the page "in place" The widget script was released for website authors to add translation to their own pages, but you actually can inject it into any site that doesn't block external Google scripts. Mozilla recently blocked/removed a number of these extensions due to a new policy that doesn't allow extensions to inject external scripts -- all scripts need to be included with the extension to be approved. A partial workaround for the block is to user one of the userscript extensions (Tampermonkey or Violentmonkey) and a userscript to inject Google's script. I posted such a userscript over here: https://greasyfork.org/en/scripts/391935-inject-google-translate-widget I tested in on the bild article and it worked for me (screenshot attached), although I admit I'm blocking a lot of content in that page, so if our blocking strategies are different, the result also could be different.

Thank you very much. The problem is that Firefox prevents the page from connecting to translate.googleusercontent.com . That's why I changed the value of accessibility.blockautorefresh in about: config to false as your suggestion at https://support.mozilla.org/en-US/questions/1178877. It solved almost the whole problem for me. There is yet a site https://www.thewindowsclub.com/ that when I am trying to translate, I get a message "The page is invalid upload. There was an error connecting to translate.googleusercontent.com". Other pages I can translate now.

Okulungisiwe ngu Gad Feldan

more options

Gad Feldan said

jscher2000 said
Hi Gad Feldan, I'm not sure about the extensions you've tried, but there are three possible strategies: (1) Send the URL of the page to Google Translate (leave the page or open a new tab) Google will attempt to independently retrieve the page and translate it. This may fail for numerous reasons. I think that might be what is happening in your first screenshot. (2) Use an official Google Translate API to translate the page "in place" This may require a paid developer account with Google, so I don't know if it is used in free extensions. But this should work as long as the API key is valid. (3) Insert the Google Translate Widget to translate the page "in place" The widget script was released for website authors to add translation to their own pages, but you actually can inject it into any site that doesn't block external Google scripts. Mozilla recently blocked/removed a number of these extensions due to a new policy that doesn't allow extensions to inject external scripts -- all scripts need to be included with the extension to be approved. A partial workaround for the block is to user one of the userscript extensions (Tampermonkey or Violentmonkey) and a userscript to inject Google's script. I posted such a userscript over here: https://greasyfork.org/en/scripts/391935-inject-google-translate-widget I tested in on the bild article and it worked for me (screenshot attached), although I admit I'm blocking a lot of content in that page, so if our blocking strategies are different, the result also could be different.

Thank you very much. The problem is that Firefox prevents the page from connecting to translate.googleusercontent.com . That's why I changed the value of accessibility.blockautorefresh in about: config to false as your suggestion at https://support.mozilla.org/en-US/questions/1178877. It solved almost the whole problem for me. There is yet a site https://www.thewindowsclub.com/ that when I am trying to translate, I get a message "The page is invalid upload. There was an error connecting to translate.googleusercontent.com". Other pages I can translate now.

               I did what you wrote in section 3 and it works for me too. Thank you very much.
more options

3rd one (inject script) worked.. thanks I don't understand why firefox is not adding any auto translate feature. Atleast they could add google translate. All chromium based browser use this. Not sure what's the challenge :(