X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Styles within pages are cached and don't reload. How not to cache styles in local pages?

Kuphostiwe

When developing an html or svg file I repeat editing content and style information and reload the file in Firefox. When editing styles I can't save them notifying cache. When editing content in external editor and reloading file all style changes are lost. However when editing styles in external editor, I can't force to reload them without deleting cache in general and when continuing to edit styles in Firefox all previously lost changes are lost on locally stored file as well. So how can I prevent Firefox from caching style information contained in local html or svg files?

When developing an html or svg file I repeat editing content and style information and reload the file in Firefox. When editing styles I can't save them notifying cache. When editing content in external editor and reloading file all style changes are lost. However when editing styles in external editor, I can't force to reload them without deleting cache in general and when continuing to edit styles in Firefox all previously lost changes are lost on locally stored file as well. So how can I prevent Firefox from caching style information contained in local html or svg files?

Isisombululo esikhethiwe

I think this solution is better for solving the cache issue within a single page:

  1. Open the developer toolbox (F12).
  2. Click the settings button (three dots near the top right).
  3. Scroll down to the Advanced settings on the bottom right.
  4. Check the option "Disable Cache (when toolbox is open)".
  5. Refresh the page.

Also try Shift + Ctrl + R.

Funda le mpendulo ngokuhambisana nalesi sihloko 0
Isicaphuno

Eminye Imininingwane Yohlelo

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (X11; Linux x86_64; rv:69.0) Gecko/20100101 Firefox/69.0

Eminye Imininingwane

jscher2000
  • Top 10 Contributor
8773 izisombululo 71719 izimpendulo
Kuphostiwe

Impendulo Ewusizo

Hi Vollbracht, as far as I can tell, Firefox's cache settings don't distinguish different types of files. You could temporarily disable the disk cache and see whether that helps:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box above the list, type or paste cache and pause while the list is filtered

(3) Double-click the browser.cache.disk.enable preference to switch the value from true to false

Does that make it easier? More difficult?

Hi Vollbracht, as far as I can tell, Firefox's cache settings don't distinguish different types of files. You could temporarily disable the disk cache and see whether that helps: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button accepting the risk. (2) In the search box above the list, type or paste '''cache''' and pause while the list is filtered (3) Double-click the '''browser.cache.disk.enable''' preference to switch the value from true to false Does that make it easier? More difficult?
Ingabe lokhu kube usizo kuwena? 1
Isicaphuno

Umnikazi wombuzo

This is a good work around - at least when in a longer development session. Thank you! But the described behavior of Firefox should merely be regarded as a bug.

A solution would be, never to cache anything coming with local files. This should be default behavior any how. A solution would be to reload every style for every reloaded page. This should be default behavior as well as even complex css are a couple of bits only. An other solution would be never to cache different file content separately.

I don't know whether all of these solutions are realistic as styles are to be merged cascading. What can I do to follow up any of them?

This is a good work around - at least when in a longer development session. Thank you! But the described behavior of Firefox should merely be regarded as a bug. A solution would be, never to cache anything coming with local files. This should be default behavior any how. A solution would be to reload every style for every reloaded page. This should be default behavior as well as even complex css are a couple of bits only. An other solution would be never to cache different file content separately. I don't know whether all of these solutions are realistic as styles are to be merged cascading. What can I do to follow up any of them?
Ingabe lokhu kube usizo kuwena?
Isicaphuno
jscher2000
  • Top 10 Contributor
8773 izisombululo 71719 izimpendulo
Kuphostiwe

Impendulo Ewusizo

Hmm, did that help on yours?

When I search the Disk cache page of about:cache (very slow loading 15000+ entries), there are extremely few file:// entries in there (only one after loading a few files). So I'm not sure what's going on.

(I habitually reload pages bypassing the cache -- Ctrl+Shift+r -- so I haven't noticed sticky style sheets from local files.)

Hmm, did that help on yours? When I search the Disk cache page of about:cache ''(very slow loading 15000+ entries)'', there are extremely few file:// entries in there (only one after loading a few files). So I'm not sure what's going on. (I habitually reload pages bypassing the cache -- Ctrl+Shift+r -- so I haven't noticed sticky style sheets from local files.)
Ingabe lokhu kube usizo kuwena? 1
Isicaphuno
FranciscoJS12 1 izisombululo 1 izimpendulo
Kuphostiwe

Isisombululo Esikhethiwe

I think this solution is better for solving the cache issue within a single page:

  1. Open the developer toolbox (F12).
  2. Click the settings button (three dots near the top right).
  3. Scroll down to the Advanced settings on the bottom right.
  4. Check the option "Disable Cache (when toolbox is open)".
  5. Refresh the page.

Also try Shift + Ctrl + R.

I think this solution is better for solving the cache issue within a single page: # Open the developer toolbox (F12). # Click the settings button (three dots near the top right). # Scroll down to the Advanced settings on the bottom right. # Check the option "Disable Cache (when toolbox is open)". # Refresh the page. Also try Shift + Ctrl + R.

Okulungisiwe ngu FranciscoJS12

Ingabe lokhu kube usizo kuwena?
Isicaphuno
Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.