X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Youtube videos not playing on firefox quantum on Ubuntu 18.04

Kuphostiwe

I am unable to play youtube videos on firefox Quantum, version 65.0(64 bit). I have a ubuntu 18.04 os. I tried disabling all add ons and starting firefox on safe mode, but none of that has worked.

I am getting the message: "your browser doesn't currently recognise any of the video formats available" Click here to visit our frequently asked questions about HTML5. Clicking on the link tells me that mozilla doesn't support H.264 and MSE&H.264.

I am unable to play youtube videos on firefox Quantum, version 65.0(64 bit). I have a ubuntu 18.04 os. I tried disabling all add ons and starting firefox on safe mode, but none of that has worked. I am getting the message: "your browser doesn't currently recognise any of the video formats available" Click here to visit our frequently asked questions about HTML5. Clicking on the link tells me that mozilla doesn't support H.264 and MSE&H.264.
Isicaphuno

Eminye Imininingwane Yohlelo

Isisebenziso

  • Firefox 65.0
  • Umsebenzisi oyi-ejenti: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:65.0) Gecko/20100101 Firefox/65.0
  • I-URL Yokweseka: https://support.mozilla.org/1/firefox/65.0/Linux/en-US/

Izandiso

  • Adblock Plus - free ad blocker 3.4.3 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}) (Akusebenzi)
  • Night Mode Pro 0.2.8 ({862f1187-5a4d-4b5c-b211-c5aea8a5c017}) (Akusebenzi)
  • YouTube High Definition 63.1.5 ({7b1bf0b6-a1b9-42b0-b75d-252036438bdc}) (Akusebenzi)

I-Javascript

  • incrementalGCEnabled: True

Imidwebo

  • adapterDescription: Intel Open Source Technology Center -- Mesa DRI Intel(R) HD Graphics 5500 (Broadwell GT2)
  • adapterDeviceID: Mesa DRI Intel(R) HD Graphics 5500 (Broadwell GT2)
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: Intel Open Source Technology Center
  • contentUsesTiling: False
  • crashGuards: []
  • driverDate:
  • driverVersion: 3.0 Mesa 18.2.2
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'blocked', u'description': u'Compositing', u'log': [{u'status': u'blocked', u'message': u'Acceleration blocked by platform', u'type': u'default'}, {u'status': u'blocked', u'message': u'Acceleration blocked by safe-mode', u'type': u'runtime'}], u'name': u'HW_COMPOSITING'}, {u'status': u'unavailable', u'description': u'OpenGL Compositing', u'log': [{u'status': u'unavailable', u'message': u'Hardware compositing is disabled', u'type': u'default'}], u'name': u'OPENGL_COMPOSITING'}, {u'status': u'unavailable', u'description': u'WebRender', u'log': [{u'status': u'opt-in', u'message': u'WebRender is an opt-in feature', u'type': u'default'}, {u'status': u'unavailable', u'message': u'Safe-mode is enabled', u'type': u'runtime'}], u'name': u'WEBRENDER'}, {u'status': u'blocked', u'description': u'WebRender qualified', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'blocked', u'message': u'No qualified hardware', u'type': u'env'}], u'name': u'WEBRENDER_QUALIFIED'}, {u'status': u'blocked', u'description': u'Off Main Thread Painting', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'blocked', u'message': u'OMTP blocked by safe-mode', u'type': u'runtime'}], u'name': u'OMTP'}]}
  • info: {u'ApzWheelInput': 1, u'ApzDragInput': 1, u'ApzKeyboardInput': 1, u'CairoUseXRender': 0, u'ApzAutoscrollInput': 1, u'AzureFallbackCanvasBackend': u'none', u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'skia', u'AzureContentBackend': u'skia'}
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • offMainThreadPaintEnabled: False
  • offMainThreadPaintWorkerCount: 0
  • usesTiling: False
  • webgl1DriverExtensions: -
  • webgl1Extensions: -
  • webgl1Renderer: WebGL is currently disabled.
  • webgl1Version: -
  • webgl1WSIInfo: -
  • webgl2DriverExtensions: -
  • webgl2Extensions: -
  • webgl2Renderer: WebGL is currently disabled.
  • webgl2Version: -
  • webgl2WSIInfo: -
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic
  • windowUsingAdvancedLayers: False

Okuthandwayo Okulungisiwe

Misc

  • Umsebenzisi JS: Cha
  • Ukufinyeleleka: Cha
WestEnd
  • Top 10 Contributor
59 izisombululo 4821 izimpendulo

What is the link?

What is the link?
Ingabe lokhu kube usizo kuwena? 0
Isicaphuno
James
  • Top 25 Contributor
  • Moderator
1577 izisombululo 11030 izimpendulo

astik159 said

I am unable to play youtube videos on firefox Quantum, version 65.0(64 bit). I have a ubuntu 18.04 os. I tried disabling all add ons and starting firefox on safe mode, but none of that has worked. I am getting the message: "your browser doesn't currently recognise any of the video formats available" Click here to visit our frequently asked questions about HTML5. Clicking on the link tells me that mozilla doesn't support H.264 and MSE&H.264.

You likely do not have the FFmpeg package installed that provides the codecs for HTML5 players to use in Firefox. This will cover the H.264 and MSE&H.264

With the various flavors of Ubuntu you may also find the FFmpeg in Ubuntu Restricted Extras for example. https://help.ubuntu.com/community/RestrictedFormats

A number of packages like FFmpeg may not be installed during the Linux OS install due to patent and copyright restrictions.

''astik159 [[#question-1250907|said]]'' <blockquote> I am unable to play youtube videos on firefox Quantum, version 65.0(64 bit). I have a ubuntu 18.04 os. I tried disabling all add ons and starting firefox on safe mode, but none of that has worked. I am getting the message: "your browser doesn't currently recognise any of the video formats available" Click here to visit our frequently asked questions about HTML5. Clicking on the link tells me that mozilla doesn't support H.264 and MSE&H.264. </blockquote> You likely do not have the FFmpeg package installed that provides the codecs for HTML5 players to use in Firefox. This will cover the H.264 and MSE&H.264 With the various flavors of Ubuntu you may also find the FFmpeg in Ubuntu Restricted Extras for example. https://help.ubuntu.com/community/RestrictedFormats A number of packages like FFmpeg may not be installed during the Linux OS install due to patent and copyright restrictions.

Okulungisiwe ngu James

Ingabe lokhu kube usizo kuwena?
Isicaphuno
James
  • Top 25 Contributor
  • Moderator
1577 izisombululo 11030 izimpendulo

WestEnd said

What is the link?

The OP was referring to https://www.youtube.com/html5/

''WestEnd [[#answer-1199806|said]]'' <blockquote> What is the link? </blockquote> The OP was referring to https://www.youtube.com/html5/
Ingabe lokhu kube usizo kuwena?
Isicaphuno
James
  • Top 25 Contributor
  • Moderator
1577 izisombululo 11030 izimpendulo

@astik159, no reply from you yet so is it fixed now or?

@astik159, no reply from you yet so is it fixed now or?
Ingabe lokhu kube usizo kuwena?
Isicaphuno
Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.