X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

I am unable to add an extension to the toolbar

Kuphostiwe

I have added https://addons.mozilla.org/en-US/firefox/addon/gfycat-click-to-gif/

It shows up in the Extensions section under "about:addons" and it is enabled. However in my toolbar, there is no icon for it and therefore I cannot use it. I've tried using the "Customize" feature but none of my extensions show up there, so I cannot drag them to the toolbar.

I would attach screenshots, but even that isn't working on this support page form.

I have added https://addons.mozilla.org/en-US/firefox/addon/gfycat-click-to-gif/ It shows up in the Extensions section under "about:addons" and it is enabled. However in my toolbar, there is no icon for it and therefore I cannot use it. I've tried using the "Customize" feature but none of my extensions show up there, so I cannot drag them to the toolbar. I would attach screenshots, but even that isn't working on this support page form.

Isisombululo esikhethiwe

Ah, if they are already in the toolbar, then they dont show up in "Customize". I have no problems now. All good.

Funda le mpendulo ngokuhambisana nalesi sihloko 0

Eminye Imininingwane Yohlelo

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:63.0) Gecko/20100101 Firefox/63.0

Eminye Imininingwane

Umnikazi wombuzo

Nevermind, the extension showed up in the URL bar, right next to Pocket and other icons. Kind of confusing that some extensions can show up in the URL bar, and others to the right in the toolbar..

Nevermind, the extension showed up in the URL bar, right next to Pocket and other icons. Kind of confusing that some extensions can show up in the URL bar, and others to the right in the toolbar..
FredMcD
  • Top 10 Contributor
4224 izisombululo 58972 izimpendulo
Kuphostiwe

drewgbarnes said

. . . . but none of my extensions show up

None of them? Are they enabled in the Add-ons Manager?

It’s possible that there is a problem with the file(s) that store the extensions registry.

Type about:support in the address bar and press enter.

Under the page logo on the left side, you will see Application Basics. Under this find Profile Folder. To its right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Linux: Under the page logo on the left side, you will see Application Basics. Under this find Profile Directory. To its right press the button Open Directory.

Delete all extensions* files and compatibility.ini in the Firefox profile folder to reset the extensions registry.

New files will be created when required.

After, restart Firefox.

See "Corrupt extension files":

''drewgbarnes [[#question-1239819|said]]'' <blockquote> . . . . but none of my extensions show up </blockquote> None of them? Are they enabled in the Add-ons Manager? It’s possible that there is a problem with the file(s) that store the extensions registry. Type '''about:support''' in the address bar and press enter. Under the page logo on the left side, you will see '''Application Basics. ''' Under this find '''Profile Folder. ''' To its right press the button '''Show Folder. ''' This will open your file browser to the current Firefox profile. Now '''Close Firefox. ''' '''Linux: ''' Under the page logo on the left side, you will see '''Application Basics.''' Under this find '''Profile Directory. ''' To its right press the button '''Open Directory. ''' Delete all '''extensions*''' files and '''compatibility.ini''' in the Firefox profile folder to reset the extensions registry. *https://support.mozilla.org/kb/Profiles New files will be created when required. After, restart Firefox. See "Corrupt extension files": *http://kb.mozillazine.org/Unable_to_install_themes_or_extensions
FredMcD
  • Top 10 Contributor
4224 izisombululo 58972 izimpendulo
Kuphostiwe

You will have to approve the updating one last time.

You will have to approve the updating one last time.

Umnikazi wombuzo

FredMcD said

Delete all extensions* files and compatibility.ini in the Firefox profile folder to reset the extensions registry.

Does this mean all files starting with `extensions*`, and not the folder named "extensions"? Or both? Wording could be more clear here.

I removed compatibility.ini and the only file named "extensions.*" (don't recall the file type), and started firefox again, but the extensions do not show up in Customize.

''FredMcD [[#answer-1170980|said]]'' <blockquote> Delete all '''extensions*''' files and '''compatibility.ini''' in the Firefox profile folder to reset the extensions registry. </blockquote> Does this mean all files starting with `extensions*`, and not the folder named "extensions"? Or both? Wording could be more clear here. I removed compatibility.ini and the only file named "extensions.*" (don't recall the file type), and started firefox again, but the extensions do not show up in Customize.

Isisombululo Esikhethiwe

Ah, if they are already in the toolbar, then they dont show up in "Customize". I have no problems now. All good.

Ah, if they are already in the toolbar, then they dont show up in "Customize". I have no problems now. All good.
FredMcD
  • Top 10 Contributor
4224 izisombululo 58972 izimpendulo
Kuphostiwe

Good to hear. Well done.

drewgbarnes said

Does this mean all files starting with `extensions*`, and not the folder named "extensions"?

Just the files. Not the folder.

Good to hear. Well done. ''drewgbarnes [[#answer-1170984|said]]'' <blockquote> Does this mean all files starting with `extensions*`, and not the folder named "extensions"? </blockquote> Just the files. Not the folder.